[PATCH] gnu: ruby-rubocop-ast: Update to 1.2.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Björn Höfling
  • Leo Famulari
  • Tomás Ortín Fernández
Owner
unassigned
Submitted by
Tomás Ortín Fernández
Severity
normal
T
T
Tomás Ortín Fernández wrote on 27 Nov 2020 23:22
(address . guix-patches@gnu.org)
42cadfd1-f719-ac23-924b-c964775dad1d@mailbox.org
* gnu/packages/ruby.scm (ruby-rubocop-ast): Update to 1.2.0.
---
gnu/packages/ruby.scm | 25 +++++--------------------
1 file changed, 5 insertions(+), 20 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ae2da01f63..fc69f4db05 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6823,32 +6823,17 @@ inspired by the Sinatra microframework style of specifying actions:
(define-public ruby-rubocop-ast
(package
(name "ruby-rubocop-ast")
- (version "0.3.0")
+ (version "1.2.0")
(source
(origin
- (method git-fetch) ;no test suite in distributed gem
- (uri (git-reference
- (url "https://github.com/rubocop-hq/rubocop-ast")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (rubygems-uri "rubocop-ast" version))
(sha256
(base32
- "1ycf6qcj8nbzk2js72priim4642lkn56w5kbny1nlryjkckxgm04"))))
+ "0q0kdi89ad7dd1xmzrdf5ikk32bllzr68hf4x8fd7azcv5jnch2l"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'disable-bundler
- (lambda _
- (substitute* "Rakefile"
- (("Bundler\\.setup.*") "nil\n"))
- #t))
- (replace 'replace-git-ls-files
- (lambda _
- (substitute* "rubocop-ast.gemspec"
- (("`git ls-files(.*)`" _ files)
- (format #f "`find ~a -type f| sort`" files)))
- #t)))))
+ '(#:tests? #f)) ; tests not included in gem
(native-inputs
`(("ruby-bump" ,ruby-bump)
("ruby-rspec" ,ruby-rspec)))
L
L
Leo Famulari wrote on 5 Dec 2020 01:01
(name . Tomás Ortín Fernández via Guix-patches via)(address . guix-patches@gnu.org)(address . 44913@debbugs.gnu.org)
X8rN3TkB0P+CiKbW@jasmine.lan
On Fri, Nov 27, 2020 at 11:22:44PM +0100, Tom�s Ort�n Fern�ndez via Guix-patches via wrote:
Toggle quote (2 lines)
> * gnu/packages/ruby.scm (ruby-rubocop-ast): Update to 1.2.0.

Thanks!

Toggle quote (30 lines)
> (source
> (origin
> - (method git-fetch) ;no test suite in distributed gem
> - (uri (git-reference
> - (url "https://github.com/rubocop-hq/rubocop-ast")
> - (commit (string-append "v" version))))
> - (file-name (git-file-name name version))
> + (method url-fetch)
> + (uri (rubygems-uri "rubocop-ast" version))
> (sha256
> (base32
> - "1ycf6qcj8nbzk2js72priim4642lkn56w5kbny1nlryjkckxgm04"))))
> + "0q0kdi89ad7dd1xmzrdf5ikk32bllzr68hf4x8fd7azcv5jnch2l"))))
> (build-system ruby-build-system)
> (arguments
> - `(#:test-target "spec"
> - #:phases (modify-phases %standard-phases
> - (add-after 'unpack 'disable-bundler
> - (lambda _
> - (substitute* "Rakefile"
> - (("Bundler\\.setup.*") "nil\n"))
> - #t))
> - (replace 'replace-git-ls-files
> - (lambda _
> - (substitute* "rubocop-ast.gemspec"
> - (("`git ls-files(.*)`" _ files)
> - (format #f "`find ~a -type f| sort`" files)))
> - #t)))))
> + '(#:tests? #f)) ; tests not included in gem

The commit message should describe the changes to the code.

For example, I might write it this way:

------
gnu: ruby-rubocop-ast: Update to 1.2.0.

* gnu/packages/ruby.scm (ruby-rubocop-ast): Update to 1.2.0.
[source]: Fetch source from rubygems.
[arguments]: Remove obsolete 'disable-bundler' phase. Skip the test suite.
------

This helps communicate your intentions to reviewers (and everyone else).

For example, why does the patch remove the 'disable-bundler' phase? If that
phase is no longer needed, it helps to describe it as obsolete in the commit
message.

The code comment about why the tests are skipped is really useful, for the same
reason. But we can't add comments about code that is removed :)

Does that make sense? Can you send a revised patch with a complete commit
message? It's fine to copy what I wrote if it is accurate.
B
B
Björn Höfling wrote on 25 Feb 2021 23:53
(name . Tomás Ortín Fernández via Guix-patches via)(address . guix-patches@gnu.org)
20210225235337.1bac6b4a@alma-ubu.fritz.box
On Fri, 27 Nov 2020 23:22:44 +0100
Tomás Ortín Fernández via Guix-patches via <guix-patches@gnu.org> wrote:

Toggle quote (2 lines)
> * gnu/packages/ruby.scm (ruby-rubocop-ast): Update to 1.2.0.

This package was updated to 1.4.1 in commit

6e3a85192ca48a749858c8c7f128c5ec59c2ff89

Closing this patch.

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYDgqcQAKCRC/KGy2WT5f
/S8PAJsEIQLBsOyu18a4wgCs9XDjN0AzIQCeNyv4MaHnb0nv41KGuYtazPSGa2M=
=iove
-----END PGP SIGNATURE-----


?