[PATCH] gnu: Add emacs-next-pgtk

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 19 Nov 2020 15:46
Add Emacs for Wayland
(address . guix-patches@gnu.org)
CABrWRW0_PWDYbc2VnOcyOC-KtNneGB5H3VX1kgP+4Rs=Zwr4Sw@mail.gmail.com
Add a package for Emacs fork, which uses pure-gtk3.

It works natively with Wayland, but also works for X11.

Tested on sway and i3.

--
Best regards,
Andrew Tropin
From 16af8a60f7f684a364dc1105ad00ac7f4cfc26da Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Thu, 19 Nov 2020 17:36:11 +0300
Subject: [PATCH] gnu: Add emacs-next-pgtk

* gnu/packages/emacs.scm (emacs-next-pgtk): New variable.
---
gnu/packages/emacs.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4f5a67093c..52a02bca34 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -313,6 +313,38 @@ languages.")
(variable "INFOPATH")
(files '("share/info"))))))))
+(define-public emacs-next-pgtk
+ (let ((commit "896ac63a25dd072402fea866b42efc4277546cb8")
+ (revision "0"))
+ (package/inherit emacs-next
+ (name "emacs-next-pgtk")
+ (synopsis "The fork of extensible, customizable,
+self-documenting text editor (with pgtk toolkit and xwidgets
+support)")
+ (description "This is an unofficial Emacs fork build with
+pure-gtk to work natively on Wayland. In addition to that xwidgets
+also enabled and work without glitches even on X server.")
+ (version (git-version "28.0.50" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/masm11/emacs")
+ (commit commit)))
+ (sha256
+ (base32
+ "0j11sjmhlb550fgqnjrrbqlqwf65n16g5666y0z2pky1xz5xzg5i"))))
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments emacs-next)
+ ((#:configure-flags flags ''())
+ `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
+ (propagated-inputs `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("glib-networking" ,glib-networking)))
+ (inputs
+ `(("webkitgtk" ,webkitgtk)
+ ,@(package-inputs emacs-next))))))
+
(define-public emacs-minimal
;; This is the version that you should use as an input to packages that just
;; need to byte-compile .el files.
--
2.25.4
A
A
Andrew Tropin wrote on 23 Nov 2020 11:13
[PATCH] gnu: Add emacs-next-pgtk
(address . 44738@debbugs.gnu.org)
CABrWRW0W2iwNEDMCSTUd7Ur9QU0a3axG0ZJTj0GbpQNstipx1Q@mail.gmail.com
Updated the revision, also changed home-page to fork's sources.

--
Best regards,
Andrew Tropin
From 168310a375b13081b73ad6ddeb26100bc7bcb61c Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Thu, 19 Nov 2020 17:36:11 +0300
Subject: [PATCH] gnu: Add emacs-next-pgtk

* gnu/packages/emacs.scm (emacs-next-pgtk): New variable.
---
gnu/packages/emacs.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4f5a67093c..957338af5d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -313,6 +313,40 @@ languages.")
(variable "INFOPATH")
(files '("share/info"))))))))
+(define-public emacs-next-pgtk
+ (let ((commit "3df4ca451d41a5f1036713277ef55ca9734c6fa7")
+ (revision "0"))
+ (package/inherit emacs-next
+ (name "emacs-next-pgtk")
+ (version (git-version "28.0.50" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/masm11/emacs")
+ (commit commit)))
+ (sha256
+ (base32
+ "1c677c97b9avhlzysg09cvf6bd69iz41ggppnszw8chhphk3knfc"))))
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments emacs-next)
+ ((#:configure-flags flags ''())
+ `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
+ (propagated-inputs `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("glib-networking" ,glib-networking)))
+ (inputs
+ `(("webkitgtk" ,webkitgtk)
+ ,@(package-inputs emacs-next)))
+
+ (home-page "https://github.com/masm11/emacs")
+ (synopsis "The fork of extensible, customizable,
+self-documenting text editor (with pgtk toolkit and xwidgets
+support)")
+ (description "This is an unofficial Emacs fork build with
+pure-gtk to work natively on Wayland. In addition to that xwidgets
+also enabled and work without glitches even on X server."))))
+
(define-public emacs-minimal
;; This is the version that you should use as an input to packages that just
;; need to byte-compile .el files.
--
2.25.4
A
A
Andrew Tropin wrote on 23 Nov 2020 11:23
Retitle
(address . control@debbugs.gnu.org)
CABrWRW2OBtNgvgNxak=qQ+d7rT9jGdV2b6rw9PLjOP+n0QSeCA@mail.gmail.com
retitle 44738 [PATCH] gnu: Add emacs-next-pgtk

--
Best regards,
Andrew Tropin
L
L
Ludovic Courtès wrote on 26 Nov 2020 23:13
Re: [bug#44738] [PATCH] gnu: Add emacs-next-pgtk
(name . Andrew Tropin)(address . andrew@trop.in)(address . 44738-done@debbugs.gnu.org)
87y2inzs09.fsf@gnu.org
Hi Andrew,

Andrew Tropin <andrew@trop.in> skribis:

Toggle quote (7 lines)
> From 168310a375b13081b73ad6ddeb26100bc7bcb61c Mon Sep 17 00:00:00 2001
> From: Andrew Tropin <andrew@trop.in>
> Date: Thu, 19 Nov 2020 17:36:11 +0300
> Subject: [PATCH] gnu: Add emacs-next-pgtk
>
> * gnu/packages/emacs.scm (emacs-next-pgtk): New variable.

As a welcome gift ;-), I applied the following cosmetic changes for you,
most of which were suggested by ‘guix lint’.

Thanks!

Ludo’.
Toggle diff (53 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 957338af5d..6fb323deaf 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -321,31 +321,29 @@ languages.")
(version (git-version "28.0.50" revision commit))
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/masm11/emacs")
- (commit commit)))
- (sha256
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/masm11/emacs")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
(base32
"1c677c97b9avhlzysg09cvf6bd69iz41ggppnszw8chhphk3knfc"))))
(arguments
- (substitute-keyword-arguments
- (package-arguments emacs-next)
- ((#:configure-flags flags ''())
- `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
- (propagated-inputs `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("glib-networking" ,glib-networking)))
+ (substitute-keyword-arguments (package-arguments emacs-next)
+ ((#:configure-flags flags ''())
+ `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
+ (propagated-inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("glib-networking" ,glib-networking)))
(inputs
`(("webkitgtk" ,webkitgtk)
- ,@(package-inputs emacs-next)))
-
+ ,@(package-inputs emacs-next)))
(home-page "https://github.com/masm11/emacs")
- (synopsis "The fork of extensible, customizable,
-self-documenting text editor (with pgtk toolkit and xwidgets
-support)")
- (description "This is an unofficial Emacs fork build with
-pure-gtk to work natively on Wayland. In addition to that xwidgets
-also enabled and work without glitches even on X server."))))
+ (synopsis "Emacs text editor with @code{pgtk} and @code{xwidgets} support")
+ (description "This is an unofficial Emacs fork build with a pure-GTK
+graphical toolkit to work natively on Wayland. In addition to that, xwidgets
+also enabled and works without glitches even on X server."))))
(define-public emacs-minimal
;; This is the version that you should use as an input to packages that just
Closed
A
A
Andrew Tropin wrote on 27 Nov 2020 08:12
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 44738-done@debbugs.gnu.org)
CABrWRW0AvtH57n3BQkAdGTd5FYux=XG=1gkQoAWVS1zn+8EaRA@mail.gmail.com
Thanks a lot for improvements and for applying the patch too!

Will setup guix dev environment next week and will start using lint)

On Fri, Nov 27, 2020 at 1:13 AM Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (21 lines)
>
> Hi Andrew,
>
> Andrew Tropin <andrew@trop.in> skribis:
>
> > From 168310a375b13081b73ad6ddeb26100bc7bcb61c Mon Sep 17 00:00:00 2001
> > From: Andrew Tropin <andrew@trop.in>
> > Date: Thu, 19 Nov 2020 17:36:11 +0300
> > Subject: [PATCH] gnu: Add emacs-next-pgtk
> >
> > * gnu/packages/emacs.scm (emacs-next-pgtk): New variable.
>
> As a welcome gift ;-), I applied the following cosmetic changes for you,
> most of which were suggested by ‘guix lint’.
>
> Thanks!
>
> Ludo’.
>


--
Best regards,
Andrew Tropin
Closed
L
L
Ludovic Courtès wrote on 27 Nov 2020 10:59
(name . Andrew Tropin)(address . andrew@trop.in)(address . 44738-done@debbugs.gnu.org)
87lfenw25j.fsf@gnu.org
Andrew Tropin <andrew@trop.in> skribis:

Toggle quote (4 lines)
> Thanks a lot for improvements and for applying the patch too!
>
> Will setup guix dev environment next week and will start using lint)

Awesome. You can also take a look at the check list at

Thanks,
Ludo’.
Closed
?