[PATCH] Miscellaneous R packages

  • Done
  • quality assurance status badge
Details
One participant
  • Lars-Dominik Braun
Owner
unassigned
Submitted by
Lars-Dominik Braun
Severity
normal
L
L
Lars-Dominik Braun wrote on 16 Nov 2020 14:15
(address . guix-patches@gnu.org)
20201116131540.GB4512@zpidnp36
Hi,

I’ve imported several R packages from CRAN using the importer. Descriptions
have been edited slightly.

Cheers,
Lars

--
Lars-Dominik Braun
Wissenschaftlicher Mitarbeiter/Research Associate

www.leibniz-psychology.org
ZPID - Leibniz-Institut für Psychologie /
ZPID - Leibniz Institute for Psychology
Universitätsring 15
D-54296 Trier - Germany
Tel.: +49–651–201-4964
From 90f282cc5a9fb369cbb650f847917ccf956e8276 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 12:56:25 +0100
Subject: [PATCH 1/9] gnu: Add r-prereg.

* gnu/packages/cran.scm (r-prereg): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 64e139c243..eb8ce230d4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24657,3 +24657,26 @@ orthogonal coordinate systems: cartesian, polar, spherical, cylindrical,
parabolic or user defined by custom scale factors.")
(license license:gpl3)))
+(define-public r-prereg
+ (package
+ (name "r-prereg")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "prereg" version))
+ (sha256
+ (base32
+ "1jhlgp7ajq6mx7gn4kf3b7wqzs3v0678pa1r6p4mgvvynic8rnqj"))))
+ (properties `((upstream-name . "prereg")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rmarkdown" ,r-rmarkdown)))
+ (home-page "https://github.com/crsh/prereg")
+ (synopsis
+ "R Markdown Templates to Preregister Scientific Studies")
+ (description
+ "This package provides a collection of templates to author
+preregistration documents for scientific studies in PDF format.")
+ (license license:gpl3)))
+
--
2.25.1
From 87219fced97d6359ac43017804347e79b3d2b0d1 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 12:58:22 +0100
Subject: [PATCH 2/9] gnu: Add r-metafor.

* gnu/packages/cran.scm (r-metafor): New variable.
---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index eb8ce230d4..59f018c123 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24680,3 +24680,40 @@ parabolic or user defined by custom scale factors.")
preregistration documents for scientific studies in PDF format.")
(license license:gpl3)))
+(define-public r-metafor
+ (package
+ (name "r-metafor")
+ (version "2.4-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "metafor" version))
+ (sha256
+ (base32
+ "1b599fxk7s0brkchmx698fr5k4g1kzkia2rnlvhg349ffs5nfjmn"))))
+ (properties `((upstream-name . "metafor")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix) ("r-nlme" ,r-nlme)))
+ (home-page
+ "https://cran.r-project.org/web/packages/metafor")
+ (synopsis "Meta-Analysis Package for R")
+ (description
+ "This package provides a comprehensive collection of functions for
+conducting meta-analyses in R. The package includes functions to calculate
+various effect sizes or outcome measures, fit fixed-, random-, and
+mixed-effects models to such data, carry out moderator and meta-regression
+analyses, and create various types of meta-analytical plots (e.g., forest,
+funnel, radial, L'Abbe, Baujat, GOSH plots). For meta-analyses of binomial and
+person-time data, the package also provides functions that implement
+specialized methods, including the Mantel-Haenszel method, Peto's method, and a
+variety of suitable generalized linear (mixed-effects) models (i.e.,
+mixed-effects logistic and Poisson regression models). Finally, the package
+provides functionality for fitting meta-analytic multivariate/multilevel models
+that account for non-independent sampling errors and/or true effects (e.g., due
+to the inclusion of multiple treatment studies, multiple endpoints, or other
+forms of clustering). Network meta-analyses and meta-analyses accounting for
+known correlation structures (e.g., due to phylogenetic relatedness) can also
+be conducted.")
+ (license license:gpl2+)))
+
--
2.25.1
From 0b52713d2c0d9ea38c8d4120ec0a719949064e56 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 12:58:47 +0100
Subject: [PATCH 3/9] gnu: Add r-ez.

* gnu/packages/cran.scm (r-ez): New variable.
---
gnu/packages/cran.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 59f018c123..602eec8250 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24717,3 +24717,43 @@ known correlation structures (e.g., due to phylogenetic relatedness) can also
be conducted.")
(license license:gpl2+)))
+(define-public r-ez
+ (package
+ (name "r-ez")
+ (version "4.4-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ez" version))
+ (sha256
+ (base32
+ "0a58s94x576dfz7wcbivrr2hmdh5x1vy16zwkqp9fmdzqx38pagq"))))
+ (properties `((upstream-name . "ez")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-car" ,r-car)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-lme4" ,r-lme4)
+ ("r-mass" ,r-mass)
+ ("r-matrix" ,r-matrix)
+ ("r-mgcv" ,r-mgcv)
+ ("r-plyr" ,r-plyr)
+ ("r-reshape2" ,r-reshape2)
+ ("r-scales" ,r-scales)
+ ("r-stringr" ,r-stringr)))
+ (home-page "https://github.com/mike-lawrence/ez")
+ (synopsis "Easy Analysis and Visualization of Factorial Experiments")
+ (description
+ "Facilitates easy analysis of factorial experiments, including purely
+within-Ss designs (a.k.a. \"repeated measures\"), purely between-Ss designs,
+and mixed within-and-between-Ss designs. The functions in this package aim to
+provide simple, intuitive and consistent specification of data analysis and
+visualization. Visualization functions also include design visualization for
+pre-analysis data auditing, and correlation matrix visualization. Finally,
+this package includes functions for non-parametric analysis, including
+permutation tests and bootstrap resampling. The bootstrap function obtains
+predictions either by cell means or by more advanced/powerful mixed effects
+models, yielding predictions and confidence intervals that may be easily
+visualized at any level of the experiment's design.")
+ (license license:gpl2+)))
+
--
2.25.1
From f7c09f739c894b5e3894eab5f3c832d37cec3ad6 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 12:59:26 +0100
Subject: [PATCH 4/9] gnu: Add r-quantpsyc.

* gnu/packages/cran.scm (r-quantpsyc): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 602eec8250..4e4c6623e4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24757,3 +24757,25 @@ models, yielding predictions and confidence intervals that may be easily
visualized at any level of the experiment's design.")
(license license:gpl2+)))
+(define-public r-quantpsyc
+ (package
+ (name "r-quantpsyc")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "QuantPsyc" version))
+ (sha256
+ (base32
+ "1i9bh88r8zxndzjqsj14qw64gnvm5a9kvhjhzk3qsrvl3qzjgh93"))))
+ (properties `((upstream-name . "QuantPsyc")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-boot" ,r-boot) ("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/QuantPsyc/")
+ (synopsis "Quantitative Psychology Tools")
+ (description
+ "Contains functions useful for data screening, testing moderation,
+mediation and estimating power.")
+ (license license:gpl2+)))
+
--
2.25.1
From 00938f70c0e0dcf5303c7eb102e1b7e46813df23 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 13:00:06 +0100
Subject: [PATCH 5/9] gnu: Add r-visnetwork.

* gnu/packages/cran.scm (r-visnetwork): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e4c6623e4..7b6338df0f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24779,3 +24779,29 @@ visualized at any level of the experiment's design.")
mediation and estimating power.")
(license license:gpl2+)))
+(define-public r-visnetwork
+ (package
+ (name "r-visnetwork")
+ (version "2.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "visNetwork" version))
+ (sha256
+ (base32
+ "0854r9znpjd9iy6j5bgrn20vj13dhp606gs3b6iy0rhym71ks2sy"))))
+ (properties `((upstream-name . "visNetwork")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-magrittr" ,r-magrittr)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "http://datastorm-open.github.io/visNetwork/")
+ (synopsis "Network Visualization using vis.js Library")
+ (description
+ "This package provides an R interface to the vis.js JavaScript charting
+library. It allows an interactive visualization of networks.")
+ (license license:expat)))
+
--
2.25.1
From ecf9923d276b2a5e2889c1bab049fe6ffbf01957 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 13:01:13 +0100
Subject: [PATCH 6/9] gnu: Add r-diagrammer.

* gnu/packages/cran.scm (r-diagrammer): New variable.
---
gnu/packages/cran.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7b6338df0f..e567cc8c2b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24805,3 +24805,48 @@ mediation and estimating power.")
library. It allows an interactive visualization of networks.")
(license license:expat)))
+(define-public r-diagrammer
+ (package
+ (name "r-diagrammer")
+ (version "1.0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "DiagrammeR" version))
+ (sha256
+ (base32
+ "0gb7ccdrh7jlyqafdk8zs465ygczxxd25s05whn914in1994qkmy"))))
+ (properties `((upstream-name . "DiagrammeR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-downloader" ,r-downloader)
+ ("r-dplyr" ,r-dplyr)
+ ("r-glue" ,r-glue)
+ ("r-htmltools" ,r-htmltools)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-igraph" ,r-igraph)
+ ("r-influencer" ,r-influencer)
+ ("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-readr" ,r-readr)
+ ("r-rlang" ,r-rlang)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-scales" ,r-scales)
+ ("r-stringr" ,r-stringr)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-viridis" ,r-viridis)
+ ("r-visnetwork" ,r-visnetwork)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/rich-iannone/DiagrammeR")
+ (synopsis "Graph/Network Visualization")
+ (description
+ "Build graph/network structures using functions for stepwise addition
+and deletion of nodes and edges. Work with data available in tables for bulk
+addition of nodes, edges, and associated metadata. Use graph selections and
+traversals to apply changes to specific nodes or edges. A wide selection of
+graph algorithms allow for the analysis of graphs. Visualize the graphs and
+take advantage of any aesthetic properties assigned to nodes and edges.")
+ (license license:expat)))
+
--
2.25.1
From 6bf8cfb004441ae75e2ca93075ae7a1d0a9799aa Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 13:01:50 +0100
Subject: [PATCH 7/9] gnu: Add r-lavaanplot.

* gnu/packages/cran.scm (r-lavaanplot): New variable.
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e567cc8c2b..4a7c1535f4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24850,3 +24850,31 @@ graph algorithms allow for the analysis of graphs. Visualize the graphs and
take advantage of any aesthetic properties assigned to nodes and edges.")
(license license:expat)))
+(define-public r-lavaanplot
+ (package
+ (name "r-lavaanplot")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lavaanPlot" version))
+ (sha256
+ (base32
+ "01bx1snd3zhc8dmq0f407qhw2d00f6d38qpr791qc1mq5kr3d8qj"))))
+ (properties `((upstream-name . "lavaanPlot")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-diagrammer" ,r-diagrammer)
+ ("r-lavaan" ,r-lavaan)
+ ("r-stringr" ,r-stringr)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/alishinski/lavaanPlot")
+ (synopsis "Path Diagrams for Lavaan Models via DiagrammeR")
+ (description
+ "Plots path diagrams from models in lavaan using the plotting
+functionality from the DiagrammeR package. DiagrammeR provides nice path
+diagrams via Graphviz, and these functions make it easy to generate these
+diagrams from a lavaan path model without having to write the DOT language
+graph specification.")
+ (license license:gpl2+)))
+
--
2.25.1
From 3312c0c3754f62222dfe67733f8610aa6e7d687a Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 13:02:28 +0100
Subject: [PATCH 8/9] gnu: Add r-clubsandwich.

* gnu/packages/cran.scm (r-clubsandwich): New variable.
---
gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4a7c1535f4..0caff23582 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24878,3 +24878,36 @@ diagrams from a lavaan path model without having to write the DOT language
graph specification.")
(license license:gpl2+)))
+(define-public r-clubsandwich
+ (package
+ (name "r-clubsandwich")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "clubSandwich" version))
+ (sha256
+ (base32
+ "1q4kidxcarlazh9zaav6vdc7ixb3hdg3zh5kr6mwkm087gi05nw5"))))
+ (properties `((upstream-name . "clubSandwich")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-sandwich" ,r-sandwich)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/jepusto/clubSandwich")
+ (synopsis "Cluster-Robust (Sandwich) Variance Estimators with Small-Sample
+Corrections")
+ (description
+ "Provides several cluster-robust variance estimators (i.e., sandwich
+estimators) for ordinary and weighted least squares linear regression models,
+including the bias-reduced linearization estimator introduced by
+@url{http://www.statcan.gc.ca/pub/12-001-x/2002002/article/9058-eng.pdf, Bell
+and McCaffrey (2002)} and developed further by
+@url{DOI:10.1080/07350015.2016.1247004, Pustejovsky and Tipton (2017)}. The
+package includes functions for estimating the variance- covariance matrix and
+for testing single- and multiple- contrast hypotheses based on Wald test
+statistics. Tests of single regression coefficients use Satterthwaite or
+saddle-point corrections. Tests of multiple- contrast hypotheses use an
+approximation to Hotelling's T-squared distribution.")
+ (license license:gpl3)))
+
--
2.25.1
From dd2095db08802c6481903466b58866b2e987eb60 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Mon, 16 Nov 2020 13:03:16 +0100
Subject: [PATCH 9/9] gnu: Add r-puniform.

* gnu/packages/cran.scm (r-puniform): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0caff23582..caf8cfbfc1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24911,3 +24911,37 @@ saddle-point corrections. Tests of multiple- contrast hypotheses use an
approximation to Hotelling's T-squared distribution.")
(license license:gpl3)))
+(define-public r-puniform
+ (package
+ (name "r-puniform")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "puniform" version))
+ (sha256
+ (base32
+ "1y47y6s76pjvp10m8rvdh7y1iidjw96a4wrr920w0js3rn4fi1fz"))))
+ (properties `((upstream-name . "puniform")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-adgoftest" ,r-adgoftest)
+ ("r-metafor" ,r-metafor)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page
+ "https://cran.r-project.org/web/packages/puniform")
+ (synopsis
+ "Meta-Analysis Methods Correcting for Publication Bias")
+ (description
+ "This package provides meta-analysis methods that correct for publication
+bias and outcome reporting bias. Four methods and a visual tool are currently
+included in the package. The p-uniform method as described in
+@url{doi:10.1037/met0000025, van Assen and and van Aert and Wicherts (2015)},
+the p-uniform* method as described in @url{doi:10.31222/osf.io/zqjr9, van Aert
+and van Assen (2019)}, the hybrid method as described in
+@url{doi:10.3758/s13428-017-0967-6, van Aert and van Assen (2017)} and the
+Snapshot Bayesian Hybrid Meta-Analysis Method as described in
+@url{doi:10.1371/journal.pone.0175302, van Aert and van Assen (2018)}.")
+ (license license:gpl2+)))
+
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEEyk+M9DfXR4/aBV/UQhN3ARo3hEYFAl+ye3kACgkQQhN3ARo3
hEbUoQwAp8mpeA311sTdeFEd6BDbqoXEoXj9G3S8fUTOEarvcEt+wEJly4AP/GXG
Kbqu7Et0aNCYRdPHpMdzvgaovImLZGoWGqHZVaEynKzXoXFZYjSXHLsCTChwQcl7
vGseeKf1nCmq1N4C1BRB5ZaCVpbUko76rOncsv4VFvP5tZmWTp4e6GQBWZuXH7qE
Lc5GwNP0rVF5HFBJaGsHg5zjU6LCdWIL+qwrwEMSoroPmEA36iGbBgljVzgjBOMM
5xWiP3dPN0rSUzwubg6PPAKkdImR+PtOZK6/sF6RULpWwBOhmoW6URXtOOx1l+Q/
jG3IzMOsTR7+H4c7bMibmlvT9VppQr5yJyIaem4UbkbIUwIjgUAN0+/cuHH8QmtI
6tCW9U9F0wcCoPmhDmQzMWAfF/QlhJHpgoxgqHoJwDmfrzNQDB3AFrVtmKc3fWKU
WPonNcYIeipilRwmn5w+nZYOO1/TRyhvNybAvBIs+0JfZ6DxACEvwTgtAJ5tGvxk
xGHpUFV4
=du0z
-----END PGP SIGNATURE-----


L
L
Lars-Dominik Braun wrote on 10 Mar 2021 12:53
(address . 44683-done@debbugs.gnu.org)
20210310115343.GF2840@zpidnp36
This patchset is now obsolete, since some of them have been updated in the meantime.

--
Lars-Dominik Braun
Wissenschaftlicher Mitarbeiter/Research Associate

www.leibniz-psychology.org
ZPID - Leibniz-Institut für Psychologie /
ZPID - Leibniz Institute for Psychology
Universitätsring 15
D-54296 Trier - Germany
Tel.: +49–651–201-4964
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEEyk+M9DfXR4/aBV/UQhN3ARo3hEYFAmBIs0MACgkQQhN3ARo3
hEYjLgv9HF5nLGSkL8mBVGS6oldmt0PzGm22fMmuzHNvI3ZeQRYpvN6wBRS/1ACB
Qoo5hy3O4VphY4x5zhA1Zv4JPk/Hh1A/3VEe8N9AvYYK+H9x9/v6n5oiPZcV+1z4
Q75553cnbMGH7hQys3ptCuRi96BfpY+DXjRhK3Qcj3Z5OmVa2V4LsDep3lWZ/uU1
L5fnhhdL60jmaRK5mc2jty5L0CAEuSLIM1ulTRn0Lwb4HGe+gtXebZyRvOU2ekMs
u1V2PNT01kYePuRcfOVzw14zTZg7uCQMMAEmqTgRGK31Bxa3RUjSiIYDeLwZTpFl
hRU98wAT4UHc8uAIHuO0qMZ9ldWsoYsX0lVAq+IroH/D1BX1GT7/XclWvWgHbvRO
/Q+d/TQv4xDb4jIy0LxXwLOV1XogFzFF5rfeERpL6NnP2QQ3+GsGyjV8gvOnHiK6
ffIe083KaD/9ZgTTxTJNlchLqPf0t72SC954ditgpQK1ImJhqhoNbAX26xrOybb/
aTysAoBS
=buxJ
-----END PGP SIGNATURE-----


Closed
?