[PATCH] gnu: Add vimix-cursor-theme.

  • Open
  • quality assurance status badge
Details
2 participants
  • Zhu Zihao
  • Efraim Flashner
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 15 Nov 2020 06:37
(address . guix-patches@gnu.org)
86blfzgoyv.fsf@163.com

-----BEGIN PGP SIGNATURE-----

iQFJBAEBCAAzFiEE7NCVzXX6efyusptG1SOVn+xGFqYFAl+wvpgVHGFsbF9idXRf
bGFzdEAxNjMuY29tAAoJENUjlZ/sRhamBFEH/2C7/tU5XnSReYyi8sRLnOJX+Kxw
QLNzlieiux+QvycnN9Gf1tpsQ3kyIFL6MKt3cj4/jHsyD9FleqGAHNW8Os8ZVxzs
LbNr3tuoECposSFAyocjE+SyDsKn3KsM6UDlWGZTjJ6avmebnbLJyYocz2er/zxk
kwj7yBXZIpwyZCt4JGYHvL2d4R9+n6ZRtLe6bidQbddQJ7D2JqaEZu5PetOqdmBb
sRRwaQOJKREuax1+LuuCh3qDxLPME0kXVoxK+f7A2O1XQYTzo09MfWT1P6vPokDP
quaD3fV5BnCdvG3noaVFNS6v6WhuyLqBQQp8Ufz7aBFU2HA0+TE3m/jJhnI=
=g2/+
-----END PGP SIGNATURE-----

From e4268e914aa835f4bf61ad57c2023cc7d7553832 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sun, 15 Nov 2020 13:36:47 +0800
Subject: [PATCH] gnu: Add vimix-cursor-theme.

* gnu/packages/gnome-xyz.scm(vimix-cursor-theme): New variable.
---
gnu/packages/gnome-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 77b4aada6f..0f2a7d2465 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -123,6 +124,28 @@ which haven't been updated for some years. The new app icons are ported from
the Obsidian icon theme.")
(license license:gpl3)))
+(define-public vimix-cursor-theme
+ (package
+ (name "vimix-cursor-theme")
+ (version "2020-02-24")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vinceliuice/Vimix-cursors")
+ (commit version)))
+ (sha256 "0bij0x916lbxph28i3d4hz5l6mzk5fa68mf21jnl7y9rpxx07xsd")))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("dist/" "/share/icons/vimix-cursor/")
+ ("dist-white/" "/share/icons/vimix-white-cursor/"))))
+ (synopsis "Material design inspired cursor theme")
+ (description "Vimix-cursor-theme is a x-cursor theme inspired by Material
+design and based on capitaine-cursors.")
+ (home-page "https://github.com/vinceliuice/Vimix-cursors")
+ (license license:gpl3+)))
+
(define-public gnome-shell-extension-appindicator
(package
(name "gnome-shell-extension-appindicator")
--
2.29.2
--
Retrieve my PGP public key: https://meta.sr.ht/~citreu.pgp

Zihao
E
E
Efraim Flashner wrote on 18 Nov 2020 10:30
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 44652@debbugs.gnu.org)
20201118093016.GA987@E5400
Does it make sense to build the icons ourselves? We can either use
build.sh or re-implement it, it doesn't actually look that bad.

On Sun, Nov 15, 2020 at 01:37:28PM +0800, Zhu Zihao wrote:


Toggle quote (62 lines)
> From e4268e914aa835f4bf61ad57c2023cc7d7553832 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Sun, 15 Nov 2020 13:36:47 +0800
> Subject: [PATCH] gnu: Add vimix-cursor-theme.
>
> * gnu/packages/gnome-xyz.scm(vimix-cursor-theme): New variable.
> ---
> gnu/packages/gnome-xyz.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index 77b4aada6f..0f2a7d2465 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -7,6 +7,7 @@
> ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
> ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
> ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
> +;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -123,6 +124,28 @@ which haven't been updated for some years. The new app icons are ported from
> the Obsidian icon theme.")
> (license license:gpl3)))
>
> +(define-public vimix-cursor-theme
> + (package
> + (name "vimix-cursor-theme")
> + (version "2020-02-24")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/vinceliuice/Vimix-cursors")
> + (commit version)))
> + (sha256 "0bij0x916lbxph28i3d4hz5l6mzk5fa68mf21jnl7y9rpxx07xsd")))
> + (build-system copy-build-system)
> + (arguments
> + `(#:install-plan
> + '(("dist/" "/share/icons/vimix-cursor/")
> + ("dist-white/" "/share/icons/vimix-white-cursor/"))))
> + (synopsis "Material design inspired cursor theme")
> + (description "Vimix-cursor-theme is a x-cursor theme inspired by Material
> +design and based on capitaine-cursors.")
> + (home-page "https://github.com/vinceliuice/Vimix-cursors")
> + (license license:gpl3+)))
> +
> (define-public gnome-shell-extension-appindicator
> (package
> (name "gnome-shell-extension-appindicator")
> --
> 2.29.2
>

>
> --
> Retrieve my PGP public key: https://meta.sr.ht/~citreu.pgp
>
> Zihao


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl+06agACgkQQarn3Mo9
g1HHyw/+Lhnhn5B2+CXh4m7lAkAtdxlvnMgof4JJmczx/NrPOrlEsXfzGqRMFAFn
ntLlxJICGyM8KYKqUo5kswYQScVSDRWP3bNa7Bxai4TGuNTE0N/KUz0smGPQXuqa
hg5cKMyRv4ps52lhLo0qgntURxJEPPZEDUoXQ8NLTiEtckCziYhP7BuljDytqK23
FIx4+SpRB6EsADaPY3qnghKQNNgAHetW70guenxwjcRwFXomCW75Tgb9l4l+ydJa
TFUZN53qjud8fBpKT/rd+YtCAFYx6rf6RzBZICaKob5Puk2H82ar+tX2yZ5uvt9Y
cqeDrtu1GgYN8q0x92ZLuxKWxOkg8xSI8APVA32IJKKOwcILU3V6ppb3RhuH07yG
EYM4XSgxTFir2GAbJbddd5mxjVGEh5+V4rfGCWvDE8bN6nyvW8W7viJSO/I8lRKr
obOVHPwJ0cOwHba8KHfAFcyN4WYhGt6p9uR5D0GxSpudyUAfNrSFmWh9PiEOmCN2
HbBGQPNgSqMKUmGqRzqWWgTXVoN05tFMbGWVcN4Qb1ZPV3bQuPbfLMsTxmTR/qMh
sNCsQ3HsVMGM91iKfVCT9b3/1b29FTSnunzu/N7Ek0Uf+W/vWH7h6muyU9ROw/AV
mE0intVcG2jbjRY+GbPhZPkVMbc6+veLsfZL1Mf2Oy+mEyIyjRo=
=bDcK
-----END PGP SIGNATURE-----


?