[PATCH v2 3/3] gnu: Add r-lpme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Aniket Patil
  • zimoun
Owner
unassigned
Submitted by
Aniket Patil
Severity
normal
A
A
Aniket Patil wrote on 28 Oct 2020 08:51
(address . guix-patches@gnu.org)
20201028075139.157032-3-aniket112.patil@gmail.com
* gnu/packages/cran.scm (r-lpme): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 20ebb06c67..82caaf54f6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24686,3 +24686,32 @@ Journal of Statistical Software, 39(10), 1-24.")
also density. It comprises several different utilities to handle
kernel estimators.")
(license license:gpl2+)))
+
+(define-public r-lpme
+ (package
+ (name "r-lpme")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lpme" version))
+ (sha256
+ (base32
+ "0si90nkgl8bqk8yvd2igdsrngiwqh8891072pfpzipifnd0f5448"))))
+ (properties `((upstream-name . "lpme")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-decon" ,r-decon)
+ ("r-flexmix" ,r-flexmix)
+ ("r-locpol" ,r-locpol)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page
+ "https://cran.r-project.org/web/packages/lpme")
+ (synopsis "Nonparametric Estimation of Measurement Error Models")
+ (description
+ "Provide nonparametric methods for mean regression model,
+modal regression and conditional density estimation in the
+presence/absence of measurement error. Bandwidth selection is
+also provided for each method.")
+ (license license:gpl2+)))
--
2.28.0
Z
Z
zimoun wrote on 2 Nov 2020 12:55
closing 44277 44278 44279 (duplicates)
(address . control@debbugs.gnu.org)
87tuu855x3.fsf@gmail.com
close 44277
close 44278
close 44279
thanks

--
Hi Aniket,

I am confused. The Patch number #44033 contains the v1.


Then the v2 seems sent to:

guix-patches@gnu.org

and CC to:

44033@debbugs.gnu.org


Usually, another Patch number is not created (via guix-patches@gnu.org)
and the v2 is only sent to the initial Patch number
(via 44033@debbugs.gnu.org).

Therefore, I am closing the duplicates.


Thank you for your contribution and this v2 series.


All the best,
simon
?