[PATCH v2 2/3] gnu: Add r-locpol.

  • Done
  • quality assurance status badge
Details
2 participants
  • Aniket Patil
  • zimoun
Owner
unassigned
Submitted by
Aniket Patil
Severity
normal
A
A
Aniket Patil wrote on 28 Oct 2020 08:51
(address . guix-patches@gnu.org)
20201028075139.157032-2-aniket112.patil@gmail.com
* gnu/packages/cran.scm (r-locpol): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ce2d860135..20ebb06c67 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24664,3 +24664,25 @@ See details in: Wang, X.F. and Wang, B. (2011). Deconvolution
estimation in measurement error models: The R package decon.
Journal of Statistical Software, 39(10), 1-24.")
(license license:gpl3+)))
+
+(define-public r-locpol
+ (package
+ (name "r-locpol")
+ (version "0.7-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "locpol" version))
+ (sha256
+ (base32
+ "1p915n0l09kbwkly627074jslxl01yssp1rf0c7sygvsw6sgy5lm"))))
+ (properties `((upstream-name . "locpol")))
+ (build-system r-build-system)
+ (home-page
+ "https://cran.r-project.org/web/packages/locpol")
+ (synopsis "Kernel Local Polynomial Regression")
+ (description
+ "Computes local polynomial estimators for the regression and
+also density. It comprises several different utilities to handle
+kernel estimators.")
+ (license license:gpl2+)))
--
2.28.0
Z
Z
zimoun wrote on 2 Nov 2020 12:55
closing 44277 44278 44279 (duplicates)
(address . control@debbugs.gnu.org)
87tuu855x3.fsf@gmail.com
close 44277
close 44278
close 44279
thanks

--
Hi Aniket,

I am confused. The Patch number #44033 contains the v1.


Then the v2 seems sent to:

guix-patches@gnu.org

and CC to:

44033@debbugs.gnu.org


Usually, another Patch number is not created (via guix-patches@gnu.org)
and the v2 is only sent to the initial Patch number
(via 44033@debbugs.gnu.org).

Therefore, I am closing the duplicates.


Thank you for your contribution and this v2 series.


All the best,
simon
?