[PATCH v2 1/3] gnu: Add r-decon.

  • Done
  • quality assurance status badge
Details
2 participants
  • Aniket Patil
  • zimoun
Owner
unassigned
Submitted by
Aniket Patil
Severity
normal
A
A
Aniket Patil wrote on 28 Oct 2020 08:51
(address . guix-patches@gnu.org)
20201028075139.157032-1-aniket112.patil@gmail.com
* gnu/packages/cran.scm (r-decon): New variable.
---
gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fea560f7a1..ce2d860135 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24628,3 +24628,39 @@ orthogonal coordinate systems: cartesian, polar, spherical, cylindrical,
parabolic or user defined by custom scale factors.")
(license license:gpl3)))
+(define-public r-decon
+ (package
+ (name "r-decon")
+ (version "1.2-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "decon" version))
+ (sha256
+ (base32
+ "1v4l0xq29rm8mks354g40g9jxn0didzlxg3g7z08m0gvj29zdj7s"))))
+ (properties `((upstream-name . "decon")))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page
+ "https://cran.r-project.org/web/packages/decon")
+ (synopsis "Deconvolution Estimation in Measurement Error Models")
+ (description
+ "This package contains a collection of functions to deal with
+nonparametric measurement error problems using deconvolution
+kernel methods. We focus two measurement error models in the
+package: (1) an additive measurement error model, where the
+goal is to estimate the density or distribution function from
+contaminated data; (2) nonparametric regression model with
+errors-in-variables. The R functions allow the measurement errors
+to be either homoscedastic or heteroscedastic. To make the
+deconvolution estimators computationally more efficient in R,
+we adapt the \"Fast Fourier Transform\" (FFT) algorithm for
+density estimation with error-free data to the deconvolution
+kernel estimation. Several methods for the selection of the
+data-driven smoothing parameter are also provided in the package.
+See details in: Wang, X.F. and Wang, B. (2011). Deconvolution
+estimation in measurement error models: The R package decon.
+Journal of Statistical Software, 39(10), 1-24.")
+ (license license:gpl3+)))
--
2.28.0
Z
Z
zimoun wrote on 2 Nov 2020 12:55
closing 44277 44278 44279 (duplicates)
(address . control@debbugs.gnu.org)
87tuu855x3.fsf@gmail.com
close 44277
close 44278
close 44279
thanks

--
Hi Aniket,

I am confused. The Patch number #44033 contains the v1.


Then the v2 seems sent to:

guix-patches@gnu.org

and CC to:

44033@debbugs.gnu.org


Usually, another Patch number is not created (via guix-patches@gnu.org)
and the v2 is only sent to the initial Patch number
(via 44033@debbugs.gnu.org).

Therefore, I am closing the duplicates.


Thank you for your contribution and this v2 series.


All the best,
simon
?