[PATCH] gnu: emacs: Make strip-double-wrap more robust

  • Done
  • quality assurance status badge
Details
5 participants
  • Morgan.J.Smith
  • Ludovic Courtès
  • Nicolas Goaziou
  • Marius Bakke
  • zimoun
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 27 Oct 2020 03:01
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB21059362E2A281295A7FA2B2C5160@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs.scm (emacs) [strip-double-wrap]:
Use regex to find emacs executable. This works even when the version is
changed by package transformations (ex: version=git.master)
---
gnu/packages/emacs.scm | 16 ++++++----------
1 file changed, 6 insertions(+), 10 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4963379d74..5c89e4c6b6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -196,17 +196,13 @@
(lambda* (#:key outputs #:allow-other-keys)
;; Directly copy emacs-X.Y to emacs, so that it is not wrapped
;; twice. This also fixes a minor issue, where WMs would not be
- ;; able to track emacs back to emacs.desktop. The version is
- ;; accessed using using THIS-PACKAGE so it "just works" for
- ;; inherited Emacs packages of different versions.
+ ;; able to track emacs back to emacs.desktop.
(with-directory-excursion (assoc-ref outputs "out")
- (copy-file (string-append
- "bin/emacs-"
- ,(let ((this-version (package-version this-package)))
- (or (false-if-exception
- (version-major+minor+point this-version))
- (version-major+minor this-version))))
- "bin/emacs")
+ (copy-file
+ (car
+ (find-files
+ "bin" (file-name-predicate "^emacs-([0-9]+\\.)+[0-9]+$")))
+ "bin/emacs")
#t)))
(add-before 'reset-gzip-timestamps 'make-compressed-files-writable
;; The 'reset-gzip-timestamps phase will throw a permission error
--
2.29.1
N
N
Nicolas Goaziou wrote on 27 Oct 2020 22:13
(address . Morgan.J.Smith@outlook.com)(address . 44249@debbugs.gnu.org)
87blgn4bk6.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (4 lines)
> * gnu/packages/emacs.scm (emacs) [strip-double-wrap]:
> Use regex to find emacs executable. This works even when the version is
> changed by package transformations (ex: version=git.master)

Thank you.

Toggle quote (3 lines)
> + (copy-file
> + (car

Please use pattern matching, i.e. `match', instead of `car'.

Toggle quote (4 lines)
> + (find-files
> + "bin" (file-name-predicate "^emacs-([0-9]+\\.)+[0-9]+$")))
> + "bin/emacs")

Would it be even more robust to simply catch any "emacs-" prefixed file
name?

Regards,
--
Nicolas Goaziou
M
M
Morgan.J.Smith wrote on 2 Nov 2020 05:35
[PATCH v2] gnu: emacs: Make strip-double-wrap more robust
(address . mail@nicolasgoaziou.fr)
DM5PR1001MB2105AC02013A8A7DD7A591C3C5100@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs.scm (emacs) [strip-double-wrap]:
Use regex to find emacs executable. This works even when the version is
changed by package transformations (ex: version=git.master)
---
gnu/packages/emacs.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4963379d74..00441dee45 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -123,6 +123,9 @@
(build-system glib-or-gtk-build-system)
(arguments
`(#:tests? #f ; no check target
+ #:modules ((guix build glib-or-gtk-build-system)
+ (guix build utils)
+ (ice-9 match))
#:configure-flags (list "--with-modules"
"--with-cairo"
"--disable-build-details")
@@ -196,17 +199,13 @@
(lambda* (#:key outputs #:allow-other-keys)
;; Directly copy emacs-X.Y to emacs, so that it is not wrapped
;; twice. This also fixes a minor issue, where WMs would not be
- ;; able to track emacs back to emacs.desktop. The version is
- ;; accessed using using THIS-PACKAGE so it "just works" for
- ;; inherited Emacs packages of different versions.
+ ;; able to track emacs back to emacs.desktop.
(with-directory-excursion (assoc-ref outputs "out")
- (copy-file (string-append
- "bin/emacs-"
- ,(let ((this-version (package-version this-package)))
- (or (false-if-exception
- (version-major+minor+point this-version))
- (version-major+minor this-version))))
- "bin/emacs")
+ (copy-file
+ (match
+ (find-files "bin" (file-name-predicate "^emacs-"))
+ (((? string? string)) string))
+ "bin/emacs")
#t)))
(add-before 'reset-gzip-timestamps 'make-compressed-files-writable
;; The 'reset-gzip-timestamps phase will throw a permission error
--
2.29.1
N
N
Nicolas Goaziou wrote on 3 Nov 2020 10:45
(address . Morgan.J.Smith@outlook.com)(address . 44249-done@debbugs.gnu.org)
874km6n58l.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (4 lines)
> * gnu/packages/emacs.scm (emacs) [strip-double-wrap]:
> Use regex to find emacs executable. This works even when the version is
> changed by package transformations (ex: version=git.master)

I added missing final full stops in the commit message, and tweaked your
patter a bit. In particular, I removed the call to `string?', since
I don't think `find-files' can return a non-empty list with anything not
being a string.Let me know if you think I'm wrong.

Patch applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
N
N
Nicolas Goaziou wrote on 3 Nov 2020 13:48
Re: bug#44249: [PATCH v2] gnu: emacs: Make strip-double-wrap more robust
(address . 44249@debbugs.gnu.org)(address . Morgan.J.Smith@outlook.com)
87r1pali7v.fsf@nicolasgoaziou.fr
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (2 lines)
> Patch applied. Thank you.

And patch reverted… It generates a build error: "No code
for module (guix build glib-or-gtk-build-system)".

What is the purpose of loading (guix build glib-or-gtk-build-system)?

Regards,
M
M
Morgan Smith wrote on 3 Nov 2020 15:49
DM5PR1001MB21055D10AE2527FB3A87DB63C5110@DM5PR1001MB2105.namprd10.prod.outlook.com
So I need to use the module (ice-9 match) there to get the definition of
match. However, it seems to override the modules that where previously
available there so I have to add them back.

Can you confirm how you create the error? I did a checkout to the commit
before you did the revert (51482b93b6) and I couldn't find any errors.
This is what I did:

guix environment guix -C --pure -- make distclean
git clean -xfd
guix environment guix -C --pure -- ./bootstrap
guix environment guix -C --pure -- ./configure --localstatedir=/var
guix environment guix -C --pure -- make
./pre-inst-env guix build emacs
./pre-inst-env guix build emacs-next


On 11/3/20 7:48 AM, Nicolas Goaziou wrote:
Toggle quote (11 lines)
> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>
>> Patch applied. Thank you.
>
> And patch reverted… It generates a build error: "No code
> for module (guix build glib-or-gtk-build-system)".
>
> What is the purpose of loading (guix build glib-or-gtk-build-system)?
>
> Regards,
>
N
N
Nicolas Goaziou wrote on 3 Nov 2020 22:38
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 44249@debbugs.gnu.org)
871rha5de5.fsf@nicolasgoaziou.fr
Morgan Smith <Morgan.J.Smith@outlook.com> writes:

Toggle quote (4 lines)
> So I need to use the module (ice-9 match) there to get the definition of
> match. However, it seems to override the modules that where previously
> available there so I have to add them back.

Ah. True.

Toggle quote (2 lines)
> Can you confirm how you create the error?

I cannot. I tested your patch before applying it, and could compile
Emacs just fine. However, as Ludovic reported it on IRC this commit had
introduced issues in `emacs-minimal' package, hence the revert. See, if
I understand Guix Data correctly,


Regards,
Z
Z
zimoun wrote on 3 Nov 2020 23:09
Re: [bug#44249] [PATCH v2] gnu: emacs: Make strip-double-wrap more robust
(address . 44249@debbugs.gnu.org)
86imamgki3.fsf@gmail.com
Dear,

On Tue, 03 Nov 2020 at 22:38, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (9 lines)
>> Can you confirm how you create the error?
>
> I cannot. I tested your patch before applying it, and could compile
> Emacs just fine. However, as Ludovic reported it on IRC this commit had
> introduced issues in `emacs-minimal' package, hence the revert. See, if
> I understand Guix Data correctly,
>
> http://data.guix.gnu.org/revision/b107a19ffb6a6abb7bde3436f3fa359071bd1f5c/package/emacs-minimal/27.1

Another entry point is:


Then click on “2020-11-03 09:43:20“ which is the (commit) date of the
first failing commit and you get the revision
b107a19ffb6a6abb7bde3436f3fa359071bd1f5c


then click on “(View cgit)” leads to:


QED. :-)


Hope that helps,
simon

PS:
The attentive reader notice the difference of hours:
“2020-11-03 09:43:20“
vs
2020-11-03 10:30:03 +0100
Hum?!
M
M
Morgan.J.Smith wrote on 4 Nov 2020 20:47
[PATCH v3] gnu: emacs: Make strip-double-wrap more robust.
(address . mail@nicolasgoaziou.fr)
DM5PR1001MB2105208A37F6D9141D01B0C8C5EF0@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs.scm (emacs) [strip-double-wrap]: Use regex to find emacs
executable. This works even when the version is changed by package
transformations (e.g., version=git.master).
---

(Can you reopen this bug report please?)

So I see 3 possible solutions:
1. Accept my first patch and give up on match
2. Accept this patch and modify almost every emacs varient (I did test building them all)
3. Figure out some proper module inheritence

I think option 3 is the most correct, but I'm lazy so I'm leaning towards option 1.
---
gnu/packages/emacs.scm | 42 ++++++++++++++++++++++++++++--------------
1 file changed, 28 insertions(+), 14 deletions(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4963379d74..4d1080f9dd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -123,6 +123,9 @@
(build-system glib-or-gtk-build-system)
(arguments
`(#:tests? #f ; no check target
+ #:modules ((guix build glib-or-gtk-build-system)
+ (guix build utils)
+ (ice-9 match))
#:configure-flags (list "--with-modules"
"--with-cairo"
"--disable-build-details")
@@ -196,17 +199,12 @@
(lambda* (#:key outputs #:allow-other-keys)
;; Directly copy emacs-X.Y to emacs, so that it is not wrapped
;; twice. This also fixes a minor issue, where WMs would not be
- ;; able to track emacs back to emacs.desktop. The version is
- ;; accessed using using THIS-PACKAGE so it "just works" for
- ;; inherited Emacs packages of different versions.
+ ;; able to track emacs back to emacs.desktop.
(with-directory-excursion (assoc-ref outputs "out")
- (copy-file (string-append
- "bin/emacs-"
- ,(let ((this-version (package-version this-package)))
- (or (false-if-exception
- (version-major+minor+point this-version))
- (version-major+minor this-version))))
- "bin/emacs")
+ (copy-file
+ (match (find-files "bin" "^emacs-")
+ ((executable . _) executable))
+ "bin/emacs")
#t)))
(add-before 'reset-gzip-timestamps 'make-compressed-files-writable
;; The 'reset-gzip-timestamps phase will throw a permission error
@@ -328,7 +326,11 @@ languages.")
((#:phases phases)
`(modify-phases ,phases
(delete 'restore-emacs-pdmp)
- (delete 'strip-double-wrap)))))
+ (delete 'strip-double-wrap)))
+ ((#:modules modules)
+ `((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 match)))))
(inputs
`(("guix-emacs.el" ,(search-auxiliary-file "emacs/guix-emacs.el"))
("ncurses" ,ncurses)))
@@ -348,7 +350,11 @@ editor (with xwidgets support)")
((#:phases phases)
`(modify-phases ,phases
(delete 'restore-emacs-pdmp)
- (delete 'strip-double-wrap)))))
+ (delete 'strip-double-wrap)))
+ ((#:modules modules)
+ `((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 match)))))
(inputs
`(("webkitgtk" ,webkitgtk)
("libxcomposite" ,libxcomposite)
@@ -375,7 +381,11 @@ editor (console only)")
((#:phases phases)
`(modify-phases ,phases
(delete 'restore-emacs-pdmp)
- (delete 'strip-double-wrap)))))))
+ (delete 'strip-double-wrap)))
+ ((#:modules modules)
+ `((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 match)))))))
(define-public emacs-no-x-toolkit
(package/inherit emacs
@@ -392,7 +402,11 @@ editor (without an X toolkit)" )
((#:phases phases)
`(modify-phases ,phases
(delete 'restore-emacs-pdmp)
- (delete 'strip-double-wrap)))))))
+ (delete 'strip-double-wrap)))
+ ((#:modules modules)
+ `((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 match)))))))
(define-public emacs-wide-int
(package/inherit emacs
--
2.29.1
N
N
Nicolas Goaziou wrote on 5 Nov 2020 23:33
(address . Morgan.J.Smith@outlook.com)(address . 44249@debbugs.gnu.org)
875z6jl9hs.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (2 lines)
> (Can you reopen this bug report please?)

I think you need to open a new one.

Toggle quote (8 lines)
> So I see 3 possible solutions:
> 1. Accept my first patch and give up on match
> 2. Accept this patch and modify almost every emacs varient (I did test building them all)
> 3. Figure out some proper module inheritence
>
> I think option 3 is the most correct, but I'm lazy so I'm leaning
> towards option 1.

I think I cannot help you, as I'm not sure about how module inheritance
is handled. Maybe someone else can chime in.

Regards,
--
Nicolas Goaziou
M
M
Marius Bakke wrote on 7 Nov 2020 21:48
Re: [bug#44249] [PATCH v3] gnu: emacs: Make strip-double-wrap more robust.
(address . 44249@debbugs.gnu.org)
878sbchozy.fsf@gnu.org
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (17 lines)
> Hello,
>
>> (Can you reopen this bug report please?)
>
> I think you need to open a new one.
>
>> So I see 3 possible solutions:
>> 1. Accept my first patch and give up on match
>> 2. Accept this patch and modify almost every emacs varient (I did test building them all)
>> 3. Figure out some proper module inheritence
>>
>> I think option 3 is the most correct, but I'm lazy so I'm leaning
>> towards option 1.
>
> I think I cannot help you, as I'm not sure about how module inheritance
> is handled. Maybe someone else can chime in.

I haven't followed the discussion in detail, but from skimming through
the thread, is it just about adding (ice-9 match) to the build system
modules?

In that case I think

#:modules ((ice-9 match) ,@%glib-or-gtk-build-system-modules)

...should do the trick.
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl+nCDEPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT64L0IALmRyXKPtCsb0SMChOB1s2PHTtBmyierAqvE
D8wx2oAAOcJRl+J1mQq1JkjOlOOWbdAtBmwQob6qPVcAoBv1u64/P6Q3zjPlpLyP
N8umotxtfom+5ugcRn6j//YIY8vKu+NpFFTRK2H6I3uFYPjioVei/AItf98YQfvG
w9BBdmbEkfeJQlybQIoz6Evoaf9tKCRyaVQj5FCR7zjW71uN90ty/Akuw1P1ILeH
AVYOrxA8aoa+gcNVRpHRwaTt8YsWWTo8MeEVMuF9ZPJACvimA3pdE/dDkh+ktF7e
8vKvKNQ2QTLgHvfbfXRSa0ab2lDhALugEmAibz3z7VwXu6c1Uj8=
=ewtP
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 15 Jan 2021 14:28
Re: bug#44249: [PATCH] gnu: emacs: Make strip-double-wrap more robust
(address . Morgan.J.Smith@outlook.com)
874kjiz5vp.fsf_-_@gnu.org
Hi Morgan,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (6 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs.scm (emacs) [strip-double-wrap]: Use regex to find emacs
> executable. This works even when the version is changed by package
> transformations (e.g., version=git.master).

[...]

Toggle quote (12 lines)
> (with-directory-excursion (assoc-ref outputs "out")
> - (copy-file (string-append
> - "bin/emacs-"
> - ,(let ((this-version (package-version this-package)))
> - (or (false-if-exception
> - (version-major+minor+point this-version))
> - (version-major+minor this-version))))
> - "bin/emacs")
> + (copy-file
> + (match (find-files "bin" "^emacs-")
> + ((executable . _) executable))

If we assume there should be just one “^emacs-” executable, you can
change the match clause to reflect it:

(match (find-files "bin" "^emacs-")
((executable) executable))

To be even more defensive, you could refine the regexp to
“^emacs-[0-9]”.

Toggle quote (2 lines)
> + "bin/emacs")

[...]

Toggle quote (5 lines)
> + ((#:modules modules)
> + `((guix build gnu-build-system)
> + (guix build utils)
> + (ice-9 match)))))

Unless I’m missing something, you don’t need to repeat #:modules in
every variant: the ‘arguments’ field is inherited by those variants, and
that includes #:modules.

You can check easily that re-adding #:modules has no effect by checking
the output of, say:

./pre-inst-env guix build emacs-xwidgets -d --no-grafts

before and after removing the ((#:modules modules) …) bit.

Could you send an updated patch?

This is the last missing bit before one can run things like:

guix install emacs-next --with-branch=emacs-next=master

:-)

Thanks,
Ludo’.
M
M
Morgan Smith wrote on 15 Jan 2021 20:49
(name . Ludovic Courtès)(address . ludo@gnu.org)
MWHPR0801MB36758C2C15729A54EB8409CEC5A70@MWHPR0801MB3675.namprd08.prod.outlook.com
I've actually been sorta half working on this for a while now.

The problem is exactly that the modules field is inherited. See each
build system includes its own module in the modules field. The various
emacsen are built with different build systems. So emacs is going to
need to import (guix build glib-or-gtk-build-system) and emacs-minimal
is going to want (guix build gnu-build-system). By setting the modules
to be the glib-or-gtk-build-system, we override the default modules in
each inherited package. This means building emacs-minimal would result
in this error:

no code for module (guix build glib-or-gtk-build-system)

I'm not entirely certain why it worked for you but it looks like maybe
you included the gnu-build system instead of the glib-or-gtk-build-system.

I think to solve this issue proper, we need to come up with a way to use
%default-modules. Currently this variable isn't usable in this context,
but as gnu/packages/code.scm:791 says: ";; FIXME use %default-modules"
L
L
Ludovic Courtès wrote on 16 Jan 2021 22:54
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
875z3wy2cq.fsf_-_@gnu.org
Hi,

Morgan Smith <Morgan.J.Smith@outlook.com> skribis:

Toggle quote (13 lines)
> I've actually been sorta half working on this for a while now.
>
> The problem is exactly that the modules field is inherited. See each
> build system includes its own module in the modules field. The various
> emacsen are built with different build systems. So emacs is going to
> need to import (guix build glib-or-gtk-build-system) and emacs-minimal
> is going to want (guix build gnu-build-system). By setting the modules
> to be the glib-or-gtk-build-system, we override the default modules in
> each inherited package. This means building emacs-minimal would result
> in this error:
>
> no code for module (guix build glib-or-gtk-build-system)

Ooh, my bad, I had completely overlooked this “detail”.

Then I guess the patch is fine though… in this case you could
exceptionally ;-) write (car (find-files …)) so you don’t even need to
both importing (ice-9 match). That’d save quite a few lines of code.

WDYT?

Thanks!

Ludo’.
M
M
Morgan Smith wrote on 16 Jan 2021 23:03
(name . Ludovic Courtès)(address . ludo@gnu.org)
SN4PR0801MB3679217EBE332B51DBB1646FC5A60@SN4PR0801MB3679.namprd08.prod.outlook.com
Hi Ludo,

I think that's an elegant and wonderful idea. Assuming the first patch
in this thread still applies, I vote we just apply that one.

There has been some discussion in this thread on if the regex should
actually look for numbers or not (notably Nicolas and you). I could go
either way. I'm pretty sure the regex that's already there that matches
2 or more period separated numbers will always hold true, but feel free
to loosen up the regex a little if you feel otherwise.

Thanks,

Morgan

On 1/16/21 4:54 PM, Ludovic Courtès wrote:
Toggle quote (29 lines)
> Hi,
>
> Morgan Smith <Morgan.J.Smith@outlook.com> skribis:
>
>> I've actually been sorta half working on this for a while now.
>>
>> The problem is exactly that the modules field is inherited. See each
>> build system includes its own module in the modules field. The various
>> emacsen are built with different build systems. So emacs is going to
>> need to import (guix build glib-or-gtk-build-system) and emacs-minimal
>> is going to want (guix build gnu-build-system). By setting the modules
>> to be the glib-or-gtk-build-system, we override the default modules in
>> each inherited package. This means building emacs-minimal would result
>> in this error:
>>
>> no code for module (guix build glib-or-gtk-build-system)
>
> Ooh, my bad, I had completely overlooked this “detail”.
>
> Then I guess the patch is fine though… in this case you could
> exceptionally ;-) write (car (find-files …)) so you don’t even need to
> both importing (ice-9 match). That’d save quite a few lines of code.
>
> WDYT?
>
> Thanks!
>
> Ludo’.
>
L
L
Ludovic Courtès wrote on 31 Jan 2021 21:30
(address . Morgan.J.Smith@outlook.com)(address . 44249-done@debbugs.gnu.org)
87tuqwluh0.fsf@gnu.org
Hi Morgan,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (6 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs.scm (emacs) [strip-double-wrap]:
> Use regex to find emacs executable. This works even when the version is
> changed by package transformations (ex: version=git.master)

Somehow I had forgotten about this patch, but I finally applied it!

Toggle quote (13 lines)
> (with-directory-excursion (assoc-ref outputs "out")
> - (copy-file (string-append
> - "bin/emacs-"
> - ,(let ((this-version (package-version this-package)))
> - (or (false-if-exception
> - (version-major+minor+point this-version))
> - (version-major+minor this-version))))
> - "bin/emacs")
> + (copy-file
> + (car
> + (find-files
> + "bin" (file-name-predicate "^emacs-([0-9]+\\.)+[0-9]+$")))

Here I just remove ‘file-name-predicate’ because it’s implicit. I
checked that it works with the currently-packaged version as well as
‘--with-branch=emacs-next=master’.

Thank you, and apologies for the long delay!

Ludo’.
Closed
?