[PATCH] gnu: Add mpdris2

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars-Dominik Braun
  • Leo Famulari
Owner
unassigned
Submitted by
Lars-Dominik Braun
Severity
normal
L
L
Lars-Dominik Braun wrote on 24 Oct 2020 13:24
(address . guix-patches@gnu.org)
20201024112405.GA96185@noor.fritz.box
* gnu/packages/mpd.scm (mpdris2): New package.
---
gnu/packages/mpd.scm | 48 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 6be7c930a1..323ae51af7 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,7 +35,9 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
@@ -53,6 +56,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
@@ -369,3 +373,47 @@ MPD library in a similar way to many other music players' 'shuffle library'
feature. ashuffle works like any other MPD client, and can be used alongside
other MPD frontends.")
(license license:expat)))
+
+(define-public mpdris2
+ (package
+ (name "mpdris2")
+ (version "0.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eonpatapon/mpDris2.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "048b8acsd1b8kcxzd9fsh5p9g2an9c4rznicfcpyrsjz5syv894h"))))
+ (build-system gnu-build-system)
+ ;; Manually wrap the binary, because we’re not using python-build-system.
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (python-path (getenv "PYTHONPATH")))
+ (wrap-program (string-append out "/bin/mpDris2")
+ `("PYTHONPATH" ":" prefix (,python-path)))
+ #t))))))
+ (inputs
+ `(("python-mpd2" ,python-mpd2)
+ ("python-dbus" ,python-dbus)
+ ("python-pygobject" ,python-pygobject)
+ ("python" ,python))) ; Sets PYTHONPATH.
+ ;; For bootstrapping.
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gnu-gettext)
+ ("which" ,which)
+ ("intltool" ,intltool)))
+ (synopsis "MPRIS V2.1 support for mpd")
+ (description "Client for the Music Player Daemon providing MPRIS 2
+support")
+ (home-page "https://github.com/eonpatapon/mpDris2")
+ (license license:gpl3)))
+
--
2.26.2
L
L
Leo Famulari wrote on 25 Oct 2020 20:06
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 44190-done@debbugs.gnu.org)
20201025190624.GA29289@jasmine.lan
On Sat, Oct 24, 2020 at 01:24:05PM +0200, Lars-Dominik Braun wrote:
Toggle quote (2 lines)
> * gnu/packages/mpd.scm (mpdris2): New package.

Thanks! Pushed as 349666b7d233b551781d37eb1fed2c1125610097 with the
following minor changes:

Toggle quote (2 lines)
I changed this to the URL reported as a permanent redirection by `guix
lint` — concretely, I removed the ".git" part.

Toggle quote (2 lines)
> + (synopsis "MPRIS V2.1 support for mpd")

I wrote it as "MPD", which is how it's stylized upstream:


Toggle quote (2 lines)
> + (license license:gpl3)))

I changed this to gpl3+, since the license header of the main source
file includes the "any later version" string.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl+VzLAACgkQJkb6MLrK
fwjTfRAAhyGGI114Zg94c94/jCjlVQqjH+DgpSZk+uhSwmYY2qm/eCh2NMS35H3E
WQyAA2SodU9uVkGNHajdAibs6Pm4qWlfyOkRBTIByVZixQq2KMdKSVMzjukGubOs
5EHZWuL0KU1XPSpkqJEzRBNx1Vmt/On74xZNgmFUVBNl88K5ibOQqiXppF/So11o
pnUgly/7lgDjR2GDn3uTmpHOheCU/F8+fMgtNXBWsqdZKXAYUBIpdo0Cg1jHE80M
nxMMX1AJBLtDszm1J2pU0WZh/8fqP7P26YfkjIZEgccnUb+tjUXgdnz9zekL+Umq
z7bkxJtF+N1hvL6JH3a2XmyCR8kiNxSsiV+mZgnbQjoEIPPx2rb3ShDB7W6uB61Z
4pRaI5r0uh7Gl//CRT+6TYV95eY8xx9ALRIhtLVowJ5ehqnuwTxZowguAV7REaH4
4ri0nXPIbi0+Q702Tz/n79SJsWNXSCIz7QTDok64reTvSVnNg5hgdnRAw4OxqVbQ
LCF4cV0d/eV3aX/I0qjFU4HVJyKYd7qOomYFJ5GVwJlO0PgjP0IBfMo3a+T/8nRP
gwo4hYRa7vXOIsiYccCcqe81rpVb58IP/xVSro/E/2d/rnEeP5kpSfefP7WG3y8/
7vCJ2Vx+W8GpXo5xYD7Py5jrR68S5nRxZjQpsDb43ycZGjijXII=
=Lvjb
-----END PGP SIGNATURE-----


Closed
?