[PATCH] gnu: Add atomicparsley.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandru-Sergiu Marton
  • Christopher Baines
Owner
unassigned
Submitted by
Alexandru-Sergiu Marton
Severity
normal
A
A
Alexandru-Sergiu Marton wrote on 23 Oct 2020 23:23
(address . guix-patches@gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
20201023212346.26664-1-brown121407@posteo.ro
* gnu/packages/video.scm (atomicparsley): New variable.
---
gnu/packages/video.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bdccb6fdb7..5cf8b56ae1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4806,3 +4807,41 @@ BBC iPlayer output.")
includes @code{dvdxchap} tool for extracting chapter information from DVD.")
(license license:gpl2)
(home-page "https://www.bunkus.org/videotools/ogmtools/")))
+
+(define-public atomicparsley
+ (package
+ (name "atomicparsley")
+ (version "20200701.154658.b0d6223")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wez/atomicparsley")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kym2l5y34nmbrrlkfmxsf1cwrvch64kb34jp0hpa0b89idbhwqh"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-cmake-version
+ (lambda* _
+ (substitute* "CMakeLists.txt"
+ (("VERSION 3.17") "VERSION 3.16"))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "AtomicParsley" bin))
+ #t)))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (synopsis "Metadata editor for MPEG-4 files")
+ (description "AtomicParsley is a lightweight command line program for
+reading, parsing and setting metadata into MPEG-4 files, in particular,
+iTunes-style metadata.")
+ (home-page "https://github.com/wez/atomicparsley")
+ (license license:gpl2)))
--
2.28.0
C
C
Christopher Baines wrote on 24 Oct 2020 22:30
(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)(address . 44181@debbugs.gnu.org)
87h7qjbc44.fsf@cbaines.net
Hi!

Thanks for the patch, I've put some comments inline below.

Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

Toggle quote (22 lines)
> * gnu/packages/video.scm (atomicparsley): New variable.
> ---
> gnu/packages/video.scm | 39 +++++++++++++++++++++++++++++++++++++++
> 1 file changed, 39 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index bdccb6fdb7..5cf8b56ae1 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -44,6 +44,7 @@
> ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
> ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
> ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
> +;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -4806,3 +4807,41 @@ BBC iPlayer output.")
> includes @code{dvdxchap} tool for extracting chapter information from DVD.")
> (license license:gpl2)
> (home-page "https://www.bunkus.org/videotools/ogmtools/")))

Looks like this is at the end of video.scm. That's OK, but often unwise
as if everyone adds new packages to the end of the modules, the patches
will often conflict. For that reason, it's normally helpful to add
packages not at the end, I usually add it close to related packages, or
those with a name close by in the alphabet.

Toggle quote (18 lines)
> +
> +(define-public atomicparsley
> + (package
> + (name "atomicparsley")
> + (version "20200701.154658.b0d6223")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/wez/atomicparsley")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1kym2l5y34nmbrrlkfmxsf1cwrvch64kb34jp0hpa0b89idbhwqh"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f

So that someone looking at the package definition can tell why the tests
are disabled, it would be good to add a comment saying why. If it's that
the tests don't pass, then it can be a TODO comment.

Toggle quote (22 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (add-before 'configure 'set-cmake-version
> + (lambda* _
> + (substitute* "CMakeLists.txt"
> + (("VERSION 3.17") "VERSION 3.16"))
> + #t))
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (bin (string-append out "/bin")))
> + (install-file "AtomicParsley" bin))
> + #t)))))
> + (inputs
> + `(("zlib" ,zlib)))
> + (synopsis "Metadata editor for MPEG-4 files")
> + (description "AtomicParsley is a lightweight command line program for
> +reading, parsing and setting metadata into MPEG-4 files, in particular,
> +iTunes-style metadata.")
> + (home-page "https://github.com/wez/atomicparsley")
> + (license license:gpl2)))

I had a look at the few source files, and they suggested that this is
gpl2+, maybe there's a bit that's gpl2 only though?

Would you be able to send an updated patch?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+UjutfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdKsQ/+JvIb0ar5vDZgHTO5Vx0LrZ2aZHdR61ed
1vehgNFvSIPxtgP5JwXZ+UkCwxQTLZIARt3cEbYltWu6TyxMTNBA5zuxF3u6DIiU
cv0Bx43D+BOWEW/7U6egBtBouhEu/tWzcu2ZHF+lV4QeltED1VW04WT2Gck9QiQ2
bnQB51FUAFuBKhtjKKCgc7o7IrqggWq0fqzGojnNcXNvoHqiTm9lV7AiOktc248C
tI42JGGoaPm/KlSp5ZXDE7gxrSBYIrlWGaqIrkP0FwYv1gXVLGBT6Jbo74HVBbac
YoEXxOjUgQ3nKUpMR2I9bB4cMMO30dspPxRgnTmadO4Lg9KgUMFgPeAp2FkJEiK5
TGQb4YW2bCVgksdArh5VUzEmOx5k0zwTH7CJYUp/kVy9KAvfsrSOXhXLSsWQSvuD
hLO19FXQKfXt6qumuS7Sr/Szud0sdfOGnMVDTuvcVGkaXHPHtJSE0DNd2YvVerOm
BSo1PGpIY2SVP2HU1V9yZxH3er66PbkO2lw88J9UPexQHJI5tITQoQatVpYw4JMP
HmqihdE2yFw9Sk7uW4hFH9WjL9NIuoyS3OlbBX9f8MlPj8ZH+zjOQs/OfAR/UzZA
tq/E2QBUI7nu5x+aRxG9hiUmup3Sr7ZgZSNWaka5VtNG71Olmp9mvN19xaZCp/JF
lw33axVx9tA=
=ozaC
-----END PGP SIGNATURE-----

A
A
Alexandru-Sergiu Marton wrote on 25 Oct 2020 01:54
[PATCH v2] gnu: Add atomicparsley.
(address . 44181@debbugs.gnu.org)
20201024235447.20487-1-brown121407@posteo.ro
* gnu/packages/video.scm (atomicparsley): New variable.
---
This patch doesn't place atomicparsley at the end of video.scm anymore, to
prevent possible conflicts, explains why the tests are disabled and why the
CMake required version is modified, and corrects the license field.

gnu/packages/video.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bdccb6fdb7..5908bc764b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3722,6 +3723,47 @@ information and other metadata about audio or video files. It supports the
many codecs and formats supported by libmediainfo.")
(license license:bsd-2)))
+(define-public atomicparsley
+ (package
+ (name "atomicparsley")
+ (version "20200701.154658.b0d6223")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wez/atomicparsley")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kym2l5y34nmbrrlkfmxsf1cwrvch64kb34jp0hpa0b89idbhwqh"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;; no tests included
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-cmake-version
+ (lambda* _
+ (substitute* "CMakeLists.txt"
+ ;; At the time of writing, Guix has CMake at 3.16, but
+ ;; AtomicParsley uses 3.17. This brings the required CMake
+ ;; version down to what Guix can afford.
+ (("VERSION 3.17") "VERSION 3.16"))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "AtomicParsley" bin))
+ #t)))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (synopsis "Metadata editor for MPEG-4 files")
+ (description "AtomicParsley is a lightweight command line program for
+reading, parsing and setting metadata into MPEG-4 files, in particular,
+iTunes-style metadata.")
+ (home-page "https://github.com/wez/atomicparsley")
+ (license license:gpl2+)))
+
(define-public livemedia-utils
(package
(name "livemedia-utils")
--
2.28.0
C
C
Christopher Baines wrote on 24 Oct 2020 23:57
(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)(address . 44181-done@debbugs.gnu.org)
87tuuj9tjl.fsf@cbaines.net
Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

Toggle quote (6 lines)
> * gnu/packages/video.scm (atomicparsley): New variable.
> ---
> This patch doesn't place atomicparsley at the end of video.scm anymore, to
> prevent possible conflicts, explains why the tests are disabled and why the
> CMake required version is modified, and corrects the license field.

Awesome, I've pushed this to master as
6a3b4765f9dfcefa89e65406177d3442b7958c28.

Thanks again,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+Uoy5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdEOw//fu40/MBUHWT8mjroqCL63cra0WEyExA4
fXiICaLwVlsUMxtLRm+QLvGlZtRzF6ezLOtTsvvd228kZngyWBZgJzt9H/cbMJpA
0f6xrtYT25AWzqKhaa5d4jtMJnwFN4Q3WgPOy4ErJyvV/TTS9Dynl5wS2iS/laZW
60xv/+VZMtBudLKplAgs+0v6CSaC9lIJ6yCKwizqlttElXwGHBbX/fz25EKEMSKK
oYO2HBbc9ArOCKBGnKVH2WswPCgV+cyawH4/2o9QJi48rxOqrN0KrVt/r3QSymMQ
3EkGrcWXmp+aZUD+Z+msy1zHgD2rZYV7VXL6V6jwy+AAngSVDWXSLoCfPeUAWArN
2LrKSuEQGdqcbz4Kj47XQJnpjj14Dd87N5a5GxdHxzxyp/V3FP7z2CYa13qiLoPJ
G+sIULztikfOC9wPs5RzquRtZwlGqLvmVBsXfgjrJYgXuVi/Cr/QNIr9qRKHPI23
61R7MjBlT+pbd2O7VcMzZcwhs+GBebidL1b33EQvhbPsuZBNT4SHYQdzePgHSf65
7gm/loYdhCtoem4lIXQq4C2Oex9O62XotvjLPdbmvjfkp0Got1Cd2O07bA5UPTHg
ogc12ZOMnVNSNVwbwCleusaPR77t8taZzEZFXknWDqrKw8tdeOTfKGcE04kBY7ft
aItj3V7wfAs=
=l4yW
-----END PGP SIGNATURE-----

Closed
?