[PATCH] gnu: Add emacs-xonsh-mode.

  • Done
  • quality assurance status badge
Details
3 participants
  • Hilton Chain
  • Joseph LaFreniere
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Joseph LaFreniere
Severity
normal
J
J
Joseph LaFreniere wrote on 23 Oct 2020 03:22
(address . guix-patches@gnu.org)
87tuulag92.fsf@odyssey.lafreniere.xyz
Patch file is attached.

The repository has existed for over a year and is referred to by
the upstream xonsh project (xon.sh), so the lack of a tagged
release is not indicative of a lack of maturity.

--
Joseph LaFreniere
From c99c1eeb00b44b54217159e8ec0814d94bb8aa09 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Thu, 22 Oct 2020 20:15:59 -0500
Subject: [PATCH] gnu: Add emacs-xonsh-mode.

* gnu/packages/emacs-xyz.scm (emacs-xonsh-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 818db3e4e5..4ecf0eb9e1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25191,3 +25191,28 @@ the TypeScript implementation.")
(description "This package provides an Emacs client for the Rocket.chat
service.")
(license license:expat))))
+
+(define-public emacs-xonsh-mode
+ ;; There is no tagged release yet.
+ (let ((tag "0.0.0")
+ (commit "7fa581524533a9b6b770426e4445e571a69e469d")
+ (revision "0"))
+ (package
+ (name "emacs-xonsh-mode")
+ (version (git-version tag revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seanfarley/xonsh-mode.git")
+ (commit commit)))
+ (sha256
+ (base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/seanfarley/xonsh-mode")
+ (synopsis "Major mode for editing @code{xonsh} files")
+ (description
+ "This package implements a major mode for xonsh scripts. The basic
+functionality includes syntax highlight for xonsh operators. Files with the
+.xonshrc or .xsh extension are automatically opened with this mode.")
+ (license license:gpl3+))))
--
2.28.0
N
N
Nicolas Goaziou wrote on 26 Oct 2020 09:41
(name . Joseph LaFreniere)(address . joseph@lafreniere.xyz)(address . 44165@debbugs.gnu.org)
877drd5qge.fsf@nicolasgoaziou.fr
Hello,

Joseph LaFreniere <joseph@lafreniere.xyz> writes:

Toggle quote (2 lines)
> Patch file is attached.

Thank you. Some comments follow.
Toggle quote (3 lines)
> + ;; There is no tagged release yet.
> + (let ((tag "0.0.0")

The version is actually "O" according to the "Version" keyword in the
Elisp file, not "0.0.0".

Toggle quote (17 lines)
> + (commit "7fa581524533a9b6b770426e4445e571a69e469d")
> + (revision "0"))
> + (package
> + (name "emacs-xonsh-mode")
> + (version (git-version tag revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/seanfarley/xonsh-mode.git")
> + (commit commit)))
> + (sha256
> + (base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/seanfarley/xonsh-mode")
> + (synopsis "Major mode for editing @code{xonsh} files")

Emacs major mode for editing @file{xonshrc} files

seems slightly more accurate.

Toggle quote (3 lines)
> + (description
> + "This package implements a major mode for xonsh scripts. The basic

Mind the two spaces after the full stop above.

Toggle quote (3 lines)
> +functionality includes syntax highlight for xonsh operators. Files with the
> +.xonshrc or .xsh extension are automatically opened with this mode.")

@file{.xonshrc} or @file{.xsh} extension

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
J
J
Joseph LaFreniere wrote on 28 Oct 2020 20:37
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87zh466t16.fsf@odyssey.lafreniere.xyz
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
Toggle quote (4 lines)
> The version is actually "O" according to the "Version" keyword
> in the
> Elisp file, not "0.0.0".

Updated.

Toggle quote (4 lines)
> Emacs major mode for editing @file{xonshrc} files
>
> seems slightly more accurate.

I pulled in the change denoting that the package provides an
_Emacs_ major mode. I'm less sure about changing @code{xonsh} to
@file{xonshrc}. You suggestion is what the Emacs Lisp package's
header says, but that header is slightly misleading because the
major mode is not just for xonsh rc files but also full xonsh
script files (.xsh).

Toggle quote (2 lines)
> Mind the two spaces after the full stop above.

Updated.

Toggle quote (2 lines)
> @file{.xonshrc} or @file{.xsh} extension

Updated.

Toggle quote (2 lines)
> Could you send an updated patch?

Patch file is attached. Thank you for the review!

--
Joseph LaFreniere
From 1c8450c5ef7666cd0334d52e70ed9ce962400de1 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Thu, 22 Oct 2020 20:15:59 -0500
Subject: [PATCH] gnu: Add emacs-xonsh-mode.

* gnu/packages/emacs-xyz.scm (emacs-xonsh-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 818db3e4e5..b0c533dc22 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25191,3 +25191,29 @@ the TypeScript implementation.")
(description "This package provides an Emacs client for the Rocket.chat
service.")
(license license:expat))))
+
+(define-public emacs-xonsh-mode
+ ;; There is no tagged release yet.
+ (let ((tag "0")
+ (commit "7fa581524533a9b6b770426e4445e571a69e469d")
+ (revision "0"))
+ (package
+ (name "emacs-xonsh-mode")
+ (version (git-version tag revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seanfarley/xonsh-mode.git")
+ (commit commit)))
+ (sha256
+ (base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/seanfarley/xonsh-mode")
+ (synopsis "Emacs major mode for editing @code{xonsh} files")
+ (description
+ "This package implements a major mode for xonsh scripts. The basic
+functionality includes syntax highlight for xonsh operators. Files with the
+@file{.xonshrc} or @file{.xsh} extension are automatically opened with this
+mode.")
+ (license license:gpl3+))))
--
2.28.0
H
H
Hilton Chain wrote on 25 Apr 2023 09:39
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
875y9k4dgz.wl-hako@ultrarare.space
Hello Nicolas,

It seems that you missed the updated patch (https://issues.guix.gnu.org/44165#2).

This patch looks good to me, and there's no update on the source side. Can you review it later?

Thanks!
N
N
Nicolas Goaziou wrote on 25 Apr 2023 11:51
(name . Hilton Chain via Guix-patches via)(address . guix-patches@gnu.org)
874jp4p9w9.fsf@nicolasgoaziou.fr
Hello,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (7 lines)
> Hello Nicolas,
>
> It seems that you missed the updated patch (<https://issues.guix.gnu.org/44165#2>).
>
> This patch looks good to me, and there's no update on the source side.
> Can you review it later?

Done. It indeed fell through the cracks.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
?