[PATCH] gnu: python-black: Update to 20.8b1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 22 Oct 2020 16:14
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201022141407.4392-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-black): Update to 20.8b1.
[arguments] Set PATH to make 1 test pass. Disable 1 failing test.
[propagated-inputs] Add python-mypy-extensions and python-typing-extensions.
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++----
1 file changed, 14 insertions(+), 4 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 575ce40ac8..e3f8589249 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4053,14 +4053,14 @@ matching of file paths.")
(define-public python-black
(package
(name "python-black")
- (version "19.10b0")
+ (version "20.8b1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "black" version))
(sha256
(base32
- "0f8mr0yzj78q1dx7v6ggbgfir2wv0n5z2shfbbvfdq7910xbgvf2"))))
+ "1spv6sldp3mcxr740dh3ywp25lly9s8qlvs946fin44rl1x5a0hw"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -4078,7 +4078,11 @@ matching of file paths.")
"")))))
#t))
(add-after 'unpack 'disable-broken-tests
- (lambda _
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; Make installed package available for running the tests
+ (setenv "PATH" (string-append (assoc-ref outputs "out") "/bin"
+ ":" (getenv "PATH")))
+
;; These tests are supposed to be skipped when the blackd
;; dependencies are missing, but this doesn't quite work.
(substitute* "tests/test_black.py"
@@ -4092,15 +4096,21 @@ matching of file paths.")
(substitute* "tests/test_black.py"
(("( *)def test_self" match indent)
(string-append indent "@unittest.skip(\"guix\")\n" match)))
+
+ (substitute* "tests/test_black.py"
+ (("( *)def test_python38" match indent)
+ (string-append indent "@unittest.skip(\"guix\")\n" match)))
#t)))))
(propagated-inputs
`(("python-click" ,python-click)
("python-attrs" ,python-attrs)
("python-appdirs" ,python-appdirs)
("python-pathspec" ,python-pathspec)
+ ("python-mypy-extensions" ,python-mypy-extensions)
("python-regex" ,python-regex)
("python-toml" ,python-toml)
- ("python-typed-ast" ,python-typed-ast)))
+ ("python-typed-ast" ,python-typed-ast)
+ ("python-typing-extensions" ,python-typing-extensions)))
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)))
(home-page "https://github.com/ambv/black")
--
2.28.0
L
L
Ludovic Courtès wrote on 23 Oct 2020 16:36
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 44136-done@debbugs.gnu.org)
878sbxnh4k.fsf@gnu.org
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/python-xyz.scm (python-black): Update to 20.8b1.
> [arguments] Set PATH to make 1 test pass. Disable 1 failing test.
> [propagated-inputs] Add python-mypy-extensions and python-typing-extensions.

Applied, thanks!

Ludo’.
Closed
T
T
Tanguy Le Carrour wrote on 23 Oct 2020 17:49
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 44136-done@debbugs.gnu.org)
20201023154910.xmkreyepsqjo7tn5@melmoth
Le 10/23, Ludovic Court�s a �crit :
Toggle quote (10 lines)
> Hi,
>
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
>
> > * gnu/packages/python-xyz.scm (python-black): Update to 20.8b1.
> > [arguments] Set PATH to make 1 test pass. Disable 1 failing test.
> > [propagated-inputs] Add python-mypy-extensions and python-typing-extensions.
>
> Applied, thanks!

Thanks!

--
Tanguy
Closed
?