[PATCH] gnu: Add emacs-wucuo.

  • Done
  • quality assurance status badge
Details
3 participants
  • Joseph LaFreniere
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Joseph LaFreniere
Severity
normal
J
J
Joseph LaFreniere wrote on 20 Oct 2020 05:26
(address . guix-patches@gnu.org)
878sc1k27o.fsf@odyssey.lafreniere.xyz
Patch file is attached. There were some warnings during build
about functions not being defined. I believe this is just an
issue of missing autoload declarations, and I have reported the
warning to the package's author.

--
Joseph LaFreniere
From dd7a1229340ee282af047689a41f95b0f1dbaf7f Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Mon, 19 Oct 2020 22:21:04 -0500
Subject: [PATCH] gnu: Add emacs-wucuo.

* gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable.
---
gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++++++++++++++++++++++
1 file changed, 62 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5acb8ce6ec..1530cc275f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8637,6 +8637,68 @@ current frame, disabling the mode line, and adding margins to the buffer that
restrict the text width to 80 characters.")
(license license:bsd-3)))
+(define-public emacs-wucuo
+ (package
+ (name "emacs-wucuo")
+ (version "0.2.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/redguardtoo/wucuo")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1iw4jdlqvki95gh7bzl7hjidc2kz9qyc1zjd7klh63gvk0z09700"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/redguardtoo/wucuo")
+ (synopsis
+ "Fastest solution to spell check camel case code or plain text")
+ (description
+ "This package provides a spell checker on top of either aspell or
+hunspell.
+
+@itemize
+@item @code{wucuo-spell-check-file} will spell check one file and report its
+typos
+@item If @code{wucuo-flyspell-start-mode} is \"normal\", @code{wucuo-start}
+runs @code{flyspell-buffer}. If it's \"normal\", @code{wucuo-start} runs
+@code{flyspell-region} to check visible region in current window.
+@item The interval of checking is set by @code{wucuo-update-interval}
+@end itemize
+
+See @code{wucuo-check-nil-font-face} on how to check plain text (text without
+font)
+@itemize
+@item Use @code{wucuo-current-font-face} to detect font face at point
+@item If @code{wucuo-flyspell-start-mode} is \"normal\",
+@code{wucuo-spell-check-buffer-max} specifies the maximum size of buffer to
+check. If @code{wucuo-flyspell-start-mode} is \"fast\",
+@code{wucuo-spell-check-region-max} specifies the maximum size of visible
+region to check.
+@item You can define a function in @code{wucuo-spell-check-buffer-predicate}.
+If the function returns t, the spell checking of current buffer will continue.
+If it returns nil, the spell checking is skipped.
+@end itemize
+
+Here is sample to skip checking in specified major modes,
+@lisp
+ (setq wucuo-spell-check-buffer-predicate
+ (lambda ()
+ (not (memq major-mode
+ '(dired-mode
+ log-edit-mode
+ compilation-mode
+ help-mode
+ profiler-report-mode
+ speedbar-mode
+ gud-mode
+ calc-mode
+ Info-mode)))))
+@end lisp")
+ (license license:gpl3+)))
+
(define-public emacs-ido-completing-read+
(package
(name "emacs-ido-completing-read+")
--
2.28.0
N
N
Nicolas Goaziou wrote on 20 Oct 2020 12:11
(name . Joseph LaFreniere)(address . joseph@lafreniere.xyz)(address . 44089@debbugs.gnu.org)
878sc18aw5.fsf@nicolasgoaziou.fr
Hello,

Joseph LaFreniere <joseph@lafreniere.xyz> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add emacs-wucuo.
>
> * gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable.

Thank you. Some comments follow.

Toggle quote (2 lines)
> + (version "0.2.7")

Based on your feedback, upstream released 0.2.8 a few hours ago.

Toggle quote (4 lines)
> + (sha256
> + (base32
> + "1iw4jdlqvki95gh7bzl7hjidc2kz9qyc1zjd7klh63gvk0z09700"))))

Nitpick: please move the string on the same line as `base32'.

Toggle quote (5 lines)
> + (build-system emacs-build-system)
> + (home-page "https://github.com/redguardtoo/wucuo")
> + (synopsis
> + "Fastest solution to spell check camel case code or plain text")

Please move the string on the same line as `synopsis'. Also, "fastest"
sounds like a buzzword. I think "Fast" would be more neutral.

Toggle quote (43 lines)
> + (description
> + "This package provides a spell checker on top of either aspell or
> +hunspell.
> +
> +@itemize
> +@item @code{wucuo-spell-check-file} will spell check one file and report its
> +typos
> +@item If @code{wucuo-flyspell-start-mode} is \"normal\", @code{wucuo-start}
> +runs @code{flyspell-buffer}. If it's \"normal\", @code{wucuo-start} runs
> +@code{flyspell-region} to check visible region in current window.
> +@item The interval of checking is set by @code{wucuo-update-interval}
> +@end itemize
> +
> +See @code{wucuo-check-nil-font-face} on how to check plain text (text without
> +font)
> +@itemize
> +@item Use @code{wucuo-current-font-face} to detect font face at point
> +@item If @code{wucuo-flyspell-start-mode} is \"normal\",
> +@code{wucuo-spell-check-buffer-max} specifies the maximum size of buffer to
> +check. If @code{wucuo-flyspell-start-mode} is \"fast\",
> +@code{wucuo-spell-check-region-max} specifies the maximum size of visible
> +region to check.
> +@item You can define a function in @code{wucuo-spell-check-buffer-predicate}.
> +If the function returns t, the spell checking of current buffer will continue.
> +If it returns nil, the spell checking is skipped.
> +@end itemize
> +
> +Here is sample to skip checking in specified major modes,
> +@lisp
> + (setq wucuo-spell-check-buffer-predicate
> + (lambda ()
> + (not (memq major-mode
> + '(dired-mode
> + log-edit-mode
> + compilation-mode
> + help-mode
> + profiler-report-mode
> + speedbar-mode
> + gud-mode
> + calc-mode
> + Info-mode)))))
> +@end lisp")

I think most of this belongs to the manual, not to the description. What
about:

This package provides a spell checker on top of either Aspell or
Hunspell, and relies on Flyspell internally. It operates on the
current region or buffer, a file, or a complete directory.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
L
L
Ludovic Courtès wrote on 18 Nov 2020 23:12
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87y2iyiabh.fsf@gnu.org
Hi Joseph,

A friendly reminder. :-)


Ludo’.

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

Toggle quote (81 lines)
> Hello,
>
> Joseph LaFreniere <joseph@lafreniere.xyz> writes:
>
>> Subject: [PATCH] gnu: Add emacs-wucuo.
>>
>> * gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable.
>
> Thank you. Some comments follow.
>
>> + (version "0.2.7")
>
> Based on your feedback, upstream released 0.2.8 a few hours ago.
>
>> + (sha256
>> + (base32
>> + "1iw4jdlqvki95gh7bzl7hjidc2kz9qyc1zjd7klh63gvk0z09700"))))
>
> Nitpick: please move the string on the same line as `base32'.
>
>> + (build-system emacs-build-system)
>> + (home-page "https://github.com/redguardtoo/wucuo")
>> + (synopsis
>> + "Fastest solution to spell check camel case code or plain text")
>
> Please move the string on the same line as `synopsis'. Also, "fastest"
> sounds like a buzzword. I think "Fast" would be more neutral.
>
>> + (description
>> + "This package provides a spell checker on top of either aspell or
>> +hunspell.
>> +
>> +@itemize
>> +@item @code{wucuo-spell-check-file} will spell check one file and report its
>> +typos
>> +@item If @code{wucuo-flyspell-start-mode} is \"normal\", @code{wucuo-start}
>> +runs @code{flyspell-buffer}. If it's \"normal\", @code{wucuo-start} runs
>> +@code{flyspell-region} to check visible region in current window.
>> +@item The interval of checking is set by @code{wucuo-update-interval}
>> +@end itemize
>> +
>> +See @code{wucuo-check-nil-font-face} on how to check plain text (text without
>> +font)
>> +@itemize
>> +@item Use @code{wucuo-current-font-face} to detect font face at point
>> +@item If @code{wucuo-flyspell-start-mode} is \"normal\",
>> +@code{wucuo-spell-check-buffer-max} specifies the maximum size of buffer to
>> +check. If @code{wucuo-flyspell-start-mode} is \"fast\",
>> +@code{wucuo-spell-check-region-max} specifies the maximum size of visible
>> +region to check.
>> +@item You can define a function in @code{wucuo-spell-check-buffer-predicate}.
>> +If the function returns t, the spell checking of current buffer will continue.
>> +If it returns nil, the spell checking is skipped.
>> +@end itemize
>> +
>> +Here is sample to skip checking in specified major modes,
>> +@lisp
>> + (setq wucuo-spell-check-buffer-predicate
>> + (lambda ()
>> + (not (memq major-mode
>> + '(dired-mode
>> + log-edit-mode
>> + compilation-mode
>> + help-mode
>> + profiler-report-mode
>> + speedbar-mode
>> + gud-mode
>> + calc-mode
>> + Info-mode)))))
>> +@end lisp")
>
> I think most of this belongs to the manual, not to the description. What
> about:
>
> This package provides a spell checker on top of either Aspell or
> Hunspell, and relies on Flyspell internally. It operates on the
> current region or buffer, a file, or a complete directory.
>
> Could you send an updated patch?
>
> Regards,
J
J
Joseph LaFreniere wrote on 8 May 2021 23:32
(address . 44089@debbugs.gnu.org)
87k0o8j4hl.fsf@lafreniere.xyz
New patch is attached for 0.2.9.

--
Joseph LaFreniere
From c622bbce2d758757eac573d822c8f913b8a81123 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Mon, 19 Oct 2020 22:21:04 -0500
Subject: [PATCH] gnu: Add emacs-wucuo.

* gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable.
---
gnu/packages/emacs-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 869f8c3c7b..c5c1f80ce1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -130,6 +130,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages aspell)
#:use-module (gnu packages audio)
#:use-module (gnu packages bash)
#:use-module (gnu packages cmake)
@@ -9827,6 +9828,41 @@ current frame, disabling the mode line, and adding margins to the buffer that
restrict the text width to 80 characters.")
(license license:bsd-3)))
+(define-public emacs-wucuo
+ (package
+ (name "emacs-wucuo")
+ (version "0.2.9")
+ (home-page "https://github.com/redguardtoo/wucuo")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit "89b99166768afb811c48a7db7c93c02d51a32b09")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03a6jlbv9axrd9yr0xscq3ni7fipm20ppc51kxy0sn241rplv0pg"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("make" "test")
+ #:phases (modify-phases %standard-phases
+ ;; Set HOME, otherwise tests fail on loading aspell dict.
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" (getcwd))
+ #t)))))
+ (native-inputs
+ ;; For tests.
+ `(("aspell" ,aspell)
+ ("aspell-dict-en" ,aspell-dict-en)))
+ (synopsis "Fast spell checker for camel case code or plain text")
+ (description
+ "This package provides a spell checker on top of either Aspell or
+Hunspell, and relies on Flyspell internally. It operates on the current
+region or buffer, a file, or a complete directory.")
+ (license license:gpl3+)))
+
(define-public emacs-ido-completing-read+
(package
(name "emacs-ido-completing-read+")
--
2.31.1
N
N
Nicolas Goaziou wrote on 14 May 2021 23:52
(name . Joseph LaFreniere)(address . joseph@lafreniere.xyz)(address . 44089-done@debbugs.gnu.org)
87pmxtt22y.fsf@nicolasgoaziou.fr
Hello,

Joseph LaFreniere <joseph@lafreniere.xyz> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add emacs-wucuo.
>
> * gnu/packages/emacs-xyz.scm (emacs-wucuo): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?