[PATCH] gnu: emacs-request: Update to latest commit.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Nicolas Goaziou
  • Niklas Eklund
Owner
unassigned
Submitted by
Niklas Eklund
Severity
normal
N
N
Niklas Eklund wrote on 15 Oct 2020 22:31
(address . guix-patches@gnu.org)
875z7bp6yi.fsf@posteo.net
This patch updates emacs-request to the latest commit on git. The reason for
updating the package is that early this year a patch was merged which allowed
emacs-request to utilize the auth-source package providing a more convenient
experience for users and package developers.
From 7236dcf7c836cec8562df3d47ba8c2bc27bfdf0d Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Thu, 15 Oct 2020 22:23:58 +0200
Subject: [PATCH] gnu: emacs-request: Update to latest commit.

* gnu/packages/emacs-xyz.scm (emacs-request): Update to latest commit.
---
gnu/packages/emacs-xyz.scm | 44 ++++++++++++++++++++------------------
1 file changed, 23 insertions(+), 21 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 09984bc704..cbdc9d4234 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6910,29 +6910,31 @@ parallel.")
(license license:gpl3+)))
(define-public emacs-request
- (package
- (name "emacs-request")
- (version "0.3.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tkf/emacs-request")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1djywhvvb6kwdj0nd3axjvb7k2g06dzkc6hsf29w9rsk96vr8ryl"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #f)) ; requires network access.
- (propagated-inputs
- `(("emacs-deferred" ,emacs-deferred)))
- (home-page "https://github.com/tkf/emacs-request")
- (synopsis "Package for speaking HTTP in Emacs Lisp")
- (description "This package provides a HTTP request library with multiple
+ (let ((commit "d02d1347ffdf138cffd380cbeac62ac8732036ef")
+ (revision "0"))
+ (package
+ (name "emacs-request")
+ (version (git-version "0.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tkf/emacs-request")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rkpakzish2d470ca15yq3k0m1j7a2lrkvvddcyvc2rx0sncsdjs"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #f)) ; requires network access.
+ (propagated-inputs
+ `(("emacs-deferred" ,emacs-deferred)))
+ (home-page "https://github.com/tkf/emacs-request")
+ (synopsis "Package for speaking HTTP in Emacs Lisp")
+ (description "This package provides a HTTP request library with multiple
backends. It supports url.el which is shipped with Emacs and the curl command
line program.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-rudel
(package
--
2.28.0
N
N
Nicolas Goaziou wrote on 15 Oct 2020 23:54
(name . Niklas Eklund)(address . niklas.eklund@posteo.net)(address . 44024@debbugs.gnu.org)
87ft6fb1ek.fsf@nicolasgoaziou.fr
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

Toggle quote (5 lines)
> This patch updates emacs-request to the latest commit on git. The reason for
> updating the package is that early this year a patch was merged which allowed
> emacs-request to utilize the auth-source package providing a more convenient
> experience for users and package developers.

Thank you.

Could you add a comment explaining the above at the top of the package
definition and send it again?

Regards,
--
Nicolas Goaziou
N
N
Niklas Eklund wrote on 18 Oct 2020 21:01
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44024@debbugs.gnu.org)
87v9f78iki.fsf@posteo.net
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (18 lines)
> Hello,
>
> Niklas Eklund <niklas.eklund@posteo.net> writes:
>
>> This patch updates emacs-request to the latest commit on git. The reason for
>> updating the package is that early this year a patch was merged which allowed
>> emacs-request to utilize the auth-source package providing a more convenient
>> experience for users and package developers.
>
> Thank you.
>
> Could you add a comment explaining the above at the top of the package
> definition and send it again?
>
> Regards,
> --
> Nicolas Goaziou

Absolutely, I wasn't sure if I were to put it in the code or not, but
now I know for the future.

Cheers,
Niklas
From 0feb4bd289c7bab7b82e4d2f37fc7247acda6f6e Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Wed, 30 Sep 2020 15:34:36 +0200
Subject: [PATCH v2] gnu: Add emacs-gcmh.

* gnu/packages/emacs-xyz.scm (emacs-gcmh): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 13471f77d1..575ee25308 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1768,6 +1768,31 @@ always indented. It reindents after every change, making it more reliable
than @code{electric-indent-mode}.")
(license license:gpl2+)))
+(define-public emacs-gcmh
+ (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
+ (revision "0"))
+ (package
+ (name "emacs-gcmh")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/koral/gcmh")
+ (commit commit)))
+ (sha256
+ (base32 "1r3wiqhrzh7wvqy484nl031fd4bn4cpvkv9646s4cjgvnnnv7jz3"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/koral/gcmh")
+ (synopsis "Emacs Garbage Collector Magic Hack")
+ (description
+ "This package enforces a sneaky @dfn{garbage collector} (GC) strategy
+to minimize GC interference with the activity. During normal use a high GC
+threshold is set. When idling GC is immediately triggered and a low threshold
+is set.")
+ (license license:gpl3+))))
+
(define-public emacs-ctrlf
(package
(name "emacs-ctrlf")
--
2.28.0
L
L
Ludovic Courtès wrote on 18 Nov 2020 23:09
(name . Niklas Eklund)(address . niklas.eklund@posteo.net)
877dqijp11.fsf@gnu.org
Hi,

Niklas Eklund <niklas.eklund@posteo.net> skribis:

Toggle quote (23 lines)
> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>
>> Hello,
>>
>> Niklas Eklund <niklas.eklund@posteo.net> writes:
>>
>>> This patch updates emacs-request to the latest commit on git. The reason for
>>> updating the package is that early this year a patch was merged which allowed
>>> emacs-request to utilize the auth-source package providing a more convenient
>>> experience for users and package developers.
>>
>> Thank you.
>>
>> Could you add a comment explaining the above at the top of the package
>> definition and send it again?
>>
>> Regards,
>> --
>> Nicolas Goaziou
>
> Absolutely, I wasn't sure if I were to put it in the code or not, but
> now I know for the future.

[...]

Toggle quote (4 lines)
> +(define-public emacs-gcmh
> + (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
> + (revision "0"))

Looks like you forgot the comment. :-)

Could you send an updated patch? (Else we can do it for you.)

Thanks,
Ludo’.
N
N
Niklas Eklund wrote on 19 Nov 2020 09:58
(name . Ludovic Courtès)(address . ludo@gnu.org)
87eekpwwnf.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (14 lines)
> Hi,
>
>> +(define-public emacs-gcmh
>> + (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
>> + (revision "0"))
>
> Looks like you forgot the comment. :-)
>
> Could you send an updated patch? (Else we can do it for you.)

>
> Thanks,
> Ludo’.

Hi Ludo,

I could have sworn I updated that, must be something that I have done
wrong here :O.

I will make a new atempt, in this message attaching a new patch. If that
still fails feel free to make the change :)
From 75bfe74c5e150b5aca294c7b51e94d63b188dbe7 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Thu, 15 Oct 2020 22:23:58 +0200
Subject: [PATCH v3] gnu: emacs-request: Update to latest commit.

* gnu/packages/emacs-xyz.scm (emacs-request): Update to latest commit.
---
gnu/packages/emacs-xyz.scm | 46 +++++++++++++++++++++-----------------
1 file changed, 25 insertions(+), 21 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 09984bc704..e88119ea43 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6910,29 +6910,33 @@ parallel.")
(license license:gpl3+)))
(define-public emacs-request
- (package
- (name "emacs-request")
- (version "0.3.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tkf/emacs-request")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1djywhvvb6kwdj0nd3axjvb7k2g06dzkc6hsf29w9rsk96vr8ryl"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #f)) ; requires network access.
- (propagated-inputs
- `(("emacs-deferred" ,emacs-deferred)))
- (home-page "https://github.com/tkf/emacs-request")
- (synopsis "Package for speaking HTTP in Emacs Lisp")
- (description "This package provides a HTTP request library with multiple
+ ;; We prefer a more recent commit that has support for auth-source,
+ ;; which makes authentication more convenient for users and maintainers.
+ (let ((commit "d02d1347ffdf138cffd380cbeac62ac8732036ef")
+ (revision "0"))
+ (package
+ (name "emacs-request")
+ (version (git-version "0.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tkf/emacs-request")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rkpakzish2d470ca15yq3k0m1j7a2lrkvvddcyvc2rx0sncsdjs"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #f)) ; requires network access.
+ (propagated-inputs
+ `(("emacs-deferred" ,emacs-deferred)))
+ (home-page "https://github.com/tkf/emacs-request")
+ (synopsis "Package for speaking HTTP in Emacs Lisp")
+ (description "This package provides a HTTP request library with multiple
backends. It supports url.el which is shipped with Emacs and the curl command
line program.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-rudel
(package
--
2.28.0
Thanks,
Niklas
N
N
Nicolas Goaziou wrote on 19 Nov 2020 21:28
(name . Niklas Eklund)(address . niklas.eklund@posteo.net)
87h7pldray.fsf@nicolasgoaziou.fr
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-request): Update to latest commit.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?