[SHEPHERD PATCH] shepherd: Move log file to XDG_CACHE_DIR.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Jan Nieuwenhuizen
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 11 Oct 2020 11:20
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20201011092017.31901-1-efraim@flashner.co.il
* modules/shepherd/support.scm (%user-log-dir): New variable.
(user-default-log-file): Use it.
* doc/shepherd.texi: (Invoking shepherd): Adjust listed default log
file.
* tests/basic.sh: Adjust for separate log directory.
---
doc/shepherd.texi | 2 +-
modules/shepherd/support.scm | 10 ++++++++--
tests/basic.sh | 4 ++++
3 files changed, 13 insertions(+), 3 deletions(-)

Toggle diff (70 lines)
diff --git a/doc/shepherd.texi b/doc/shepherd.texi
index 696477e..0c3901e 100644
--- a/doc/shepherd.texi
+++ b/doc/shepherd.texi
@@ -417,7 +417,7 @@ permissions are not as expected.
Log output into @var{file}.
For unprivileged users, the default log file is
-@file{$XDG_CONFIG_HOME/shepherd/shepherd.log}.
+@file{$XDG_CACHE_DIR/shepherd/shepherd.log}.
@cindex syslog
When running as root, the default behavior is to connect to
diff --git a/modules/shepherd/support.scm b/modules/shepherd/support.scm
index cdb7b35..008b280 100644
--- a/modules/shepherd/support.scm
+++ b/modules/shepherd/support.scm
@@ -271,6 +271,12 @@ There is NO WARRANTY, to the extent permitted by law.")))
(string-append user-homedir "/.config"))
"/shepherd"))
+(define %user-log-dir
+ ;; Default log directory if shepherd is run as a normal user.
+ (string-append (or (getenv "XDG_CACHE_DIR")
+ (string-append user-homedir "/.cache"))
+ "/shepherd"))
+
(define %user-runtime-dir
;; Default runtime directory if shepherd is run as a normal user.
(string-append (or (getenv "XDG_RUNTIME_DIR")
@@ -302,8 +308,8 @@ TARGET should be a string representing a filepath + name."
;; Logging.
(define (user-default-log-file)
"Return the file name of the user's default log file."
- (mkdir-p %user-config-dir #o700)
- (string-append %user-config-dir "/shepherd.log"))
+ (mkdir-p %user-log-dir #o700)
+ (string-append %user-log-dir "/shepherd.log"))
(define default-logfile-date-format
;; 'strftime' format string to prefix each entry in the log.
diff --git a/tests/basic.sh b/tests/basic.sh
index a6148fc..145c0d3 100644
--- a/tests/basic.sh
+++ b/tests/basic.sh
@@ -24,6 +24,7 @@ herd --version
socket="t-socket-$$"
conf="t-conf-$$"
confdir="t-confdir-$$"
+cachedir="t-cachedir-$$"
log="t-log-$$"
stamp="t-stamp-$$"
pid="t-pid-$$"
@@ -259,7 +260,9 @@ test -f "$log"
# Set XDG_CONFIG_HOME for configuration files.
export XDG_CONFIG_HOME=$confdir
+export XDG_CACHE_DIR=$cachedir
mkdir -p $confdir/shepherd
+mkdir -p $cachedir/shepherd
mv $conf $confdir/shepherd/init.scm
rm -f "$pid" "$socket"
shepherd -I -s "$socket" --pid="$pid" &
@@ -281,3 +284,4 @@ $herd stop root
! kill -0 $shepherd_pid
rm -rf $confdir
+rm -rf $cachedir
--
2.28.0
L
L
Ludovic Courtès wrote on 22 Oct 2020 16:23
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 43920@debbugs.gnu.org)
87imb2tk3m.fsf@gnu.org
Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (6 lines)
> * modules/shepherd/support.scm (%user-log-dir): New variable.
> (user-default-log-file): Use it.
> * doc/shepherd.texi: (Invoking shepherd): Adjust listed default log
> file.
> * tests/basic.sh: Adjust for separate log directory.

[...]

Toggle quote (4 lines)
> For unprivileged users, the default log file is
> -@file{$XDG_CONFIG_HOME/shepherd/shepherd.log}.
> +@file{$XDG_CACHE_DIR/shepherd/shepherd.log}.

The previous location wasn’t perfect, but the proposed one isn’t great
either: one can generally assume “rm -rf ~/.cache” won’t lose anything
that cannot be reconstructed, and the log is something that cannot be
reconstructed.

Do the XDG spec have something else that might be more appropriate?

Thanks,
Ludo’.
L
L
Leo Prikler wrote on 24 Oct 2020 00:17
[bug#43920] [SHEPHERD PATCH] shepherd: Move log file to XDG_CACHE_DIR.
(address . ludo@gnu.org)(address . 43920@debbugs.gnu.org)
bbe34857052850f4ee224602320079d38eb837b6.camel@student.tugraz.at
Toggle quote (6 lines)
> The previous location wasn’t perfect, but the proposed one isn’t
> great
> either: one can generally assume “rm -rf ~/.cache” won’t lose
> anything
> that cannot be reconstructed, and the log is something that cannot be
> reconstructed.
That is actually not part of the XDG specification – it merely states,
that non-essential files be put there. Whether or not one considers
the shepherd log essential is debatable.

You could alternatively put it under $XDG_DATA_HOME. Some projects
like Xorg seem to do that. Of course, there always remains the option
of having yet another environment variable or command line parameter
for the placement of the log file.

Regards, Leo
L
L
Ludovic Courtès wrote on 24 Oct 2020 18:15
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87h7qjiore.fsf@gnu.org
Hi,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (10 lines)
>> The previous location wasn’t perfect, but the proposed one isn’t
>> great
>> either: one can generally assume “rm -rf ~/.cache” won’t lose
>> anything
>> that cannot be reconstructed, and the log is something that cannot be
>> reconstructed.
> That is actually not part of the XDG specification – it merely states,
> that non-essential files be put there. Whether or not one considers
> the shepherd log essential is debatable.

Right, that’s my interpretation of what “cache” means.

Toggle quote (5 lines)
> You could alternatively put it under $XDG_DATA_HOME. Some projects
> like Xorg seem to do that. Of course, there always remains the option
> of having yet another environment variable or command line parameter
> for the placement of the log file.

Yup, XDG_DATA_HOME would work for me; it seems to be rather in line with
what the XDG states and what Xorg does, as you note.


WDYT, Efraim & Janneke?

Ludo’.
E
E
Efraim Flashner wrote on 24 Oct 2020 18:51
5115DA89-FC2F-4B00-8F3B-D461908E1775@flashner.co.il
On October 24, 2020 4:15:33 PM UTC, "Ludovic Courtès" <ludo@gnu.org> wrote:
Toggle quote (17 lines)
>Hi,
>
>Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
>>> The previous location wasn’t perfect, but the proposed one isn’t
>>> great
>>> either: one can generally assume “rm -rf ~/.cache” won’t lose
>>> anything
>>> that cannot be reconstructed, and the log is something that cannot be
>>> reconstructed.
>> That is actually not part of the XDG specification – it merely states,
>> that non-essential files be put there. Whether or not one considers
>> the shepherd log essential is debatable.
>
>Right, that’s my interpretation of what “cache” means.
>

I felt like it belongs in cache much more than in a config dir.

Toggle quote (12 lines)
>> You could alternatively put it under $XDG_DATA_HOME. Some projects
>> like Xorg seem to do that. Of course, there always remains the option
>> of having yet another environment variable or command line parameter
>> for the placement of the log file.
>
>Yup, XDG_DATA_HOME would work for me; it seems to be rather in line with
>what the XDG states and what Xorg does, as you note.
>
> https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html
>
>WDYT, Efraim & Janneke?

I don't think it's really data, it's not like it belongs in something/share. As another data point keybase writes its (verbose) logs in .cache/keybase.

Toggle quote (3 lines)
>
>Ludo’.

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.
J
J
Jan Nieuwenhuizen wrote on 25 Oct 2020 00:58
(name . Ludovic Courtès)(address . ludo@gnu.org)
87zh4b44fm.fsf@gnu.org
Ludovic Courtès writes:

Hello,

Toggle quote (14 lines)
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
>>> The previous location wasn’t perfect, but the proposed one isn’t
>>> great
>>> either: one can generally assume “rm -rf ~/.cache” won’t lose
>>> anything
>>> that cannot be reconstructed, and the log is something that cannot be
>>> reconstructed.
>> That is actually not part of the XDG specification – it merely states,
>> that non-essential files be put there. Whether or not one considers
>> the shepherd log essential is debatable.
>
> Right, that’s my interpretation of what “cache” means.

Yes, essential is pretty vague; a cache is something that can be
re-generated.

Toggle quote (12 lines)
>> You could alternatively put it under $XDG_DATA_HOME. Some projects
>> like Xorg seem to do that. Of course, there always remains the option
>> of having yet another environment variable or command line parameter
>> for the placement of the log file.
>
> Yup, XDG_DATA_HOME would work for me; it seems to be rather in line with
> what the XDG states and what Xorg does, as you note.
>
> https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html
>
> WDYT, Efraim & Janneke?

Data sounds a bit strong (I would consider a database to be data), and
cache is too loose. Otoh, losing a log can be crucial; so I'd go for
XDG_DATA_HOME.

Janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
L
L
Ludovic Courtès wrote on 26 Oct 2020 11:27
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87pn55cmdy.fsf@gnu.org
Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (2 lines)
> On October 24, 2020 4:15:33 PM UTC, "Ludovic Courtès" <ludo@gnu.org> wrote:

[...]

Toggle quote (7 lines)
>>>> The previous location wasn’t perfect, but the proposed one isn’t
>>>> great
>>>> either: one can generally assume “rm -rf ~/.cache” won’t lose
>>>> anything
>>>> that cannot be reconstructed, and the log is something that cannot be
>>>> reconstructed.

[...]

Toggle quote (2 lines)
> I don't think it's really data, it's not like it belongs in something/share. As another data point keybase writes its (verbose) logs in .cache/keybase.

To me the question whether it’s OK to lose the log. In a way, storing
the log in ~/.cache akin to storing it in /tmp.

If we agree on that, then we have the choice between ~/.local/share
aka. XDG_DATA_HOME (like Xorg does), or maybe using ~/.local/var/log or
something similar that goes beyond XDG?

Thoughts?

Naming directories is hard. :-)

Ludo’.
L
L
Ludovic Courtès wrote on 18 Nov 2020 22:35
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87wnyijqkw.fsf@gnu.org
Hi,

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (24 lines)
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
>> On October 24, 2020 4:15:33 PM UTC, "Ludovic Courtès" <ludo@gnu.org> wrote:
>
> [...]
>
>>>>> The previous location wasn’t perfect, but the proposed one isn’t
>>>>> great
>>>>> either: one can generally assume “rm -rf ~/.cache” won’t lose
>>>>> anything
>>>>> that cannot be reconstructed, and the log is something that cannot be
>>>>> reconstructed.
>
> [...]
>
>> I don't think it's really data, it's not like it belongs in something/share. As another data point keybase writes its (verbose) logs in .cache/keybase.
>
> To me the question whether it’s OK to lose the log. In a way, storing
> the log in ~/.cache akin to storing it in /tmp.
>
> If we agree on that, then we have the choice between ~/.local/share
> aka. XDG_DATA_HOME (like Xorg does), or maybe using ~/.local/var/log or
> something similar that goes beyond XDG?

I pushed a variant of your patch that uses XDG_DATA_HOME instead:


There’s a now ‘%user-log-dir’ so it’ll be easier to adjust going
forward if we change our mind.

Thanks,
Ludo’.
Closed
?