[PATCH 0/3] Update python-breathe and dependencies

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal
S
S
Simon South wrote on 11 Oct 2020 00:21
(address . guix-patches@gnu.org)(name . Simon South)(address . simon@simonsouth.net)
cover.1602367454.git.simon@simonsouth.net
These patches update the python-breathe package and two of its
dependencies, python-sphinx and python-six, to their latest available
version. (python-docutils is already up-to-date.)

Note "guix refresh --list-dependent" reports that python-breathe,
python-sphinx and python-six have 1, 363 and 6,538 dependent packages,
respectively.

--
Simon South
simon@simonsouth.net


Simon South (3):
gnu: python-six: Update to 1.15.0.
gnu: python-sphinx: Update to 3.2.1.
gnu: python-breathe: Update to 4.22.1.

gnu/packages/python-xyz.scm | 4 ++--
gnu/packages/sphinx.scm | 8 ++++----
2 files changed, 6 insertions(+), 6 deletions(-)

--
2.28.0
S
S
Simon South wrote on 11 Oct 2020 00:24
[PATCH 1/3] gnu: python-six: Update to 1.15.0.
(address . 43915@debbugs.gnu.org)(name . Simon South)(address . simon@simonsouth.net)
8c723c428f0887ed89067d00c0e4b57fd922d5a8.1602367454.git.simon@simonsouth.net
* gnu/packages/python-xyz.scm (python-six): Update to 1.15.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 25eaf4a625..cd75a0cd26 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1706,14 +1706,14 @@ from the Python interpreter, or as a small part of a larger application.")
(define-public python-six
(package
(name "python-six")
- (version "1.14.0")
+ (version "1.15.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "six" version))
(sha256
(base32
- "02lw67hprv57hyg3cfy02y3ixjk3nzwc0dx3c4ynlvkfwkfdnsr3"))))
+ "0n82108wxn5giff50hd9ykjhd3zl7cndabdasi6568yvbh1rqqrh"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.28.0
S
S
Simon South wrote on 11 Oct 2020 00:24
[PATCH 2/3] gnu: python-sphinx: Update to 3.2.1.
(address . 43915@debbugs.gnu.org)(name . Simon South)(address . simon@simonsouth.net)
0f1bfed3b1e2bbff6e32baa264cb3585efd9c69b.1602367454.git.simon@simonsouth.net
* gnu/packages/sphinx.scm (python-sphinx): Update to 3.2.1.
---
gnu/packages/sphinx.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index f27f9d0176..476632a378 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -48,14 +48,14 @@
(define-public python-sphinx
(package
(name "python-sphinx")
- (version "2.3.1")
+ (version "3.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Sphinx" version))
(sha256
(base32
- "19a28nsb0w4bs6k8rdfyk6vzrcwdpvhs2wq77rgpmww59yvndrz6"))))
+ "1s70hxhddzf656kmj01lws4cbywgsinbg8750r9ilf7s2sdns79j"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.28.0
S
S
Simon South wrote on 11 Oct 2020 00:24
[PATCH 3/3] gnu: python-breathe: Update to 4.22.1.
(address . 43915@debbugs.gnu.org)(name . Simon South)(address . simon@simonsouth.net)
ae1326f6541168b8533477662f8927fd2352bb7c.1602367454.git.simon@simonsouth.net
* gnu/packages/sphinx.scm (python-breathe): Update to 4.22.1.
---
gnu/packages/sphinx.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 476632a378..bdfe82d93e 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -556,14 +556,14 @@ and several other projects.")
(define-public python-breathe
(package
(name "python-breathe")
- (version "4.13.1")
+ (version "4.22.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "breathe" version))
(sha256
(base32
- "1aw749n2ry27434qd7gr99dvsrs3x3chyi9aywmhjj1g4m2j6xf6"))))
+ "0snk538xv60z4vfhl3f7v5g658za7257hddkg07cknkn33k6cjvf"))))
(build-system python-build-system)
(propagated-inputs
`(("python-docutils" ,python-docutils)
--
2.28.0
S
S
Simon South wrote on 11 Oct 2020 00:28
Re: [PATCH 0/3] Update python-breathe and dependencies
(address . 43915@debbugs.gnu.org)
87ft6llnra.fsf@simonsouth.net
Simon South <simon@simonsouth.net> writes:
Toggle quote (4 lines)
> Note "guix refresh --list-dependent" reports that python-breathe,
> python-sphinx and python-six have 1, 363 and 6,538 dependent packages,
> respectively.

...and as soon as I hit "send" I notice this in the Guix manual:

...if your patch is to be applied on a branch other than ‘master’,
say ‘core-updates’, specify it in the subject like ‘[PATCH
core-updates] ...’.

I can resend if desired, and I'll follow this convention in the future.

--
Simon South
simon@simonsouth.net
C
C
Christopher Baines wrote on 23 Oct 2020 23:48
Re: [bug#43915] [PATCH 0/3] Update python-breathe and dependencies
(name . Simon South)(address . simon@simonsouth.net)(address . 43915@debbugs.gnu.org)
87y2jw1ung.fsf@cbaines.net
Simon South <simon@simonsouth.net> writes:

Toggle quote (13 lines)
> Simon South <simon@simonsouth.net> writes:
>> Note "guix refresh --list-dependent" reports that python-breathe,
>> python-sphinx and python-six have 1, 363 and 6,538 dependent packages,
>> respectively.
>
> ...and as soon as I hit "send" I notice this in the Guix manual:
>
> ...if your patch is to be applied on a branch other than ‘master’,
> say ‘core-updates’, specify it in the subject like ‘[PATCH
> core-updates] ...’.
>
> I can resend if desired, and I'll follow this convention in the future.

No problem :)

I've pushed the python-six change to the core-updates branch as
6f95911ad175a836fbd5aaa42a8aecb0fc335a1e.

Given the python-sphinx change is a major version update, I was unsure
about pushing it to master, at least without testing whether any of the
363 dependent packages are broken by this change.

I think the staging branch is also frozen. I'll investigate tomorrow
about starting a new staging branch...
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+TT5NfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf0mhAAixUa+NB1ckb8kMYL6mJI3KjFMDHfztP7
GBXsSFOP6i9/1qmQ8XedxUUj3EaCWMQT0wvcaQ5b8Ay3l/09NMANlnzPxad0xdTh
waQI73tx6WSLt4ixSojyg/QliGy5irodHzz8eRt2pu4nbN9GXTt9l8sWHJ5Gpu80
D0RhPmrzb3wzNkYSViehqDPEoS0fG3VwKno6BuPIuUe2XSrEI87OAj2gC3SWuF6k
VJv1ehHG9UI93oXTz3Ok5QMnHoqQeUBWa/rRGeJiF2WWzwMHpISl3c/gcG7lwePd
vOp9EGprF8LGmFjMNme/7zUTaxNxgi6kKO4MvMCI8ptH8/JptVhz1f4bHxAZVb/2
u/KqD+1wcjsyahMNlJYJaZF15iRcUalJjLZDf/SvVyH97HtOVPyeIVbWqImbK+VN
v9x1ymH/rhPZEzvw5b+bhg5uyvqEHCLZGHwVUlqHSeDmuyJBim6uGEMd/46nyRLc
i3yJPKyMyuB88ERA+/87Ekh7DQY7NAsmce64KCXbxr7H+Yy96BqAgN3ZJdVUlHS2
UHxOrsOlnSru8ZvcsOXSKFjpGIusA35OuvK+gk5+0PF2mNNfp/sKSnsgono3e361
4oakxuYom5iu8WoVGDZlb+SYj2pHdw4RTi/aJcXFQC5dMX1jIEZ3fjp94xzlSzVG
UV9nwV20SWg=
=GSHt
-----END PGP SIGNATURE-----

S
S
Simon South wrote on 24 Oct 2020 00:39
(name . Christopher Baines)(address . mail@cbaines.net)(address . 43915@debbugs.gnu.org)
87imb0bm8n.fsf@simonsouth.net
Christopher Baines <mail@cbaines.net> writes:
Toggle quote (3 lines)
> I've pushed the python-six change to the core-updates branch as
> 6f95911ad175a836fbd5aaa42a8aecb0fc335a1e.

Nice, thanks.

Toggle quote (4 lines)
> Given the python-sphinx change is a major version update, I was unsure
> about pushing it to master, at least without testing whether any of
> the 363 dependent packages are broken by this change.

Yes, after submitting the patch I realized: It's really too significant
a change for the amount of testing I've done on it. Better to hold off
for now I think, especially with the release coming up.

My interest really was in seeing python-breathe updated, as the new
version happens to fix a warning from Sphinx when generating Texinfo
output (and there's only one other package it affects, which I
definitely have tested). I thought updating its dependencies at the same
time would be a good idea but now I think it would be a bit reckless.

--
Simon South
simon@simonsouth.net
C
C
Christopher Baines wrote on 24 Oct 2020 22:17
(name . Simon South)(address . simon@simonsouth.net)(address . 43915@debbugs.gnu.org)
87k0vfbcqi.fsf@cbaines.net
Simon South <simon@simonsouth.net> writes:

Toggle quote (15 lines)
> Christopher Baines <mail@cbaines.net> writes:
>> Given the python-sphinx change is a major version update, I was unsure
>> about pushing it to master, at least without testing whether any of
>> the 363 dependent packages are broken by this change.
>
> Yes, after submitting the patch I realized: It's really too significant
> a change for the amount of testing I've done on it. Better to hold off
> for now I think, especially with the release coming up.
>
> My interest really was in seeing python-breathe updated, as the new
> version happens to fix a warning from Sphinx when generating Texinfo
> output (and there's only one other package it affects, which I
> definitely have tested). I thought updating its dependencies at the same
> time would be a good idea but now I think it would be a bit reckless.

I've gone ahead and created a staging-next branch with the python-sphinx
and python-breathe patches now.

I'll leave it up to you whether to close this bug, or leave it open
until the staging-next branch is merged.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+Ui8VfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XceUQ//UsvvI6ffgHY3PxppSsEILYNEg6ZM3IKn
OgPWwaDsB3lRmj/0WVSm1FXCNHgS5BsgX1voh3jAbKkQYeU/Fhoq0kEE9jv3IOhH
Ocg0fb1YyBmEy+meQSpO5xPlumflcmCfkeeMN7a9vAfYzVzwWtB7gbyxxj+FeoOd
nVlZYhOCbuZ/i90VoMxwC3MChsdz8wCsBcrJJixakVtpteWfbrOdUWPApubD2EhP
2NtZCVA6NNfNK7Eq4A9J9c2+aJ1Mp3hmxyRc+xefS6wNmiusi3iq/eS8Zaj/oeE2
p/NjiwMRJp+JY/8T1/ItMOikxxitglQqSXytmFFHpAB5W9X8Ue2F2vm3QyGZMzI7
AGcnR2NSiZ5wcW7n1Tpm8pcH1V708yF4MRHDIz3/kTRFwDqNY7N/NOLBkLZlJM6l
H5GNzNSuqocg3x1OWwYkqtevScddjbZOQltSuQvQSDSOYCRvQ38Zwy6ZZApAB5yV
hkrKnWdig0arwB6y8k1LpQsnz7zPGYjGsN/3wW+Jt5fj/a+rM/PtAkOq4Wl2AuS6
AhH34hzdb4m/k1Rejfg0VIiZmJ1GqZCmY6Va5uHaMN7KcPunNFoMIxgG6k7ChaFh
3KiFueh1U9MWlxqQZ5SVe+zVTpioS3iRpr7O64IMqBIJK/LI1JV+GrDBh+GV2kQu
RH0oLww935Q=
=YMR6
-----END PGP SIGNATURE-----

S
S
Simon South wrote on 18 Dec 2020 15:27
(address . 43915-done@debbugs.gnu.org)(name . Christopher Baines)(address . mail@cbaines.net)
874kkj6vg6.fsf@simonsouth.net
The updates to python-breathe and python-sphinx have arrived in master,
and the update to python-six is in core-updates, so I'm going to go
ahead and close this issue.

--
Simon South
simon@simonsouth.net
Closed
?