[PATCH] Add missing dependencies of Slic3r

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Malte Frank Gerdes
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Malte Frank Gerdes
Severity
normal
M
M
Malte Frank Gerdes wrote on 10 Oct 2020 15:52
(address . guix-patches@gnu.org)
86ft6m2nou.fsf@gmail.com
Hi,

these patches add the missing dependencies for slic3r.


Malte
From e80c0bd2fdb606d184a1069828e3b2e57ff7351b Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:07:50 +0200
Subject: [PATCH 2/7] gnu: Add perl-alien-wxwidgets.

* gnu/packages/perl.scm (perl-alien-wxwidgets): New variable.
---
gnu/packages/perl.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9916c579e4..2cbc57d174 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages textutils)
#:use-module (gnu packages video)
#:use-module (gnu packages web)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xorg))
;;;
@@ -386,6 +387,33 @@ possibility to download and install prebuilt binaries or to build SDL & co.@:
from source codes.")
(license license:perl-license)))
+(define-public perl-alien-wxwidgets
+ (package
+ (name "perl-alien-wxwidgets")
+ (version "0.69")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MD/MDOOTSON/Alien-wxWidgets-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0jg2dmkzhj03f6b0vmv597yryfw9cclsdn9ynvvlrzzgpd5lw8jk"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-lwp-protocol-https" ,perl-lwp-protocol-https)
+ ("perl-module-build" ,perl-module-build)
+ ("wxwidgets-gtk" ,wxwidgets-gtk2)))
+ (propagated-inputs
+ `(("perl-module-pluggable" ,perl-module-pluggable)))
+ (home-page "https://metacpan.org/release/Alien-wxWidgets")
+ (synopsis "building, finding and using wxWidgets binaries")
+ (description "Alien::wxWidgets can be used to detect and get configuration
+settings from an installed wxWidgets.")
+ (license license:perl-license)))
+
(define-public perl-any-moose
(package
(name "perl-any-moose")
--
2.28.0
From c959affd510b3c4f8ba74283684fc63d170d9f4b Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:08:59 +0200
Subject: [PATCH 3/7] gnu: Add perl-data-uuid.

* gnu/packages/perl.scm (perl-data-uuid): New variable.
---
gnu/packages/perl.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2cbc57d174..3658382884 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2862,6 +2862,29 @@ necessary later on.")
variants.")
(license (package-license perl))))
+(define-public perl-data-uuid
+ (package
+ (name "perl-data-uuid")
+ (version "1.226")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RJ/RJBS/Data-UUID-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0lv4k4ibxwkw7zz9hw97s34za9nvjxb4kbmgmx5sj4fll3zmfg89"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Data-UUID")
+ (synopsis "Globally/Universally Unique Identifiers (GUIDs/UUIDs)")
+ (description "This module provides a framework for generating v3 UUIDs
+(Universally Unique Identifiers, also known as GUIDs (Globally Unique
+Identifiers). A UUID is 128 bits long, and is guaranteed to be different
+from all other UUIDs/GUIDs generated until 3400 CE.")
+ (license license:bsd-3)))
+
(define-public perl-data-visitor
(package
(name "perl-data-visitor")
--
2.28.0
From dfc0b42e3723aabf254ba6a4f54e4956553bcce1 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:10:14 +0200
Subject: [PATCH 4/7] gnu: Add perl-net-bonjour.

* gnu/packages/perl.scm (perl-net-bonjour): New variable.
---
gnu/packages/perl.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3658382884..bdf962e027 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -67,6 +67,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages less)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages networking)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages perl-compression)
#:use-module (gnu packages perl-web)
@@ -7744,6 +7745,31 @@ kernel routing table of the host system. However, such operations could be
implemented using the API provided by the module.")
(license license:perl-license)))
+(define-public perl-net-bonjour
+ (package
+ (name "perl-net-bonjour")
+ (version "0.96")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/C/CH/CHLIGE/Net-Bonjour-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "15qzkfk0isn6c4js3ih95k3dylq6scijp863s0485c00n8x1z2n3"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-net-dns" ,perl-net-dns)))
+ (home-page "https://metacpan.org/release/Net-Bonjour")
+ (synopsis "Module for DNS service discovery (Apple's Bonjour)")
+ (description "Net::Bonjour is a set of modules that allow one to discover
+local services via multicast DNS (mDNS) or enterprise services via
+traditional DNS. This method of service discovery has been branded as
+Bonjour by Apple Computer.")
+ (license license:perl-license)))
+
(define-public perl-net-dns-native
(package
(name "perl-net-dns-native")
--
2.28.0
From a684261d723bf57553c909b20774152db3ef2798 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:15:13 +0200
Subject: [PATCH 5/7] gnu: Add perl-growl-gntp.

* gnu/packages/perl.scm (perl-growl-gntp): New variable.
---
gnu/packages/perl.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index bdf962e027..a34eab43c2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5017,6 +5017,32 @@ vaguely inspired by John Ousterhout's Tk_ParseArgv.")
the abstract data structures.")
(license (package-license perl))))
+(define-public perl-growl-gntp
+ (package
+ (name "perl-growl-gntp")
+ (version "0.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MA/MATTN/Growl-GNTP-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0gq8ypam6ifp8f3s2mf5d6sw53m7h3ki1zfahh2p41kl8a77yy98"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build-tiny" ,perl-module-build-tiny)))
+ (propagated-inputs
+ `(("perl-crypt-cbc" ,perl-crypt-cbc)
+ ("perl-data-uuid" ,perl-data-uuid)))
+ (home-page "https://metacpan.org/release/Growl-GNTP")
+ (synopsis "Perl implementation of GNTP Protocol (Client Part)")
+ (description "Growl::GNTP is Perl implementation of GNTP Protocol (Client
+Part)")
+ (license license:perl-license)))
+
(define-public perl-guard
(package
(name "perl-guard")
--
2.28.0
From 34c09a396ddd4db0ea821d8114c7f4537f4c7468 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:16:46 +0200
Subject: [PATCH 6/7] gnu: Add perl-wx.

* gnu/packages/perl.scm (perl-wx): New variable.
---
gnu/packages/perl.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a34eab43c2..879fdd4e74 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -10877,6 +10877,42 @@ it. With this module, you can add your own magic to any variable without
having to write a single line of XS.")
(license (package-license perl))))
+(define-public perl-wx
+ (package
+ (name "perl-wx")
+ (version "0.9932")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MD/MDOOTSON/Wx-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0w0vcpk8bmklh16c0z1vxgipnmvdw7cckcmay7k7cihgb99vdz8w"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (native-inputs
+ `(("perl-alien-wxwidgets" ,perl-alien-wxwidgets)
+ ("perl-extutils-xspp" ,perl-extutils-xspp)
+ ("xvfb" ,xorg-server-for-tests)))
+ (propagated-inputs
+ `(("perl-alien-wxwidgets" ,perl-alien-wxwidgets)))
+ (home-page "https://metacpan.org/release/Wx")
+ (synopsis "interface to the wxWidgets cross-platform GUI toolkit")
+ (description "The Wx module is a wrapper for the wxWidgets (formerly
+known as wxWindows) GUI toolkit.")
+ (license license:perl-license)))
+
(define-public perl-xml-writer
(package
(name "perl-xml-writer")
--
2.28.0
From 2348760d580539199e99e4a7f3b9141f6c7884f2 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:17:14 +0200
Subject: [PATCH 7/7] gnu: Add perl-wx-glcanvas.

* gnu/packages/perl.scm (perl-wx-glcanvas): New variable.
---
gnu/packages/perl.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 879fdd4e74..9bf60433e3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -10913,6 +10913,40 @@ having to write a single line of XS.")
known as wxWindows) GUI toolkit.")
(license license:perl-license)))
+(define-public perl-wx-glcanvas
+ (package
+ (name "perl-wx-glcanvas")
+ (version "0.09")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MB/MBARBON/Wx-GLCanvas-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1q4gvj4gdx4l8k4mkgiix24p9mdfy1miv7abidf0my3gy2gw5lka"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (native-inputs `(("perl-wx" ,perl-wx)
+ ("xvfb" ,xorg-server-for-tests)))
+ (inputs `(("mesa" ,mesa)))
+ (propagated-inputs `(("perl-wx" ,perl-wx)))
+ (home-page "https://metacpan.org/release/Wx-GLCanvas")
+ (synopsis "interface to wxWidgets' OpenGL canvas")
+ (description "The documentation for this module is included in the main
+wxPerl distribution (wxGLCanvas).")
+ (license license:perl-license)))
+
(define-public perl-xml-writer
(package
(name "perl-xml-writer")
--
2.28.0
A
A
Andreas Enge wrote on 10 Oct 2020 21:53
(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)(address . 43906@debbugs.gnu.org)
20201010195303.GA27775@jurong
Hello,

On Sat, Oct 10, 2020 at 03:52:17PM +0200, Malte Frank Gerdes wrote:
Toggle quote (2 lines)
> Subject: [PATCH 2/7] gnu: Add perl-alien-wxwidgets.

during build, I see the following messages:
starting phase `build'
Building Alien-wxWidgets
'media' library not found: some functionality will be missing

Does this matter? Should we add more inputs?

Then this:
starting phase `check'
t/01_load.t .......... ok
t/zy_pod_coverage.t .. skipped: Test::Pod::Coverage 1.00 required for testing POD coverage
t/zz_pod.t ........... skipped: Test::Pod 1.00 required for testing POD

Similarly, add (native-)inputs?

Concerning these, I ran this command:
$ guix gc --references /gnu/store/r8lbv88cg2nqkk0a2hjcvrs0z3ljqrcy-perl-alien-wxwidgets-0.69
/gnu/store/a41jn9pcrgpkgba6vpd3m56r0fsczsv2-wxwidgets-gtk2-3.0.5.1
/gnu/store/r8lbv88cg2nqkk0a2hjcvrs0z3ljqrcy-perl-alien-wxwidgets-0.69

So wxwidgets-gtk2 should be a normal, non-native input.
Why -gtk2? Does this warrant a comment?

Concerning normal vs. propagated inputs, I must confess my ignorance of perl;
do all perl packages need to be propagated?

I would suggest insignificantly beefed up descriptive fields:
(synopsis "Module for building, finding and using wxWidgets binaries")
(description "Alien::wxWidgets can be used to detect and get configuration
settings from an installed wxWidgets package.")

Andreas
T
T
Tobias Geerinckx-Rice wrote on 10 Oct 2020 22:26
(name . Andreas Enge)(address . andreas@enge.fr)
874kn1zv1o.fsf@nckx
Andreas,

Andreas Enge ???
Toggle quote (10 lines)
> Then this:
> starting phase `check'
> t/01_load.t .......... ok
> t/zy_pod_coverage.t .. skipped: Test::Pod::Coverage 1.00
> required for testing POD coverage
> t/zz_pod.t ........... skipped: Test::Pod 1.00 required for
> testing POD
>
> Similarly, add (native-)inputs?

I deliberately ignore these when I see them.

Like test coverage or code formatting tests, these test the source
code (here: documentation) itself, not the build result. IMO
that's useful for upstream authors but not for us redistributors.

Toggle quote (3 lines)
> Concerning normal vs. propagated inputs, I must confess my
> ignorance of perl; do all perl packages need to be propagated?

Yes, unless a PERL5LIB wrapper is used instead. Binaries &
scripts can be wrapped, Perl modules can't.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCX4IZFA0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15mtsA/16sUnVpnmqpwSVuYPa4LtE580JdT919Y8bVANSA
phygAQDxXG1oKD7k/Ep5ap+aaAtf2i82R5Ge4yfBA6qzHuZ4DA==
=j3Sb
-----END PGP SIGNATURE-----

M
M
Malte Frank Gerdes wrote on 13 Oct 2020 21:27
Re: [bug#43906] [PATCH v2] perl-alien-wxwidgets
(name . Andreas Enge)(address . andreas@enge.fr)(address . 43906@debbugs.gnu.org)
865z7esz81.fsf_-_@gmail.com
Andreas Enge <andreas@enge.fr> writes:

Toggle quote (12 lines)
> Hello,
>
> On Sat, Oct 10, 2020 at 03:52:17PM +0200, Malte Frank Gerdes wrote:
>> Subject: [PATCH 2/7] gnu: Add perl-alien-wxwidgets.
>
> during build, I see the following messages:
> starting phase `build'
> Building Alien-wxWidgets
> 'media' library not found: some functionality will be missing
>
> Does this matter? Should we add more inputs?

I checked that and (i'm also not a perl user, in fact i have never read
as much perl as in those packages in order to get slic3r :D) i can't
see any reason why it shouldn't find that library. It /is/ there. It's
part of wxwidgets. So i don't know what is going on there :/

Toggle quote (9 lines)
> Then this:
> starting phase `check'
> t/01_load.t .......... ok
> t/zy_pod_coverage.t .. skipped: Test::Pod::Coverage 1.00 required for testing
> POD coverage
> t/zz_pod.t ........... skipped: Test::Pod 1.00 required for testing POD
>
> Similarly, add (native-)inputs?

As Tobias said, it might be perfectly fine to ignore these. I added the
relevant bits nonetheless, because it might be of help sometimes (or not
:D).

Toggle quote (9 lines)
> Concerning these, I ran this command:
> $ guix gc --references
> /gnu/store/r8lbv88cg2nqkk0a2hjcvrs0z3ljqrcy-perl-alien-wxwidgets-0.69
> /gnu/store/a41jn9pcrgpkgba6vpd3m56r0fsczsv2-wxwidgets-gtk2-3.0.5.1
> /gnu/store/r8lbv88cg2nqkk0a2hjcvrs0z3ljqrcy-perl-alien-wxwidgets-0.69
>
> So wxwidgets-gtk2 should be a normal, non-native input.
> Why -gtk2? Does this warrant a comment?

i don't know why i chose wxwidgets-gtk2 - it works perfectly fine with
wxwidgets, sorry!

Toggle quote (5 lines)
> I would suggest insignificantly beefed up descriptive fields:
> (synopsis "Module for building, finding and using wxWidgets binaries")
> (description "Alien::wxWidgets can be used to detect and get configuration
> settings from an installed wxWidgets package.")

I have modified the patch according to your suggestions.


Malte
From bedffb896dba772bfcc8d2af05fb3bbacfeb6e08 Mon Sep 17 00:00:00 2001
From: Malte Frank Gerdes <malte.f.gerdes@gmail.com>
Date: Wed, 7 Oct 2020 18:07:50 +0200
Subject: [PATCH] gnu: Add perl-alien-wxwidgets.

* gnu/packages/perl.scm (perl-alien-wxwidgets): New variable.
---
gnu/packages/perl.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9916c579e4..34a84ab2fb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages textutils)
#:use-module (gnu packages video)
#:use-module (gnu packages web)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xorg))
;;;
@@ -386,6 +387,35 @@ possibility to download and install prebuilt binaries or to build SDL & co.@:
from source codes.")
(license license:perl-license)))
+(define-public perl-alien-wxwidgets
+ (package
+ (name "perl-alien-wxwidgets")
+ (version "0.69")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MD/MDOOTSON/Alien-wxWidgets-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0jg2dmkzhj03f6b0vmv597yryfw9cclsdn9ynvvlrzzgpd5lw8jk"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-lwp-protocol-https" ,perl-lwp-protocol-https)
+ ("perl-module-build" ,perl-module-build)
+ ("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)
+ ("wxwidgets" ,wxwidgets)))
+ (propagated-inputs
+ `(("perl-module-pluggable" ,perl-module-pluggable)))
+ (home-page "https://metacpan.org/release/Alien-wxWidgets")
+ (synopsis "Module for building, finding and using wxWidgets binaries")
+ (description "Alien::wxWidgets can be used to detect and get configuration
+settings from an installed wxWidgets package.")
+ (license license:perl-license)))
+
(define-public perl-any-moose
(package
(name "perl-any-moose")
--
2.28.0
A
A
Andreas Enge wrote on 9 Feb 2023 21:47
[bug#43906] [PATCH v3] perl-wx
(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)(address . 43906@debbugs.gnu.org)
Y+Vb1ieJBGCQzwgH@jurong
Hello,

in the meantime, perl-data-uuid had already been added to Guix.

I have reimported perl-net-bonjour and perl-growl-gntp and pushed them.

Then I have adapted your perl-alien-wxwidgets to modern conventions
and pushed it.

perl-wx as attached fails with the following message, so I did not test
perl-wx-glcanvas:
No such 'link' library: 'adv' at /tmp/guix-build-perl-wx-0.9932.drv-0/Wx-0.9932/build/Wx/build/MakeMaker.pm line 212.

It looks as if the wxwidgets are not found, which makes me wonder if the
perl-alien-wxwidgets package is correct...

Is there still interest in slic3r? Wikipedia claims that prusa-slicer
(which we have) is an improved fork, but maybe it work only with Prusa
printers? If there is no interest, I am going to close the bug.

Andreas
From f12b8bd68c62c48a5655cda36b38ee7e13a5aa00 Mon Sep 17 00:00:00 2001
Message-Id: <f12b8bd68c62c48a5655cda36b38ee7e13a5aa00.1675975292.git.andreas@enge.fr>
From: Andreas Enge <andreas@enge.fr>
Date: Thu, 9 Feb 2023 21:40:09 +0100
Subject: [PATCH] gnu: Add perl-wx.

* gnu/packages/wxwidgets.scm (perl-wx): New variable.
---
gnu/packages/wxwidgets.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index c62fc20fec..719a2db56c 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -371,3 +371,31 @@ (define-public perl-alien-wxwidgets
(description "Alien::wxWidgets is a Perl module for detecting and
getting configuration settings from an installed wxWidgets package.")
(license l:perl-license)))
+
+(define-public perl-wx
+ (package
+ (name "perl-wx")
+ (version "0.9932")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MD/MDOOTSON/Wx-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0w0vcpk8bmklh16c0z1vxgipnmvdw7cckcmay7k7cihgb99vdz8w"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))))
+ (native-inputs (list perl-alien-wxwidgets perl-extutils-xspp
+ xorg-server-for-tests wxwidgets))
+ (propagated-inputs (list perl-alien-wxwidgets))
+ (home-page "https://metacpan.org/release/Wx")
+ (synopsis "Perl interface to the wxWidgets cross-platform GUI toolkit")
+ (description "The Wx module is a Perl wrapper for the wxWidgets
+cross-platform GUI toolkit.")
+ (license l:perl-license)))
--
2.39.1
A
A
Andreas Enge wrote on 18 Feb 2023 12:05
(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)(address . 43906-done@debbugs.gnu.org)
Y/Cw7giWfqzXreWN@jurong
Closing the issue, if there is renewed interest in slic3r or its
dependencies please feel free to submit new patches.

Andreas
Closed
?