’corrode’ fails because ’ghc-language-c’ wrong version

OpenSubmitted by zimoun.
Details
One participant
  • zimoun
Owner
unassigned
Severity
normal
Z
Z
zimoun wrote on 9 Oct 2020 03:25
(address . bug-guix@gnu.org)
86ft6o8a2k.fsf@gmail.com
Dear,
Using Guix a0d4aa2, the package ’corrode’ fails to build because:
Toggle snippet (5 lines)Configuring corrode-0.1.0.0...Setup.hs: Encountered missing dependencies:language-c >=0.4 && <0.6
and the package ’ghc-language-c’ had been updated to 0.8.1 by the commit19b29882878a6558e5f16d587265eb3a0c0cdec6 (Jan. 2017). So the package isprobably broken since 3 years.
Four fixes are possible:
1. add the package ’ghc-language-c@0.5.0’ introduced by 2d2388e243d31f00b31b36b8ada76876b6fdacf2. 2. turn the package as “private” or at least deprecated. 3. move it to guix-past. 4. remove it. (Note that upstream is stalling; last commit 4 years ago.)

I am in favor of option #4. Or maybe someone wants to fix?

WDYT?
All the best,simon
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send email to 43874@debbugs.gnu.org