[PATCH] gnu: Add go-github-com-errata-ai-vale.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Arazas
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Arazas
Severity
normal
Merged with
G
G
Gabriel Arazas wrote on 2 Oct 2020 19:13
(address . guix-patches@gnu.org)(name . Gabriel Arazas)(address . foo.dogsquared@gmail.com)
20201002171317.1680-2-foo.dogsquared@gmail.com
* gnu/packages/textutils.scm (go-github-com-errata-ai-vale): New variable.
---
gnu/packages/textutils.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 6653d01a31..f84fbc52ba 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -52,6 +52,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gettext)
#:use-module (gnu packages java)
#:use-module (gnu packages ncurses)
@@ -1173,3 +1174,35 @@ This package provides Python bindings.")
(description "@command{aha} (Ansi Html Adapter) converts ANSI escape sequences
of a Unix terminal to HTML code.")
(license (list license:lgpl2.0+ license:mpl1.1))))
+
+(define-public go-github-com-errata-ai-vale
+ (package
+ (name "go-github-com-errata-ai-vale")
+ (version "2.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/errata-ai/vale")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0d07fwha2220m8j24h527xl0gnl3svvyaywflgk5292d6g49ach2"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("github.com/sp13/afero" ,go-github-com-spf13-afero)
+ ("github.com/urfave/cli" ,go-github-com-urfave-cli)
+ ("github.com/olekukonko/tablewriter" ,go-github-com-olekukonko-tablewriter)
+ ("github.com/mitchellh/mapstructure" ,go-github-com-mitchellh-mapstructure)))
+ (arguments
+ `(#:import-path "github.com/errata-ai/vale"
+ #:install-source? #f))
+ (home-page "https://github.com/errata-ai/vale")
+ (synopsis "Fully customizable syntax-aware linter that focuses on your style")
+ (description
+ "Vale is a fully extensible linter that focuses on your own writing style
+by making use of rules in individual YAML files. It is syntax-aware on markup
+languages such as HTML, Markdown, Asciidoc, and reStructuredText. The community
+around it also has a list of style guides implemented with Vale in
+@url{https://github.com/errata-ai/styles, their styles repo}.")
+ (license license:expat)))
--
2.28.0
L
L
Ludovic Courtès wrote on 2 Nov 2020 14:50
control message for bug #43766
(address . control@debbugs.gnu.org)
87v9enlvex.fsf@gnu.org
merge 43766 43765
quit
L
L
Ludovic Courtès wrote on 2 Nov 2020 14:53
Re: [bug#43766] [PATCH] gnu: Add go-github-com-errata-ai-vale.
(name . Gabriel Arazas)(address . foo.dogsquared@gmail.com)(address . 43766-done@debbugs.gnu.org)
87r1pblvau.fsf@gnu.org
Hi,

Gabriel Arazas <foo.dogsquared@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/textutils.scm (go-github-com-errata-ai-vale): New variable.

Applied, thanks!

Ludo’.
Closed
?