(address . bug-guix@gnu.org)
I tried to install Utox today and it fails with the following issue:
The corresponding part of the log:
In file included from
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:33:0:
/gnu/store/aqidpw0zfj1sr6cbqqs27j5dj202cfkp-openal-1.20.1/include/AL/alc.h:34:26:
error: conflicting types for ‘ALCdevice’
typedef struct ALCdevice ALCdevice;
^~~~~~~~~
In file included from
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:1:0:
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.h:8:33: note:
previous declaration of ‘ALCdevice’ was here
typedef struct ALCdevice_struct ALCdevice;
^~~~~~~~~
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:161:6: error:
conflicting types for ‘utox_audio_in_device_set’
bool utox_audio_in_device_set(ALCdevice *new_device) {
^~~~~~~~~~~~~~~~~~~~~~~~
In file included from
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:1:0:
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.h:68:6: note:
previous declaration of ‘utox_audio_in_device_set’ was here
bool utox_audio_in_device_set(ALCdevice *new_device);
^~~~~~~~~~~~~~~~~~~~~~~~
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:178:12: error:
conflicting types for ‘utox_audio_in_device_get’
ALCdevice *utox_audio_in_device_get(void) {
^~~~~~~~~~~~~~~~~~~~~~~~
In file included from
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:1:0:
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.h:70:12: note:
previous declaration of ‘utox_audio_in_device_get’ was here
ALCdevice *utox_audio_in_device_get(void);
^~~~~~~~~~~~~~~~~~~~~~~~
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:265:6: error:
conflicting types for ‘utox_audio_out_device_set’
bool utox_audio_out_device_set(ALCdevice *new_device) {
^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:1:0:
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.h:69:6: note:
previous declaration of ‘utox_audio_out_device_set’ was here
bool utox_audio_out_device_set(ALCdevice *new_device);
^~~~~~~~~~~~~~~~~~~~~~~~~
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:278:12: error:
conflicting types for ‘utox_audio_out_device_get’
ALCdevice *utox_audio_out_device_get(void) {
^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.c:1:0:
/tmp/guix-build-utox-0.17.1.drv-0/source/src/av/audio.h:72:12: note:
previous declaration of ‘utox_audio_out_device_get’ was here
ALCdevice *utox_audio_out_device_get(void);
^~~~~~~~~~~~~~~~~~~~~~~~~
make[2]: *** [src/av/CMakeFiles/utoxAV.dir/build.make:79:
src/av/CMakeFiles/utoxAV.dir/audio.c.o] Error 1
make[2]: Leaving directory '/tmp/guix-build-utox-0.17.1.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:356:
src/av/CMakeFiles/utoxAV.dir/all] Error 2
make[1]: Leaving directory '/tmp/guix-build-utox-0.17.1.drv-0/build'
make: *** [Makefile:166: all] Error 2
command "make" "-j" "1" failed with status 2
Marinus Savoritias