[PATCH] gnu: taglib: Fix 'taglib-config --libs' -L flag.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 8 Sep 2020 12:48
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200908104835.12211-1-mike@rohleder.de
* gnu/packages/mp3.scm (taglib): Add "" around the substitution of
ZLIB_LIBRARIES_FLAGS.
---
gnu/packages/mp3.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index a7574f0cf9..2e9b023407 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -182,9 +182,9 @@ a highly stable and efficient implementation.")
;; flag for zlib.
(substitute* "CMakeLists.txt"
(("set\\(ZLIB_LIBRARIES_FLAGS -lz\\)")
- (string-append "set(ZLIB_LIBRARIES_FLAGS -L"
+ (string-append "set(ZLIB_LIBRARIES_FLAGS \"-L"
(assoc-ref inputs "zlib")
- " -lz)")))
+ " -lz\")")))
#t)))))
(inputs `(("zlib" ,zlib)))
(home-page "https://taglib.org")
--
2.28.0
L
L
Ludovic Courtès wrote on 9 Sep 2020 09:38
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43273-done@debbugs.gnu.org)
87mu1zmmb2.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (3 lines)
> * gnu/packages/mp3.scm (taglib): Add "" around the substitution of
> ZLIB_LIBRARIES_FLAGS.

Applied. Thanks and sorry for the delay!

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 9 Sep 2020 10:28
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43273@debbugs.gnu.org)
87eenbmjzo.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (20 lines)
> * gnu/packages/mp3.scm (taglib): Add "" around the substitution of
> ZLIB_LIBRARIES_FLAGS.
> ---
> gnu/packages/mp3.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
> index a7574f0cf9..2e9b023407 100644
> --- a/gnu/packages/mp3.scm
> +++ b/gnu/packages/mp3.scm
> @@ -182,9 +182,9 @@ a highly stable and efficient implementation.")
> ;; flag for zlib.
> (substitute* "CMakeLists.txt"
> (("set\\(ZLIB_LIBRARIES_FLAGS -lz\\)")
> - (string-append "set(ZLIB_LIBRARIES_FLAGS -L"
> + (string-append "set(ZLIB_LIBRARIES_FLAGS \"-L"
> (assoc-ref inputs "zlib")
> - " -lz)")))
> + " -lz\")")))

As it turns out, we were also missing “/lib” there… I’ve added it, and
hopefully now we’re all fine!

Ludo’.
?