[PATCH emacs-guix] elisp: guix-set-emacs-environment: Also update Emacs' path.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jan (janneke) Nieuwenhuizen
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Jan (janneke) Nieuwenhuizen
Severity
normal
J
J
Jan (janneke) Nieuwenhuizen wrote on 6 Sep 2020 10:46
20200906084646.28115-1-janneke@gnu.org
This helps Geiser find the correct (environment's) Guile.

* elisp/guix-misc.el (guix-set-emacs-environment): Set "exec-path"
when setting "PATH" variable.
---
elisp/guix-misc.el | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/elisp/guix-misc.el b/elisp/guix-misc.el
index 6f79fe6..7e9c068 100644
--- a/elisp/guix-misc.el
+++ b/elisp/guix-misc.el
@@ -1,7 +1,7 @@
;;; guix-misc.el --- Miscellaneous definitions -*- lexical-binding: t -*-
;; Copyright © 2014–2018 Alex Kost <alezost@gmail.com>
-;; Copyright © 2018 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;; Copyright © 2018,2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;; This file is part of Emacs-Guix.
@@ -242,7 +242,9 @@ If PROFILE is nil, use `guix-current-profile'."
(value (if (and separator current-value)
(concat path separator current-value)
path)))
- (setenv variable value)))))
+ (setenv variable value)
+ (when (equalp variable "PATH")
+ (setq exec-path (split-string value ":")))))))
;;; Executing guix commands
--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com | Avatar® http://AvatarAcademy.com
M
M
Maxim Cournoyer wrote on 16 Jan 2023 19:03
(name . Jan (janneke) Nieuwenhuizen)(address . janneke@gnu.org)
875yd65pbz.fsf@gmail.com
Hi Janneke,

"Jan (janneke) Nieuwenhuizen" <janneke@gnu.org> writes:

Toggle quote (19 lines)
> This helps Geiser find the correct (environment's) Guile.
>
> * elisp/guix-misc.el (guix-set-emacs-environment): Set "exec-path"
> when setting "PATH" variable.
> ---
> elisp/guix-misc.el | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/elisp/guix-misc.el b/elisp/guix-misc.el
> index 6f79fe6..7e9c068 100644
> --- a/elisp/guix-misc.el
> +++ b/elisp/guix-misc.el
> @@ -1,7 +1,7 @@
> ;;; guix-misc.el --- Miscellaneous definitions -*- lexical-binding: t -*-
>
> ;; Copyright © 2014–2018 Alex Kost <alezost@gmail.com>
> -;; Copyright © 2018 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
> +;; Copyright © 2018,2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>

There's no use for a copyright line here as the change is not
substantial enough (< 10 lines).

Toggle quote (11 lines)
> ;; This file is part of Emacs-Guix.
>
> @@ -242,7 +242,9 @@ If PROFILE is nil, use `guix-current-profile'."
> (value (if (and separator current-value)
> (concat path separator current-value)
> path)))
> - (setenv variable value)))))
> + (setenv variable value)
> + (when (equalp variable "PATH")
> + (setq exec-path (split-string value ":")))))))

That's still useful with Emacs 28, right? If you can confirm it, LGTM.

--
Thanks,
Maxim
J
J
Janneke Nieuwenhuizen wrote on 16 Jan 2023 22:33
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87sfgaxizy.fsf@gnu.org
Maxim Cournoyer writes:

Hi Maxim,

Toggle quote (9 lines)
> "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org> writes:
>
>> This helps Geiser find the correct (environment's) Guile.
>> -;; Copyright © 2018 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
>> +;; Copyright © 2018,2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
>
> There's no use for a copyright line here as the change is not
> substantial enough (< 10 lines).

Ah...I guess I figured that we need copyright years to be updated in all
years the program is "released". Oh well...

Toggle quote (5 lines)
>> + (when (equalp variable "PATH")
>> + (setq exec-path (split-string value ":")))))))
>
> That's still useful with Emacs 28, right? If you can confirm it, LGTM.

It's still useful...but also...I found this has already been installed
as

commit d246b2c443bbb9d49575b63bb78c14699c4448cf
elisp/misc: Update Emacs path if needed

and

41fba4eec845e050be92bfe76c0f7980bbe821bd
Fix the previous commit

Sorry for the noise...Closing.

Greetings,
Janneke

--
Janneke Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond https://LilyPond.org
Freelance IT https://www.JoyOfSource.com| Avatar® https://AvatarAcademy.com
Closed
M
M
Maxim Cournoyer wrote on 17 Jan 2023 02:46
(name . Janneke Nieuwenhuizen)(address . janneke@gnu.org)
87mt6i2ar2.fsf@gmail.com
Hi Janneke,

Janneke Nieuwenhuizen <janneke@gnu.org> writes:

[...]

Toggle quote (13 lines)
> It's still useful...but also...I found this has already been installed
> as
>
> commit d246b2c443bbb9d49575b63bb78c14699c4448cf
> elisp/misc: Update Emacs path if needed
>
> and
>
> 41fba4eec845e050be92bfe76c0f7980bbe821bd
> Fix the previous commit
>
> Sorry for the noise...Closing.

I see! Thanks for your reply and closing it!

--
Thanks,
Maxim
Closed
?