[PATCH] Add new font APL385 & APL333

  • Open
  • quality assurance status badge
Details
4 participants
  • Zhu Zihao
  • Julien Lepiller
  • Leo Famulari
  • zimoun
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Z
Zhu Zihao wrote on 31 Aug 2020 06:27
(address . 43125@debbugs.gnu.org)
200de889.41fe.17442c4fb3d.Coremail.all_but_last@163.com
From f4745ab244032643bcdbe00ea91e5bfe550f8dad Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 31 Aug 2020 11:39:31 +0800
Subject: [PATCH 1/2] gnu: Add font-apl385

* gnu/packages/fonts.scm (font-apl385): New variable.
---
gnu/packages/fonts.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 77484157e3..794d988df2 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1961,3 +1961,22 @@ operators and special symbols.")
is a stylish type with a polished yet relaxed feel. Its versatility makes it
suitable for a wide range of uses.")
(license license:silofl1.1))))
+
+(define-public font-apl385
+ (let ((revision "0"))
+ (package
+ (name "font-apl385")
+ (version (string-append "1.0.0-" revision))
+ (source
+ (origin
+ (method url-fetch/zipbomb)
+ (uri "https://apl385.com/fonts/apl385.zip")
+ (sha256
+ (base32 "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
+ (build-system font-build-system)
+ (home-page "https://apl385.com")
+ (synopsis "Monospace font for APL programming")
+ (description "APL385 is developed with all APL software vendors
+in the late 1980s and enhanced as required with new characters to meet
+interpreter updates.")
+ (license license:public-domain))))
--
2.27.0







From 952a5b50902eab13c43599de44c1b4ac501c71df Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 31 Aug 2020 11:40:49 +0800
Subject: [PATCH 2/2] gnu: Add font-apl333

* gnu/packages/fonts.scm (font-apl333): New variable.
---
gnu/packages/fonts.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 794d988df2..e61a0d2f4a 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1980,3 +1980,20 @@ suitable for a wide range of uses.")
in the late 1980s and enhanced as required with new characters to meet
interpreter updates.")
(license license:public-domain))))
+
+(define-public font-apl333
+ (let ((revision "0"))
+ (package
+ (name "font-apl333")
+ (version (string-append "1.0.0-" revision))
+ (source
+ (origin
+ (method url-fetch/zipbomb)
+ (uri "https://apl385.com/fonts/apl333.zip")
+ (sha256
+ (base32 "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
+ (build-system font-build-system)
+ (home-page "https://apl385.com")
+ (synopsis "Proportional font for APL programming")
+ (description "APL333 is the proportional variant of APL385.")
+ (license license:public-domain))))
--
2.27.0
Attachment: file
Z
Z
Zhu Zihao wrote on 8 Sep 2020 03:10
(address . 43125@debbugs.gnu.org)
7515c29a.1485.1746b43a64e.Coremail.all_but_last@163.com
Any feedback?
Attachment: file
Z
Z
Zhu Zihao wrote on 10 Nov 2020 10:32
296a2407.745f.175b180247e.Coremail.all_but_last@163.com
Ludo, Can you please help review this patch? It's been idle for a long long time, Thanks a lot.











? 2020-08-31 12:27:19?"Zhu Zihao" <all_but_last@163.com> ???

From f4745ab244032643bcdbe00ea91e5bfe550f8dad Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 31 Aug 2020 11:39:31 +0800
Subject: [PATCH 1/2] gnu: Add font-apl385

* gnu/packages/fonts.scm (font-apl385): New variable.
---
gnu/packages/fonts.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 77484157e3..794d988df2 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1961,3 +1961,22 @@ operators and special symbols.")
is a stylish type with a polished yet relaxed feel. Its versatility makes it
suitable for a wide range of uses.")
(license license:silofl1.1))))
+
+(define-public font-apl385
+ (let ((revision "0"))
+ (package
+ (name "font-apl385")
+ (version (string-append "1.0.0-" revision))
+ (source
+ (origin
+ (method url-fetch/zipbomb)
+ (uri "https://apl385.com/fonts/apl385.zip")
+ (sha256
+ (base32 "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
+ (build-system font-build-system)
+ (home-page "https://apl385.com")
+ (synopsis "Monospace font for APL programming")
+ (description "APL385 is developed with all APL software vendors
+in the late 1980s and enhanced as required with new characters to meet
+interpreter updates.")
+ (license license:public-domain))))
--
2.27.0







From 952a5b50902eab13c43599de44c1b4ac501c71df Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 31 Aug 2020 11:40:49 +0800
Subject: [PATCH 2/2] gnu: Add font-apl333

* gnu/packages/fonts.scm (font-apl333): New variable.
---
gnu/packages/fonts.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 794d988df2..e61a0d2f4a 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1980,3 +1980,20 @@ suitable for a wide range of uses.")
in the late 1980s and enhanced as required with new characters to meet
interpreter updates.")
(license license:public-domain))))
+
+(define-public font-apl333
+ (let ((revision "0"))
+ (package
+ (name "font-apl333")
+ (version (string-append "1.0.0-" revision))
+ (source
+ (origin
+ (method url-fetch/zipbomb)
+ (uri "https://apl385.com/fonts/apl333.zip")
+ (sha256
+ (base32 "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
+ (build-system font-build-system)
+ (home-page "https://apl385.com")
+ (synopsis "Proportional font for APL programming")
+ (description "APL333 is the proportional variant of APL385.")
+ (license license:public-domain))))
--
2.27.0
Attachment: file
J
J
Julien Lepiller wrote on 10 Nov 2020 12:58
Re: [bug#43125] Re: [PATCH] Add new font APL385 & APL333
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 43125@debbugs.gnu.org)
20201110125813.630987d3@tachikoma.lepiller.eu
Hi,

I've tried to apply and build these fonts. Apl 385 applied and built
without any issue, but it seems that apl333 sources have changed since
you posted your patch.

Apparently, they update the archives in-place, which is a bad practice
for distros such as ours, since it will break our packaging system at
an unknown time in the future. Do you know of any other source for
these fonts with versionned archives? Do you know how to contact the
author, to ask them for a versionned link?

Le Tue, 10 Nov 2020 17:32:46 +0800 (CST),
"Zhu Zihao" <all_but_last@163.com> a écrit :

Toggle quote (108 lines)
> Ludo, Can you please help review this patch? It's been idle for a
> long long time, Thanks a lot.
>
>
>
>
>
>
>
>
>
>
>
> ? 2020-08-31 12:27:19?"Zhu Zihao" <all_but_last@163.com> ???
>
> From f4745ab244032643bcdbe00ea91e5bfe550f8dad Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Mon, 31 Aug 2020 11:39:31 +0800
> Subject: [PATCH 1/2] gnu: Add font-apl385
>
> * gnu/packages/fonts.scm (font-apl385): New variable.
> ---
> gnu/packages/fonts.scm | 19 +++++++++++++++++++
> 1 file changed, 19 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 77484157e3..794d988df2 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -1961,3 +1961,22 @@ operators and special symbols.")
> is a stylish type with a polished yet relaxed feel. Its versatility
> makes it suitable for a wide range of uses.")
> (license license:silofl1.1))))
> +
> +(define-public font-apl385
> + (let ((revision "0"))
> + (package
> + (name "font-apl385")
> + (version (string-append "1.0.0-" revision))
> + (source
> + (origin
> + (method url-fetch/zipbomb)
> + (uri "https://apl385.com/fonts/apl385.zip")
> + (sha256
> + (base32
> "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
> + (build-system font-build-system)
> + (home-page "https://apl385.com")
> + (synopsis "Monospace font for APL programming")
> + (description "APL385 is developed with all APL software vendors
> +in the late 1980s and enhanced as required with new characters to
> meet +interpreter updates.")
> + (license license:public-domain))))
> --
> 2.27.0
>
>
>
>
>
>
>
> From 952a5b50902eab13c43599de44c1b4ac501c71df Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Mon, 31 Aug 2020 11:40:49 +0800
> Subject: [PATCH 2/2] gnu: Add font-apl333
>
> * gnu/packages/fonts.scm (font-apl333): New variable.
> ---
> gnu/packages/fonts.scm | 17 +++++++++++++++++
> 1 file changed, 17 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 794d988df2..e61a0d2f4a 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -1980,3 +1980,20 @@ suitable for a wide range of uses.")
> in the late 1980s and enhanced as required with new characters to
> meet interpreter updates.")
> (license license:public-domain))))
> +
> +(define-public font-apl333
> + (let ((revision "0"))
> + (package
> + (name "font-apl333")
> + (version (string-append "1.0.0-" revision))
> + (source
> + (origin
> + (method url-fetch/zipbomb)
> + (uri "https://apl385.com/fonts/apl333.zip")
> + (sha256
> + (base32
> "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
> + (build-system font-build-system)
> + (home-page "https://apl385.com")
> + (synopsis "Proportional font for APL programming")
> + (description "APL333 is the proportional variant of APL385.")
> + (license license:public-domain))))
> --
> 2.27.0
>
>
>
>
>
>
>
>
Z
Z
Zhu Zihao wrote on 10 Nov 2020 15:15
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 43125@debbugs.gnu.org)
86imad1enp.fsf@163.com
Sadly I can't contact them, because they leave no contact at the site.
:(

I' ll email you if I can find a way to retrieve source
deterministically, thanks.

Julien Lepiller writes:

Toggle quote (17 lines)
> Hi,
>
> I've tried to apply and build these fonts. Apl 385 applied and built
> without any issue, but it seems that apl333 sources have changed since
> you posted your patch.
>
> Apparently, they update the archives in-place, which is a bad practice
> for distros such as ours, since it will break our packaging system at
> an unknown time in the future. Do you know of any other source for
> these fonts with versionned archives? Do you know how to contact the
> author, to ask them for a versionned link?
>
> Le Tue, 10 Nov 2020 17:32:46 +0800 (CST),
> "Zhu Zihao" <all_but_last@163.com> a écrit :
>


--
Retrieve my PGP public key: https://meta.sr.ht/~citreu.pgp

Zihao
-----BEGIN PGP SIGNATURE-----

iQFJBAEBCAAzFiEE7NCVzXX6efyusptG1SOVn+xGFqYFAl+qoIoVHGFsbF9idXRf
bGFzdEAxNjMuY29tAAoJENUjlZ/sRhamNIQH/RspE/ATtGSuWPwLF8IQrJT0ds2j
oVycRIoosRTZu83u3m850hrewEuzOKfayTxAZBIs/BeqHFsgcXGiJK+kyW9jMbFf
kXyzg9w1pm27euAzAmBt+K+RvkcBSSxlYPDTrQ2dipQDEHkmcRGh8kU5P94IBAzm
CyRCnRWiWU29gENTooCfCQB/PsCpD+3MM0wOih8d5nuVc/MVUqQsZmUE0hfX/avP
njS0oauPFskqdF3xO2Uwef4fbf1fi4WmI6mjRYkh6X/PsFp4uOh7gjTE1Dp2+1JX
zaabTRpe17M26HHMfYojgmkJoqsDvOIhp9C9TAtyR/uUkDr1fYaX4ZBubUc=
=gDGi
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 17 Nov 2020 21:17
(name . Zhu Zihao)(address . all_but_last@163.com)
20201117201727.GA9535@jasmine.lan
If you don't find another method, you could upload the source code to
archive.org and make the Guix package fetch from there. We've done that
before to work around this kind of problem.

On Tue, Nov 10, 2020 at 10:15:38PM +0800, Zhu Zihao wrote:
Toggle quote (30 lines)
>
> Sadly I can't contact them, because they leave no contact at the site.
> :(
>
> I' ll email you if I can find a way to retrieve source
> deterministically, thanks.
>
> Julien Lepiller writes:
>
> > Hi,
> >
> > I've tried to apply and build these fonts. Apl 385 applied and built
> > without any issue, but it seems that apl333 sources have changed since
> > you posted your patch.
> >
> > Apparently, they update the archives in-place, which is a bad practice
> > for distros such as ours, since it will break our packaging system at
> > an unknown time in the future. Do you know of any other source for
> > these fonts with versionned archives? Do you know how to contact the
> > author, to ask them for a versionned link?
> >
> > Le Tue, 10 Nov 2020 17:32:46 +0800 (CST),
> > "Zhu Zihao" <all_but_last@163.com> a écrit :
> >
>
>
> --
> Retrieve my PGP public key: https://meta.sr.ht/~citreu.pgp
>
> Zihao
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl+0L9MACgkQJkb6MLrK
fwjCDQ//Y5Dogyi41Tf9yubnhmg7MjcWxRuYlUNQHjzqhcqemAEgZ/QYIm/aZUQo
Imi95ccaOowm2Cz2o6HOXqxcuJFDjLHYa9U4Z8ajQAWHcLR/2zus9rY9T+FAlV2z
zlZHt8Nb5cUcHDPV4sj49cfFOw2/nFIV9ue4QFk0cU87ndxIVTgPIliFvMV3nz9G
zrhwpj/BkP4gdjnC2JJ4mWcpI/atwREl/ZVsxJaCwodmacHNiyo8rXKSZ245UIm2
zhSEi6d0yXvWpY5mHtoyLr73luWZTCWWtstUM1ZL8/+SZgygkrvnaDJMQX76BdBJ
nUvtPJ2GbKTOYy58fdVsd9dmaW24Yu7ZoN7A+ni5+rpQw43MDlQYw1eQFG45e5gf
eIF8v7B921+MO19Kq0sCvn+gEAk491ja3u73oxi0mHLtscpLw2l4oCnGUBTYat+W
qAmzvssVyhpOvGU6bB1bU/yycRD3LdExKA8elv4XTJV5ArvgjEj7I0yn2j9/AmJW
w6FKv1fjOdRhHcg8iC8pbgaytVS2ULRxNBMkGESSHYtec9E3opuWIcktesk1ka2j
ZP6E8dgMRzbV95YK5CL130d23sjZ97fHQbTlMRV2QA1skC6V2aXRpf6GYg9GsgH/
Ymfwm3uJTM63OORUtr3zAme1E+GL1XWOIvX1h1vGRrTkcvRcrao=
=9EJS
-----END PGP SIGNATURE-----


Z
Z
zimoun wrote on 18 Nov 2020 00:45
86eekrmtsl.fsf@gmail.com
Hi,


On Tue, 17 Nov 2020 at 15:17, Leo Famulari <leo@famulari.name> wrote:

Toggle quote (4 lines)
> If you don't find another method, you could upload the source code to
> archive.org and make the Guix package fetch from there. We've done that
> before to work around this kind of problem.

What have been done recently for case where the upstream is not
available anymore is: convert to Git and save to Software Heritage.

For instance, see commit 74cb33c22818b25d1b9c6d576352fc8249832d34 and


especially this snippet:

Toggle snippet (6 lines)
$ (cd /tmp; tar xf $(guix build -S gdsl); guix hash -r /tmp/gdsl-1.8)
0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0
$ guix hash -r $(./pre-inst-env guix build -S gdsl)
0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0

Obviously, need tweaks for the issue at hand. :-)

All the best,
simon
?