[PATCH] gnu: Add guile-srfi-158.

  • Done
  • quality assurance status badge
Details
2 participants
  • Martin Becze
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 30 Aug 2020 12:44
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20200830104425.9891-1-mjbecze@riseup.net
* gnu/packages/guile-xyz.scm (guile-srfi-158): New variable.
---
gnu/packages/guile-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b8c104993f..9f9335c8f7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2827,6 +2827,36 @@ parameters, which define* and lambda* special forms")
denote the invalidity of certain code paths in a Scheme program.")
(license license:gpl3+)))
+(define-public guile-srfi-158
+ (package
+ (name "guile-srfi-158")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mjbecze/guile-srfi-158.git")
+ (commit version)))
+ (sha256
+ (base32
+ "0b8hlv1bldbcwkcxi9y8mm6xp5gbgpg7b15bwqxv70iynl9d9a7c"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://gitlab.com/samplet/guile-srfi-158")
+ (synopsis "SRFI 158 (Generators and Accumulators) for Guile")
+ (description "This package provides an implementation of SRFI 158
+for Guile. SRFI 158 defines utility procedures that create,
+transform, and consume generators. It also defines procedures that
+return accumulators. It is implemented by wrapping the sample
+implementation in a thin Guile compatibility layer.")
+ (license license:gpl3+)))
+
(define-public guile-srfi-159
(let ((commit "1bd98abda2ae4ef8f36761a167903e55c6bda7bb")
(revision "0"))
--
2.28.0
M
M
Mathieu Othacehe wrote on 31 Aug 2020 10:00
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 43111-done@debbugs.gnu.org)
87y2lvgs7g.fsf@gnu.org
Hey Martin,

Toggle quote (2 lines)
> * gnu/packages/guile-xyz.scm (guile-srfi-158): New variable.

Pushed, thanks!

Mathieu
Closed
?