[PATCH] update gajim to 1.2.2

  • Done
  • quality assurance status badge
Details
4 participants
  • Mason Hock
  • Efraim Flashner
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Mason Hock
Severity
normal
Merged with
M
M
Mason Hock wrote on 27 Aug 2020 22:56
(address . guix-patches@gnu.org)
20200827205619.31836-1-chaosmonk@riseup.net
From: Mason Hock <mason@masonhock.com>

---
gnu/packages/messaging.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9dc3e58ef9..6c47004293 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -642,7 +642,7 @@ was initially a fork of xmpppy, but uses non-blocking sockets.")
(define-public gajim
(package
(name "gajim")
- (version "1.1.3")
+ (version "1.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://gajim.org/downloads/"
@@ -650,7 +650,7 @@ was initially a fork of xmpppy, but uses non-blocking sockets.")
"/gajim-" version ".tar.bz2"))
(sha256
(base32
- "0bzxwcpdd4ydh6d6mzpr0gxwhcb0x9ympk55fpvm1hcw9d28a716"))))
+ "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.28.0
E
E
Efraim Flashner wrote on 1 Sep 2020 15:44
(name . Mason Hock)(address . chaosmonk@riseup.net)(address . 43076@debbugs.gnu.org)
20200901134409.GE856@E5400
Hello and thank you for taking a look at this package.

On Thu, Aug 27, 2020 at 01:56:19PM -0700, Mason Hock wrote:
Toggle quote (32 lines)
> From: Mason Hock <mason@masonhock.com>
>
> ---
> gnu/packages/messaging.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index 9dc3e58ef9..6c47004293 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -642,7 +642,7 @@ was initially a fork of xmpppy, but uses non-blocking sockets.")
> (define-public gajim
> (package
> (name "gajim")
> - (version "1.1.3")
> + (version "1.2.2")
> (source (origin
> (method url-fetch)
> (uri (string-append "https://gajim.org/downloads/"
> @@ -650,7 +650,7 @@ was initially a fork of xmpppy, but uses non-blocking sockets.")
> "/gajim-" version ".tar.bz2"))
> (sha256
> (base32
> - "0bzxwcpdd4ydh6d6mzpr0gxwhcb0x9ympk55fpvm1hcw9d28a716"))))
> + "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))))
> (build-system python-build-system)
> (arguments
> `(#:phases
> --
> 2.28.0
>

I got a hash mismatch when I tried to download the package, it turns out
the file changed from .bz2 to .gz

Then when I tried to build it I got a failure during the 'check phase.
Can you take a look at it?

starting phase `check'
running test
Searching for packaging
Download error on https://pypi.org/simple/packaging/:[Errno -2] Name or service not known -- Some packages may not be found!
Couldn't find index page for 'packaging' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Download error on https://pypi.org/simple/:[Errno -2] Name or service not known -- Some packages may not be found!
No local packages or working download links found for packaging
error: Could not find suitable distribution for Requirement.parse('packaging')
command "python" "./setup.py" "test" "-s" "test.no_gui" failed with status 1
builder for `/gnu/store/3f9gfcg7i32h9zzad3szq4rbxaj1fqzb-gajim-1.2.2.drv' failed with exit code 1
build of /gnu/store/3f9gfcg7i32h9zzad3szq4rbxaj1fqzb-gajim-1.2.2.drv failed

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9OUCkACgkQQarn3Mo9
g1GIkA//UN/s6JSqEFQQNsSwSPQCoZWO51L2G2tE7UFfq/VfTEVTao9KsesDdaRR
4yBV5xwfk4Ry+K7G46xfeTUQT6N2BMfxAoPdqhqIQfp2mk/1jYGuoJu4M420EKgE
gO8SAOyuhJd92FS4C6FZp7dqQ4kV6ugy3D51CEM+Sryaqhij7215G9rL8mWEgrVP
sDgFfg6cXFbVsJQEmPfdQFuZRXG2CdyVUDyOS6hXPUaR0PHXSc9v0nIp/wQ34f6u
XbrxMNHBrMwECP0D0H8ilPqEjGVsVpr/uz/KaBsunMehkcg+902Zvz1jpXSDadNQ
jr358mSTjddcnbteFKxtvMNK0WfyUGGuDIkKpZr9mFOTWce3XWS4hI7dEumSJtQ9
xP24PdfPyz0vuyag1hIMHIWPmYXkrt5n7WvF9ndsQeOJogT2/6wyz9Vh8stxCWyR
nKSTK+VOW5oVh/BZGz2+llcfTH7LfXB8CkMs2uGxki6aqI5ZHYMuyOtEB8jscnVh
9Pb8ZnnoamiExhP6V4XMG7aGoMS9KB+6qmcIrq09shBN5FxgP513d26v60HeqN9I
5OH0dS0JQeJreYWFCsAG39HkdkVWhkcLmNNZn7xlvF42TuHBWFdL8uTOHFBfhKMN
KSyQuVvP3h+Y/8iz1xGemDFtZ1Rkmcfgj2nv84clpqSEXNj51KI=
=B3nq
-----END PGP SIGNATURE-----


M
M
Mason Hock wrote on 1 Sep 2020 19:09
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 43076@debbugs.gnu.org)
C5C765ORL6ZK.218XEKZUL0NOY@libricia-thinkcentre
On Tue Sep 1, 2020 at 6:44 AM PDT, Efraim Flashner wrote:
Toggle quote (41 lines)
> Hello and thank you for taking a look at this package.
>
> On Thu, Aug 27, 2020 at 01:56:19PM -0700, Mason Hock wrote:
> > From: Mason Hock <mason@masonhock.com>
> >
> > ---
> > gnu/packages/messaging.scm | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> > index 9dc3e58ef9..6c47004293 100644
> > --- a/gnu/packages/messaging.scm
> > +++ b/gnu/packages/messaging.scm
> > @@ -642,7 +642,7 @@ was initially a fork of xmpppy, but uses non-blocking sockets.")
> > (define-public gajim
> > (package
> > (name "gajim")
> > - (version "1.1.3")
> > + (version "1.2.2")
> > (source (origin
> > (method url-fetch)
> > (uri (string-append "https://gajim.org/downloads/"
> > @@ -650,7 +650,7 @@ was initially a fork of xmpppy, but uses non-blocking sockets.")
> > "/gajim-" version ".tar.bz2"))
> > (sha256
> > (base32
> > - "0bzxwcpdd4ydh6d6mzpr0gxwhcb0x9ympk55fpvm1hcw9d28a716"))))
> > + "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))))
> > (build-system python-build-system)
> > (arguments
> > `(#:phases
> > --
> > 2.28.0
> >
>
> I got a hash mismatch when I tried to download the package, it turns out
> the file changed from .bz2 to .gz
>
> Then when I tried to build it I got a failure during the 'check phase.
> Can you take a look at it?

Sorry about that. I've sent a revised patch that should work.

Toggle quote (27 lines)
> starting phase `check'
> running test
> Searching for packaging
> Reading https://pypi.org/simple/packaging/
> Download error on https://pypi.org/simple/packaging/: [Errno -2] Name or
> service not known -- Some packages may not be found!
> Couldn't find index page for 'packaging' (maybe misspelled?)
> Scanning index of all packages (this may take a while)
> Reading https://pypi.org/simple/
> Download error on https://pypi.org/simple/: [Errno -2] Name or service
> not known -- Some packages may not be found!
> No local packages or working download links found for packaging
> error: Could not find suitable distribution for
> Requirement.parse('packaging')
> command "python" "./setup.py" "test" "-s" "test.no_gui" failed with
> status 1
> builder for
> `/gnu/store/3f9gfcg7i32h9zzad3szq4rbxaj1fqzb-gajim-1.2.2.drv' failed
> with exit code 1
> build of /gnu/store/3f9gfcg7i32h9zzad3szq4rbxaj1fqzb-gajim-1.2.2.drv
> failed
>
> --
> Efraim Flashner <efraim@flashner.co.il> ????? ?????
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received
> unencrypted
L
L
Leo Famulari wrote on 1 Sep 2020 20:00
(no subject)
(address . control@debbugs.gnu.org)
20200901180026.GA9490@jasmine.lan
merge 43076 43156
L
L
Ludovic Courtès wrote on 12 Oct 2020 19:26
Re: [bug#43156] [PATCH v2] gnu: gajim: Update to 1.2.2
(name . Mason Hock)(address . chaosmonk@riseup.net)
87k0vvnynp.fsf@gnu.org
Hi Mason,

"Mason Hock" <chaosmonk@riseup.net> skribis:

Toggle quote (3 lines)
> Sorry, after some further testing I found another problem. Please
> disregard.

Any update on this patch?

Thanks in advance,
Ludo’.
M
M
Mason Hock wrote on 21 Oct 2020 05:20
(name . Ludovic Courtès)(address . ludo@gnu.org)
C6I8U3LV6YTG.397J6VZB07795@libricia-thinkcentre
On Mon Oct 12, 2020 at 10:26 AM PDT, Ludovic Courtès wrote:
Toggle quote (7 lines)
> "Mason Hock" <chaosmonk@riseup.net> skribis:
>
> > Sorry, after some further testing I found another problem. Please
> > disregard.
>
> Any update on this patch?

Hi Ludovic,

The problem is that Gajim launches, but fails to connect to the the
server due to an error in lib/python3.8/site-packages/nbxmpp/tcp.py:

Gi.repository.GLib.Error: g-tls-error-quark: TLS support is not
available

As far as I was able to gather, this error typically means that
glib-networking is not available. However, I tried adding
glib-networking as a both an input and a propogated input for both gajim
and python-nbxmpp, and still get the same error.

I wasn't sure what to try next, and then other tasks got in the way of
digging any deeper. Sorry for the delay.
L
L
Ludovic Courtès wrote on 18 Dec 2020 14:09
Re: [bug#43076] [bug#43156] [PATCH v2] gnu: gajim: Update to 1.2.2
87a6ubdzwm.fsf@gnu.org
Hi,

Gajim was updated in a4f763cd6a69b64bf6a7e7d1a82002040c7eefe9.

Closing!

Ludo’.
Closed
?