[PATCH 1/2] gnu: muse-sequencer: Update to 3.1.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Ludovic Courtès
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 23 Aug 2020 17:15
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200823151551.16314-1-monego@posteo.net
* gnu/packages/music.scm (muse-sequencer): Update to 3.1.1.
[arguments]: Set CMAKE_BUILD_TYPE to Release. Add stage to set LDFLAGS.
Add stage to wrap executable.
[inputs]: Sort alphabetically.
---
This package is broken in the CI. I had to update the version to fix.

There are still some rough edges, but it builds and is somewhat usable.
gnu/packages/music.scm | 44 +++++++++++++++++++++++++++++-------------
1 file changed, 31 insertions(+), 13 deletions(-)

Toggle diff (88 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ae8579cb47..7cc6d7b1ea 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4127,7 +4128,7 @@ sample library.")
(define-public muse-sequencer
(package
(name "muse-sequencer")
- (version "3.0.0")
+ (version "3.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4139,7 +4140,7 @@ sample library.")
(file-name (git-file-name name version))
(sha256
(base32
- "1nninz8qyqlxxjdnrm79y3gr3056pga9l2fsqh674jd3cjvafya3"))))
+ "1rasp2v1ds2aw296lbf27rzw0l9fjl0cvbvw85d5ycvh6wkm301p"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there is no test target
@@ -4147,27 +4148,44 @@ sample library.")
(list "-DENABLE_LV2_SUPPLIED=OFF"
"-DENABLE_RTAUDIO=OFF" ; FIXME: not packaged
"-DENABLE_INSTPATCH=OFF" ; FIXME: not packaged
- "-DENABLE_VST_NATIVE=OFF")
+ "-DENABLE_VST_NATIVE=OFF"
+ "-DCMAKE_BUILD_TYPE=Release")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'chdir
- (lambda _ (chdir "muse3"))))))
+ (lambda _ (chdir "muse3")))
+ ;; Fix validate-runpath stage.
+ (add-before 'configure 'set-LDFLAGS
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (setenv "LDFLAGS"
+ (string-append
+ "-Wl,-rpath=" (assoc-ref outputs "out")
+ "/lib/muse-3.1/modules"))))
+ ;; Ensure that icons are found at runtime.
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/muse3")
+ `("QT_PLUGIN_PATH" prefix
+ ,(list (string-append (assoc-ref inputs "qtsvg")
+ "/lib/qt5/plugins/"))))))))))
(inputs
`(("alsa-lib" ,alsa-lib)
- ("lash" ,lash)
- ("jack" ,jack-1)
- ("liblo" ,liblo)
("dssi" ,dssi)
+ ("fluidsynth" ,fluidsynth)
+ ("jack" ,jack-1)
("ladspa" ,ladspa)
- ("lv2" ,lv2)
- ("lilv" ,lilv)
- ("sord" ,sord)
- ("libsndfile" ,libsndfile)
+ ("lash" ,lash)
+ ("liblo" ,liblo)
("libsamplerate" ,libsamplerate)
- ("fluidsynth" ,fluidsynth)
+ ("libsndfile" ,libsndfile)
+ ("lilv" ,lilv)
+ ("lv2" ,lv2)
("pcre" ,pcre)
+ ("pulseaudio" ,pulseaudio)
("qtbase" ,qtbase)
- ("qtsvg" ,qtsvg)))
+ ("qtsvg" ,qtsvg)
+ ("sord" ,sord)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
--
2.20.1
V
V
Vinicius Monego wrote on 23 Aug 2020 17:17
[PATCH 2/2] gnu: muse-sequencer: Add dependencies.
(address . 42997@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200823151745.16679-1-monego@posteo.net
* gnu/packages/music.scm (muse-sequencer): Add dependencies.
[arguments]: Fix RtAudio include path.
[inputs]: Add glib, libinstpatch, lrdf, python, python-pyro4, rtaudio, rubberband.
---
gnu/packages/music.scm | 14 ++++++++++++--
1 file changed, 12 insertions(+), 2 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7cc6d7b1ea..31aaa130e8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4146,14 +4146,17 @@ sample library.")
`(#:tests? #f ; there is no test target
#:configure-flags
(list "-DENABLE_LV2_SUPPLIED=OFF"
- "-DENABLE_RTAUDIO=OFF" ; FIXME: not packaged
- "-DENABLE_INSTPATCH=OFF" ; FIXME: not packaged
"-DENABLE_VST_NATIVE=OFF"
"-DCMAKE_BUILD_TYPE=Release")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'chdir
(lambda _ (chdir "muse3")))
+ ;; Fix RtAudio include syntax.
+ (add-after 'chdir 'fix-rtaudio
+ (lambda _
+ (substitute* "muse/driver/rtaudio.h"
+ (("rtaudio/RtAudio.h") "RtAudio.h"))))
;; Fix validate-runpath stage.
(add-before 'configure 'set-LDFLAGS
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -4173,18 +4176,25 @@ sample library.")
`(("alsa-lib" ,alsa-lib)
("dssi" ,dssi)
("fluidsynth" ,fluidsynth)
+ ("glib" ,glib)
("jack" ,jack-1)
("ladspa" ,ladspa)
("lash" ,lash)
+ ("libinstpatch" ,libinstpatch)
("liblo" ,liblo)
("libsamplerate" ,libsamplerate)
("libsndfile" ,libsndfile)
("lilv" ,lilv)
+ ("lrdf" ,lrdf)
("lv2" ,lv2)
("pcre" ,pcre)
("pulseaudio" ,pulseaudio)
+ ("python" ,python)
+ ("python-pyro4" ,python-pyro4)
("qtbase" ,qtbase)
("qtsvg" ,qtsvg)
+ ("rtaudio" ,rtaudio)
+ ("rubberband" ,rubberband)
("sord" ,sord)))
(native-inputs
`(("pkg-config" ,pkg-config)
--
2.20.1
L
L
Leo Famulari wrote on 23 Aug 2020 20:22
Re: [bug#42997] [PATCH 1/2] gnu: muse-sequencer: Update to 3.1.1.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42997@debbugs.gnu.org)
20200823182203.GA5668@jasmine.lan
Attachment: file
V
V
Vinicius Monego wrote on 24 Aug 2020 18:46
(name . Leo Famulari)(address . leo@famulari.name)(address . 42997@debbugs.gnu.org)
87zh6km1pw.fsf@posteo.net
Leo Famulari writes:

Toggle quote (9 lines)
>> + (add-before 'configure 'set-LDFLAGS
>> + (lambda* (#:key inputs outputs #:allow-other-keys)
>> + (setenv "LDFLAGS"
>> + (string-append
>> + "-Wl,-rpath=" (assoc-ref outputs "out")
>> + "/lib/muse-3.1/modules"))))
>
> Does this phase actually work?

Without this phase the validate-runpath phase will fail. If
validate-runpath is deleted, the executable will not find the
shared
libraries (libmuse*) in that folder and will not start. With this
phase
it finds the libraries and starts, despite the warning.

There are some segfaults and some UI elements are not loading
(e.g. the
"Add synth" in the right-click menu and the plugin
configuration). I'm going to
pass the torch to the next contributor. I hope these patches will
save some work.
L
L
Ludovic Courtès wrote on 18 Dec 2020 14:13
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42997@debbugs.gnu.org)
875z4zdzq7.fsf@gnu.org
Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (5 lines)
> * gnu/packages/music.scm (muse-sequencer): Update to 3.1.1.
> [arguments]: Set CMAKE_BUILD_TYPE to Release. Add stage to set LDFLAGS.
> Add stage to wrap executable.
> [inputs]: Sort alphabetically.

Hi! This update happened independently in commit
5525aea7cf1444fe65dd96ce1d413c7f7331d67b.

Ludo’.
L
L
Ludovic Courtès wrote on 18 Dec 2020 14:14
Re: [bug#42997] [PATCH 2/2] gnu: muse-sequencer: Add dependencies.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42997-done@debbugs.gnu.org)
871rfndzod.fsf@gnu.org
Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (4 lines)
> * gnu/packages/music.scm (muse-sequencer): Add dependencies.
> [arguments]: Fix RtAudio include path.
> [inputs]: Add glib, libinstpatch, lrdf, python, python-pyro4, rtaudio, rubberband.

Done in fb24a4d5b87fa77a42966938df5e9761c0991876. Closing!

Ludo'.
Closed
?