request: make guix upgrade recognize --do-not-upgrade

  • Done
  • quality assurance status badge
Details
2 participants
  • Jesse Gibbons
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Jesse Gibbons
Severity
normal
J
J
Jesse Gibbons wrote on 11 Aug 2020 20:37
(address . bug-guix@gnu.org)
6f97171f-73ac-8289-d006-e379d00c0785@gmail.com
From the manual:

   • ‘guix search’ is an alias for ‘guix package -s’,
   • ‘guix install’ is an alias for ‘guix package -i’,
   • ‘guix remove’ is an alias for ‘guix package -r’,
   • ‘guix upgrade’ is an alias for ‘guix package -u’,
   • and ‘guix show’ is an alias for ‘guix package --show=’.

One option for "guix package -u" I often find myself using is
--do-not-upgrade. However, guix upgrade does not recognize that option.

When I run "guix upgrade --do-not-upgrade=ungoogled-chromium" I get the
following results:

guix upgrade: error: do-not-upgrade=ungoogled-chromium: unrecognized option

This is a bit frustrating, because I want to be able to upgrade all my
profiles with the command:

"guix package --list-profiles | xargs -n1 guix upgrade
--do-not-upgrade=ungoogled-chromium"

But it prints the above error for every profile and doesn't actually do
anything.

For now, my work-around is code like the following:

"for profile in $(guix package --list-profiles); do guix package -p
$profile --do-not-upgrade=ungoogled-chromium -u; done"

As you can see, this is quite a bit more complex than it needs to be.

So, why not have guix upgrade recognize the --do-not-upgrade option?
M
M
Mathieu Othacehe wrote on 28 Aug 2020 14:28
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)(address . 42814-done@debbugs.gnu.org)
87eenr0xb0.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> As you can see, this is quite a bit more complex than it needs to be.
>
> So, why not have guix upgrade recognize the --do-not-upgrade option?

Thanks for the suggestion, it has been implemented by Jakub with
7ba7d50f92416821ec4fc124a49d74149b6d4d33.

Mathieu
Closed
?