[PATCH] gnu: Add python-devtools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 10 Aug 2020 09:55
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20200810075517.4816-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-devtools): New variable.
---
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4026d13f2d..1ecec43ed2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21532,3 +21532,35 @@ and have a maximum lifetime built-in.")
"This package contains a small collection of test tool plugins for
@code{nose2} and @code{flake8}.")
(license license:asl2.0)))
+
+(define-public python-devtools
+ (package
+ (name "python-devtools")
+ (version "0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/samuelcolvin/python-devtools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15zczdcm90wl54c68f1qjb05nkd5bjsc9xjl3lk4frs7k7wkmrvp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-mock" ,python-pytest-mock)))
+ (propagated-inputs
+ `(("python-pygments" ,python-pygments)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest")
+ #t)))))
+ (home-page "https://github.com/samuelcolvin/python-devtools")
+ (synopsis "Python's missing debug print command and other development tools")
+ (description
+ "Python's missing debug print command and other development tools.
+Adds a simple and readable way to print stuff during development.")
+ (license license:expat)))
--
2.28.0
M
M
Mathieu Othacehe wrote on 10 Aug 2020 12:11
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 42791-done@debbugs.gnu.org)
87tuxag68r.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-devtools): New variable.

Fixed indentation, edited synopsis and description and pushed!

Thanks,

Mathieu
Closed
?