Linux-libre 'deblob-check' file-names do not include a version number

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Mark H Weaver
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 10 Aug 2020 03:59
Re: Linux-libre 5.8 and beyond
(name . Mark H Weaver)(address . mhw@netris.org)
20200810015931.GA24189@jasmine.lan
On Sun, Aug 09, 2020 at 06:17:48PM -0400, Mark H Weaver wrote:
Toggle quote (5 lines)
> If the file name and hash matches a previously downloaded file in your
> store, the guix daemon uses that one and skips the download, regardless
> of the URL. That's why no error was reported. There's no version
> number in the file name of the 'deblob-check' file.

We should try to make these files include the version number to avoid
this kind of mistake in the future.

I've CC-ed bug-guix so that we don't forget.
L
L
Leo Famulari wrote on 10 Aug 2020 19:06
(no subject)
(address . control@debbugs.gnu.org)
20200810170629.GA24355@jasmine.lan
retitle 42789 Linux-libre 'deblob-check' file-names do not include a version number
L
L
Leo Famulari wrote on 10 Aug 2020 19:16
Re: Linux-libre 'deblob-check' file-names do not include a version number
(address . 42789@debbugs.gnu.org)
20200810171636.GA24590@jasmine.lan
I've attached a patch that should prevent this kind of mistake in the
future.

We should queue it up to be pushed with the next kernel updates (on the
kernel-updates branch).
From e9ca6405e351baf4356a7300aa252d25056a322c Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Mon, 10 Aug 2020 12:40:49 -0400
Subject: [PATCH] gnu: Use a descriptive file-name for linux-libre
'deblob-check' scripts.


* gnu/packages/linux.scm (linux-libre-deblob-scripts): Use file-name for
the deblob-check script.
---
gnu/packages/linux.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a2d6d384ee..9d553e7772 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -200,6 +200,7 @@ defconfig. Return the appropriate make target if applicable, otherwise return
(uri (string-append "https://linux-libre.fsfla.org"
"/pub/linux-libre/releases/" version "-gnu/"
"deblob-check"))
+ (file-name (string-append "linux-libre-" version "-deblob-check"))
(sha256 deblob-check-hash))))
(define deblob-scripts-5.8
--
2.28.0
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl8xgPQACgkQJkb6MLrK
fwgwAhAAp9lJfvDDpHr1dYc/lsxpqMwN+nVd7fmgjS+gFai9oz9y/rRfg5zOBy+Y
CnRE0LbrCu7HXPqwCsIlcn+q6QUJfkZc4SA29/xfqes0l8dRR/graqCs1d+AhWXm
RVfB22kVuRLuA7mswgWliuvUXYQH8dYG2y3sLcOhhi0d+VYh3IJ5f+uZBMDhiOYZ
vOYvSQ07djzjYIPHgcryHtzFyMQBGhnnW2XVzNFGOVjFQB0eJsBe55ssScJ9Mx/R
Url0+LR6FlW4ajzJpHigoVpqsBe1sczddaqAL1pzMEnHroOwY0N9A7N1/TGkKiw5
VdgXT580nM12xtmL6t+J+tcm8EaVxmXNMveUz65R18BJFC1FnCIwNvxfX4hOS3w9
8b5jjOfpKv/BI0Y7cYuM8nBnvSo6roc37gSRfFwdsZLX0f9j7Zk8hOgTfDVPqS1z
BO/mzgGOcl8D7xn+VZhKgrCAxG8bFN3/e4V+QsApWqE5/7luhs/Qgfst7k4JBwJI
JMO5PI6sbzvR4iOxzoZhejsz+PES7GVV+/r9QCyQvHQRapExOgrsLHY9bzhQ2RF7
Yilvnzz52C2LWvxz0IcRBH/cQf028UnmJalQ/nLZWRBk+J0iDAkXDLnbyYGOTKVF
RRg/A/+1ANxuIzjPUicfXLdl/XrImAeWHgUivGZTi3wvaz2Ryrk=
=wYex
-----END PGP SIGNATURE-----


M
M
Mark H Weaver wrote on 11 Aug 2020 05:46
Re: Linux-libre 5.8 and beyond
(name . Leo Famulari)(address . leo@famulari.name)
871rkdj13e.fsf@netris.org
Hi Leo,

Leo Famulari <leo@famulari.name> wrote:
Toggle quote (9 lines)
> On Sun, Aug 09, 2020 at 06:17:48PM -0400, Mark H Weaver wrote:
>> If the file name and hash matches a previously downloaded file in your
>> store, the guix daemon uses that one and skips the download, regardless
>> of the URL. That's why no error was reported. There's no version
>> number in the file name of the 'deblob-check' file.
>
> We should try to make these files include the version number to avoid
> this kind of mistake in the future.

That's a good idea. In a later message you posted a proposed patch:

Toggle quote (27 lines)
> From e9ca6405e351baf4356a7300aa252d25056a322c Mon Sep 17 00:00:00 2001
> From: Leo Famulari <leo@famulari.name>
> Date: Mon, 10 Aug 2020 12:40:49 -0400
> Subject: [PATCH] gnu: Use a descriptive file-name for linux-libre
> 'deblob-check' scripts.
>
> Fixes <https://bugs.gnu.org/42789>.
>
> * gnu/packages/linux.scm (linux-libre-deblob-scripts): Use file-name for
> the deblob-check script.
> ---
> gnu/packages/linux.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index a2d6d384ee..9d553e7772 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -200,6 +200,7 @@ defconfig. Return the appropriate make target if applicable, otherwise return
> (uri (string-append "https://linux-libre.fsfla.org"
> "/pub/linux-libre/releases/" version "-gnu/"
> "deblob-check"))
> + (file-name (string-append "linux-libre-" version "-deblob-check"))
> (sha256 deblob-check-hash))))
>
> (define deblob-scripts-5.8

If we're going to prefix "linux-libre-" to the name, which I agree is a
good idea, maybe we should add the same prefix to the other 'deblob'
script, for consistency. Also for consistency, I think the version
number should be at the end, after "deblob-check", as is the case for
the other deblob script.

There's also the question of whether the micro version number should be
included in the file name. In practice, these deblob scripts almost
never change from one micro version to the next. Also, I suspect
(although I've not yet confirmed it) that these deblob scripts likely
work for older kernels in the same stable series.

For those reasons, at present the micro version number appears only in
the URLs, and not in either the file names or in the version number as
recorded in the first element of the triplet returned by
'linux-libre-deblob-scripts'. I'd personally be inclined to keep it
that way, although I don't feel strongly about it.

What do you think?

Thanks,
Mark
L
L
Leo Famulari wrote on 12 Aug 2020 00:46
(name . Mark H Weaver)(address . mhw@netris.org)
20200811224601.GA31177@jasmine.lan
On Mon, Aug 10, 2020 at 11:46:34PM -0400, Mark H Weaver wrote:
Toggle quote (18 lines)
> If we're going to prefix "linux-libre-" to the name, which I agree is a
> good idea, maybe we should add the same prefix to the other 'deblob'
> script, for consistency. Also for consistency, I think the version
> number should be at the end, after "deblob-check", as is the case for
> the other deblob script.
>
> There's also the question of whether the micro version number should be
> included in the file name. In practice, these deblob scripts almost
> never change from one micro version to the next. Also, I suspect
> (although I've not yet confirmed it) that these deblob scripts likely
> work for older kernels in the same stable series.
>
> For those reasons, at present the micro version number appears only in
> the URLs, and not in either the file names or in the version number as
> recorded in the first element of the triplet returned by
> 'linux-libre-deblob-scripts'. I'd personally be inclined to keep it
> that way, although I don't feel strongly about it.

Good ideas. I've taken them into account on my local branch while I test
building the final tarballs. I'll push to the kernel-updates branch once
I am satisfied with the result.

Thanks for your feedback!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl8zH6IACgkQJkb6MLrK
fwh/jxAAmAuGkBhi62S00NxbvCeXtAdDTO2C1y4Lz4obYASaVDg7sotu/QE7MFMF
7vDHtiPlJLhEX7C2jZFk7lG03nAdzJlfANH2wCa3hvo/vc7pvXjHiSF66KlXTbQ+
TYulk++GERADZZqUqrbtEwIFjLT+6TbypxmOCj6EGG8+N5wSc9qqzag5N9F6Mmb2
XBpnWTgUAoOYbsakG2MHpZCm7c0Gx4izvfXEWAbkPhnakluUltlCHvCMLggDy+36
6PHCsOrjf2NFU42KQTothcZezsN+mNhg4tsR9TlW2DozEQ8vcsI8QKtUwZPjrBnl
a1RwcUt01bxptrYL/U0usW2O3/cueZE2IVn39sYZCS4/g2U2Pd8tz2PKI93tVjIO
DTkCxmot0D2S4zkTAgPbYbugDSvmBf3MnyHfAJV75cL7cqBiWVg1ZjyMIJCmOFKm
814YUuSxmGOSN7q2RG0CzOgXtykfYAGQpvh4P4Iy7NOygRkpNcQKtvQKNNNBjEJK
jWThFAgVFM8JhcoXIZ4wAHBIh71CWt/iWuOc4s2RdrHc1cVxxh/uz/47sjaHeIMl
3h4D0FZ5xkG8EMz6qS1vT4oBAPCE0IMHpjxuk0lHv8NfJ9rlE7rgXp6TI4HYhDWs
gobNgNZVFwKWo96zS4bm2k+u8P9isAa950acAx48EN1vVjrcoBw=
=7HKj
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 12 Aug 2020 05:24
(name . Mark H Weaver)(address . mhw@netris.org)
20200812032440.GA24370@jasmine.lan
On Tue, Aug 11, 2020 at 06:46:01PM -0400, Leo Famulari wrote:
Toggle quote (4 lines)
> Good ideas. I've taken them into account on my local branch while I test
> building the final tarballs. I'll push to the kernel-updates branch once
> I am satisfied with the result.

I've pushed an updated patch to the kernel-updates branch:


It will be built on the build farm here, based on commit b1f5568b1:

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl8zYPgACgkQJkb6MLrK
fwjvHw//fQEW6WLiUBfd5W75F6gTCfKI+T9nWFlybiEgPKkqJvd85mw1ar9zacp5
Mbv/RC6VUwwxAyYyn8GpmappgcYU+BB8P11KjeBUw+Q/VrrPYHRmiPbu4nvcRKtR
gEmVA25nTYiVYSEFb9QtuPNN38pMW87phKgB3pU6riJ3BvtfYkWu2JZJKPq9fJgn
Ajo1qcsZxjK+ni6hlE8PWYi5XazP3yJFg0aDCcJPMxvkJg0W+TZLzLZ0SXvbrbsm
5RHV69vHOptWpzXgoFvmBBTEJvPpLhlhPWYVQbl1NnJjvhk+O3aBaxaLqSvQbxs/
yMm8GJKgpDhilObt6JS33XYkggk0Mk3OgvLz9gJ5LqTn+CQL2mS/labaOzSKwjn7
izCx+ycdgp8fFO6X6GpWxK1kohf+EVwRkXm0H0ZrcZ9AddbZEyrYPY4x63CJI/Sd
n71cZiTQcgbpBZi91SuPnkPm6VOH/ThfTDOPbtz7Ku1oyqaXA3m61XJrAUafdP2a
divVDYscgIsR8r98YayJiMfRq2eYL7FIDxFBvFxJc6cnFjgaU8kp0oFvCNGNRnLR
YOHKJNahkc6QgFX9b3bZgE0BzzujacirII7bopDrANx7b2/8UBnI6PHKuwPeaL8G
domx3g+0i9CKyOMvrvdH8FL2R6eB7U1p23C41nV/rLLpjzEi7j0=
=VKzb
-----END PGP SIGNATURE-----


M
M
Mark H Weaver wrote on 12 Aug 2020 23:34
(name . Leo Famulari)(address . leo@famulari.name)
87lfijv98n.fsf@netris.org
Leo Famulari <leo@famulari.name> wrote:

Toggle quote (4 lines)
> I've pushed an updated patch to the kernel-updates branch:
>
> https://git.savannah.gnu.org/cgit/guix.git/commit/?h=kernel-updates&id=387446c93261868bd4c4188687b508aa0a2da7e8

Looks good to me. Thank you!

Mark
L
L
Leo Famulari wrote on 22 Aug 2020 00:02
(name . Mark H Weaver)(address . mhw@netris.org)
20200821220219.GA7057@jasmine.lan
On Wed, Aug 12, 2020 at 05:34:21PM -0400, Mark H Weaver wrote:
Toggle quote (8 lines)
> Leo Famulari <leo@famulari.name> wrote:
>
> > I've pushed an updated patch to the kernel-updates branch:
> >
> > https://git.savannah.gnu.org/cgit/guix.git/commit/?h=kernel-updates&id=387446c93261868bd4c4188687b508aa0a2da7e8
>
> Looks good to me. Thank you!

Pushed as 1bc275034fe8070c720ca341db2d9588480aa044
Closed
?