[PATCH] gnu: Add rttr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Michael Rohleder
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 8 Aug 2020 19:53
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20200808175320.12200-1-mike@rohleder.de
* gnu/packages/cpp.scm (rttr): New variable.
---
A newer version of kdenlive needs this.

gnu/packages/cpp.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 5e83bb69f6..9ff4dc864b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -82,7 +83,35 @@ strings, configuration, bit streams, threading, translation, and cross-platform
operating system functions.")
(license license:zlib)))
+(define-public rttr
+ (package
+ (name "rttr")
+ (version "0.9.6")
+ (home-page "https://github.com/rttrorg/rttr/")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1yxad8sj40wi75hny8w6imrsx8wjasjmsipnlq559n4b6kl84ijp"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; TODO
+ #:configure-flags
+ '("-DBUILD_UNIT_TESTS=OFF"
+ "-DBUILD_DOCUMENTATION=OFF")))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "C++ Reflection Library")
+ (description
+ "RTTR stands for Run Time Type Reflection. It describes the ability of a
+computer program to introspect and modify an object at runtime. It is also the
+name of the library itself, which is written in C++ and released as open
+source library.")
+ (license license:expat)))
+
(define-public rct
(let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
(revision "2"))
--
2.28.0
M
M
Mathieu Othacehe wrote on 10 Aug 2020 11:34
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42767@debbugs.gnu.org)
87eeoehmja.fsf@gnu.org
Hello Michael,

Thanks for this patch. Did you change something to the way you are
sending patches? I have troubles to apply them, with errors such as:

Toggle snippet (8 lines)
Applying: gnu: Add rttr.
Using index info to reconstruct a base tree...
M gnu/packages/cpp.scm
error: patch failed: gnu/packages/cpp.scm:82
error: gnu/packages/cpp.scm: patch does not apply
error: Did you hand edit your patch?

Toggle quote (2 lines)
This field is traditionally at the end of the package definition, right
before synopsis.

Toggle quote (3 lines)
> + (source
> + '(#:tests? #f ; TODO

You could elaborate on why they are not enabled. Something to fix in particular?

Toggle quote (11 lines)
> + #:configure-flags
> + '("-DBUILD_UNIT_TESTS=OFF"
> + "-DBUILD_DOCUMENTATION=OFF")))
> + (native-inputs `(("pkg-config" ,pkg-config)))
> + (synopsis "C++ Reflection Library")
> + (description
> + "RTTR stands for Run Time Type Reflection. It describes the ability of a
> +computer program to introspect and modify an object at runtime. It is also the
> +name of the library itself, which is written in C++ and released as open
> +source library.")

There are a couple of linting warnings on this description. No need to
mention that it's open source :).

Thanks,

Mathieu
M
M
Michael Rohleder wrote on 10 Aug 2020 20:19
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 42767@debbugs.gnu.org)
87sgcunz2y.fsf@rohleder.de
Hello Mathieu,

Thank you very much for reviewing (my mess, as I was too focused on making
kdenlive run...).

Here is a (hopefully) better version.

It includes running 528 unit_tests, except the ones for library_test.cpp
where I couldn't figure out why they fail, so I substitute it away.
From 46a38e83b831cf0c5a0e31b2d905ac9d4d77a5a8 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Mon, 10 Aug 2020 20:17:07 +0200
Subject: [PATCH] gnu: Add rttr.

* gnu/packages/cpp.scm (rttr): New variable.
---
gnu/packages/cpp.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index bf89ff12ea..8c0afe4955 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -82,6 +83,42 @@ strings, configuration, bit streams, threading, translation, and cross-platform
operating system functions.")
(license license:zlib)))
+(define-public rttr
+ (package
+ (name "rttr")
+ (version "0.9.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rttrorg/rttr/")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1yxad8sj40wi75hny8w6imrsx8wjasjmsipnlq559n4b6kl84ijp"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; no check target. Setting test-target to "unit_test" runs
+ ; it twice.
+ #:configure-flags
+ '("-DBUILD_DOCUMENTATION=OFF" "-DBUILD_EXAMPLES=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ ;; library_test fails in chroot.
+ (add-after 'unpack 'skip-library-test
+ (lambda _
+ (substitute* "src/unit_tests/unit_tests.cmake"
+ (("misc/library_test.cpp") ""))
+ #t)))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/rttrorg/rttr/")
+ (synopsis "C++ Reflection Library")
+ (description
+ "RTTR stands for Run Time Type Reflection. It describes the ability of a
+computer program to introspect and modify an object at runtime. It is also
+the name of the library itself, which is written in C++.")
+ (license license:expat)))
+
(define-public rct
(let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
(revision "2"))
--
2.28.0
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8xj6UACgkQfHr/vv7y
yyVDmAf7BlIG1qbPItOrNUJEZS4p2lmFq5c/GmJZzF9cSSSmN3VhavMYAFwq9yR6
kWz5cMERIee4vICqMvPBK0bMk9Vy2fcV94cB2UWFSAJIQhvjDZLV/p3IdToHHlj2
pl5boA+qQnsN4kz4+aHb2AVmpWNynTPYey8ODGpMb8es1WejJU6M1lm+YKC1aYKA
DxAplcHay0Cfik01ub/j43a/q7S8c6zjlDnowi95WF/Nmn10eyFpRWnFcfdyKKkP
nIQXptdeTJNPt1AVNnqo3q33s5BKoLGLzNQE4DqiBOEeD7ds0onaMtllKHa9KXds
TAU+WovNSWxpdLYf7eNaSoucyg1e+g==
=WsI6
-----END PGP SIGNATURE-----

M
M
Mathieu Othacehe wrote on 11 Aug 2020 11:01
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 42767-done@debbugs.gnu.org)
87wo25wo7r.fsf@gnu.org
Hey,

Toggle quote (3 lines)
> It includes running 528 unit_tests, except the ones for library_test.cpp
> where I couldn't figure out why they fail, so I substitute it away.

This looks fine, pushed!

Thanks,

Mathieu
Closed
?