[PATCH] gnu: foo2zjs: Fix install phase.

  • Done
  • quality assurance status badge
Details
2 participants
  • Boris A. Dekshteyn
  • Leo Famulari
Owner
unassigned
Submitted by
Boris A. Dekshteyn
Severity
normal
B
B
Boris A. Dekshteyn wrote on 8 Aug 2020 10:09
(address . guix-patches@gnu.org)(name . Boris A. Dekshteyn)(address . boris.dekshteyn@gmail.com)
20200808080918.21304-1-boris.dekshteyn@gmail.com
* gnu/packages/cups.scm (foo2zjs): Fix install phase

Existed package definition builds fine, but de-facto it doesn't work
as expected. This quick and dirty patch make it's functional (tested with
HP LJ M1005, at least i'am able to add printer, configure, and print test
page through cups web interface), but needs some further work (fix and install
udev rules and hotplug helper) to make it fully functional.
---
gnu/packages/cups.scm | 39 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 38 insertions(+), 1 deletion(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 281c2718e8..899ea594f3 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages fonts) ; font-dejavu
#:use-module (gnu packages fontutils)
@@ -716,6 +717,40 @@ printer/driver specific, but spooler-independent PPD file.")
(("^MODTIME[[:blank:]]*=.*$")
"MODTIME = echo Thu Jan 01 01:00:00 1970\n"))
#t))
+ (add-before 'install 'make-install-dirs
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make missing install dirs
+ (let ((out (assoc-ref outputs "out"))
+ (dirs '("/share/cups/model"
+ "/share/foomatic/db/source/opt"
+ "/share/foomatic/db/source/printer"
+ "/share/foomatic/db/source/driver"
+ "/lib/cups/filter")))
+ (for-each (lambda (dir)
+ (mkdir-p (string-append out dir)))
+ dirs))))
+ (add-after 'install 'wrap-wrappers
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (ghostscript (assoc-ref inputs "ghostscript"))
+ (coreutils (assoc-ref inputs "coreutils"))
+ (sed (assoc-ref inputs "sed")))
+ (for-each (lambda (file)
+ (wrap-program file
+ `("PATH" ":" prefix
+ (,(string-append ghostscript "/bin:"
+ coreutils "/bin:"
+ sed "/bin")))))
+ (find-files (string-append
+ out "/bin") "wrapper$")))))
+ (add-after 'install 'install-cups-filters-symlinks
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each
+ (lambda (file)
+ (symlink file
+ (string-append out "/lib/cups/filter/" (basename file))))
+ (find-files (string-append out "/bin"))))))
(add-after 'install 'remove-pdf
(lambda* (#:key outputs #:allow-other-keys)
;; Remove 'manual.pdf' which is (1) useless (it's a
@@ -729,7 +764,9 @@ printer/driver specific, but spooler-independent PPD file.")
#:tests? #f ;no tests
#:make-flags '("CC=gcc")))
(inputs
- `(("ghostscript" ,ghostscript)
+ `(("coreutils" ,coreutils)
+ ("sed" ,sed)
+ ("ghostscript" ,ghostscript)
("foomatic-filters" ,foomatic-filters))) ;for 'foomatic-rip'
(native-inputs
`(("bc" ,bc)
--
2.28.0
L
L
Leo Famulari wrote on 15 Dec 2020 22:53
(name . Boris A. Dekshteyn)(address . boris.dekshteyn@gmail.com)(address . 42758-done@debbugs.gnu.org)
X9kwPVT22nNZPgrp@jasmine.lan
On Sat, Aug 08, 2020 at 08:09:18PM +1200, Boris A. Dekshteyn wrote:
Toggle quote (8 lines)
> * gnu/packages/cups.scm (foo2zjs): Fix install phase
>
> Existed package definition builds fine, but de-facto it doesn't work
> as expected. This quick and dirty patch make it's functional (tested with
> HP LJ M1005, at least i'am able to add printer, configure, and print test
> page through cups web interface), but needs some further work (fix and install
> udev rules and hotplug helper) to make it fully functional.

Thanks! I satisfied the linter and made the commit message more
descriptive, and pushed as cf066b7a4eb1426b17442e0bcb779e7d7ff4e150.

I hope you will find time for the "further work" :)
Closed
?