[PATCH 0/1] Add yeganesh.

  • Done
  • quality assurance status badge
Details
3 participants
  • EuAndreh
  • Oleg Pykhalov
  • Mathieu Othacehe
Owner
unassigned
Submitted by
EuAndreh
Severity
normal
Merged with
E
E
EuAndreh wrote on 8 Aug 2020 02:24
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20200808002418.24876-2-eu@euandre.org
Add yeganesh package, a simple wrapper around dmenu.

Instead of adding it to gnu/packages/suckless.scm where dmenu lives, I put it
inside gnu/packages/wm.scm where xmonad lives.

That's because it was made with xmonad in mind, and is also written in
Haskell, as is xmonad.

EuAndreh (1):
gnu: Add yeganesh.

gnu/packages/wm.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

--
2.27.0
E
E
EuAndreh wrote on 8 Aug 2020 11:24
[PATCH 1/1] gnu: Add yeganesh.
(address . 42754@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20200808092421.28832-1-eu@euandre.org
* gnu/packages/wm.scm (yeganesh): New variable.
---
gnu/packages/wm.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index bc3c152627..32bb35b4c6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Boris A. Dekshteyn <harlequin78@gmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
+;;; Copyright © 2020 EuAndreh <eu@euandre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -742,6 +743,30 @@ is also usable with any other window manager. While xmobar is written in
Haskell, no knowledge of the language is required to install and use it.")
(license license:bsd-3)))
+(define-public yeganesh
+ (package
+ (name "yeganesh")
+ (version "2.4")
+ (source
+ (origin
+
+ (method url-fetch)
+ (uri (string-append "http://dmwit.com/yeganesh/yeganesh-" version ".tar.gz"))
+ (sha256
+ (base32 "04djfyjab3c5y9z9x8zd0xcx0jyy35zq7cl9ddr4ppf6k5ky6iky"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-strict" ,ghc-strict)
+ ("ghc-xdg-basedir" ,ghc-xdg-basedir)))
+ (home-page "http://dmwit.com/yeganesh/")
+ (synopsis "Small wrapper around dmenu")
+ (description
+ "@code{yeganesh} is a small wrapper around demnu. Like dmenu,
+it accepts input on stdin and writes the chosen result on stdout. Unlike dmenu,
+it mangles the input before it presents its choices. In particular,it displays
+commonly-chosen options before uncommon ones.")
+ (license license:bsd-3)))
+
(define-public ghc-xmonad-contrib
(package
(name "ghc-xmonad-contrib")
--
2.27.0
M
M
Mathieu Othacehe wrote on 8 Aug 2020 09:27
control message for bug #42754
(address . control@debbugs.gnu.org)
874kpdppgs.fsf@cervin.i-did-not-set--mail-host-address--so-tickle-me
merge 42754 42755
quit
O
O
Oleg Pykhalov wrote on 14 Aug 2020 14:34
Re: [bug#42754] [PATCH 0/1] Add yeganesh.
(name . EuAndreh via Guix-patches via)(address . guix-patches@gnu.org)
87h7t5s8ww.fsf@gmail.com
Hi,

EuAndreh via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (8 lines)
> Add yeganesh package, a simple wrapper around dmenu.
>
> Instead of adding it to gnu/packages/suckless.scm where dmenu lives, I put it
> inside gnu/packages/wm.scm where xmonad lives.
>
> That's because it was made with xmonad in mind, and is also written in
> Haskell, as is xmonad.

Thank you. Pushed to master as 9c814c337946f5e70b0dbe45fb54f451b06fe0b2
with small typo fix and formatting:
Toggle diff (20 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 5406aa8b99..28c3a3bac6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -761,11 +761,10 @@ Haskell, no knowledge of the language is required to install and use it.")
("ghc-xdg-basedir" ,ghc-xdg-basedir)))
(home-page "http://dmwit.com/yeganesh/")
(synopsis "Small wrapper around dmenu")
- (description
- "@code{yeganesh} is a small wrapper around demnu. Like dmenu,
-it accepts input on stdin and writes the chosen result on stdout. Unlike dmenu,
-it mangles the input before it presents its choices. In particular,it displays
-commonly-chosen options before uncommon ones.")
+ (description "@code{yeganesh} is a small wrapper around demnu. Like
+dmenu, it accepts input on stdin and writes the chosen result on stdout.
+Unlike dmenu, it mangles the input before it presents its choices. In
+particular, it displays commonly-chosen options before uncommon ones.")
(license license:bsd-3)))
(define-public ghc-xmonad-contrib
Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl82hN8ACgkQFn+OpQAa
+pwfOBAAk6Q4/INvSIhUGKy/rJLyJaPsa3hHXChs4bxmP4RQMH8FLroOyxGkS9Ca
/jlvdtTGVFunghuVM7CUIP+0LwCAe0xwtUVIXRq3SYrArEkhoW578Q2T+vvYFRMN
snh/fBFXnHF2BTgU9xXNTT7T4km0a7bKJm4TbiE0WPME+cees8mUor9lfxsIgmzn
pUtNzNAAmLlfEQ5f0To6wRHjHDLElCQwDYDSnhw5dc0nOlN2+nYJX/8UHBDfMb/w
ugshZht+ISG1DS9r/1MfRzh9bNWPccbfOQLXa/JUIjZ3F03AN0B2ZRkhSG0qZ35w
q0UUduWkgLwe4vqIBBffOr7Hfq81s325nEcoCMC3XRdeC69+dCAv5n6jg1YLY0Rj
2R2a8S+NEq+yh8gfd1uhi/gdn+Gb8fCZB9/Qum3hfn3WZmHyBm6wsMLD1BAr7D6V
EjjVsJ/EaixwpcAn3grfdvefJKg/AD2/NkYJWSvAB/GnZJU5obr8K8LXv1uHwmJQ
ynY17cMsWoVFZcFsxjJEnFJ7TvksBltmJbBlq3du8XeWqrnhErG3H/TiR00mjR9z
p9blE9M0eL/zykR6C/CJ96ksWVgNQ+LNJ17mWL6Wb8XuZ9Wyq0btfa32RNtXJu1l
C7ERRTorssi1qXWzafr4qt+4u74kl2mbXRgFyndHoXLon6QmKRU=
=yMF7
-----END PGP SIGNATURE-----

?