[PATCH 3/4] gnu: Add python-trio.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 7 Aug 2020 15:24
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200807132416.49309-3-monego@posteo.net
* gnu/packages/python-xyz.scm (python-trio): New variable.
---
gnu/packages/python-xyz.scm | 63 +++++++++++++++++++++++++++++++++++++
1 file changed, 63 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e15f1a495e..302366411a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18962,7 +18962,68 @@ project.")
;; Either license applies.
(license (list license:expat license:asl2.0))))
+(define-public python-trio
+ (package
+ (name "python-trio")
+ (version "0.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trio" version))
+ (sha256
+ (base32 "0g6gkwz6i05rm9ym4l4imxakzld7qcgxhb21kprilchcav87s1nz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'change-home
+ (lambda _
+ ;; Tests require a writable home.
+ (setenv "HOME" "/tmp")
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv" "-k"
+ (string-append
+ ;; This test times out.
+ "not test_ki_protection_works"
+ ;; Assertion errors.
+ " and not test_guest_mode_ki"
+ " and not test_run_in_trio_thread_ki"
+ ;; These try to raise KeyboardInterrupt which does not work
+ ;; in the build environment.
+ " and not test_ki_self"
+ " and not test_ki_wakes_us_up"
+ ;; Failure in name resolution.
+ " and not test_getnameinfo"
+ " and not test_SocketType_resolve"
+ ;; OSError: protocol not found.
+ " and not test_getprotobyname")))))))
+ (native-inputs
+ `(("python-astor" ,python-astor)
+ ("python-ipython" ,python-ipython)
+ ("python-jedi" ,python-jedi)
+ ("python-pylint" ,python-pylint)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-trustme" ,python-trustme)))
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-idna" ,python-idna)
+ ("python-outcome" ,python-outcome)
+ ("python-sniffio" ,python-sniffio)
+ ("python-sortedcontainers"
+ ,python-sortedcontainers)))
+ (home-page "https://github.com/python-trio/trio")
+ (synopsis "Friendly Python library for async concurrency and I/O")
+ (description
+ "Trio strives to be a production-quality, async/await-native I/O library
+for Python. Like all async libraries, its main purpose is to help you write
+programs that do multiple things at the same time with parallelized I/O.")
+ ;; Either license applies.
+ (license (list license:expat license:asl2.0))))
+
(define-public python-humanize
(package
(name "python-humanize")
--
2.20.1
E
E
Efraim Flashner wrote on 9 Aug 2020 13:56
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42743-done@debbugs.gnu.org)
20200809115603.GE840@E5400
Thanks! Pushed as deca924aa5dafc84a5da1693a0bf494bdbae44c7


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8v5FMACgkQQarn3Mo9
g1HQwRAAtJgmD1sksqJ8zu6L/TR8Mnj8QNyUDMfuv66U2ecD5ah1X75Ph1WfCYaS
NFLF1W+fDmm729BByIDtz+9TaHpkqhmunz75A4lnUyd9je25bdwCYMVmYRRbKQtO
xYh40oXl5U4FI6aglHSamocdxOqoL+WonzcH66VnOU1mOrLsFyFp8zXDY9cyZ558
HnRJbOBJAV8lXGKHPkMOih9SOV63eXrX4LzWjjrNpAMVojOZnFyFI96Rq+1tyNGr
2E4iaOMaqQnWHII1cTgs2NpSxyQ/DYe8CFNK/wyhG2LN7XKFkvFriuGBWjBX4cuW
yQzSn/d3J4M08ApUNebJj6BRCVXkQde651wIJlvET0EYqd38YjdzNGXYhIAh2/96
Ra/1PfnspeMvpu9pOuuvnPNLsRex1GyhSdv+cdVnDwNUBMyOarnjh6nebpmm2vRk
JJpwjSRo+/aLRGnoCEuOVuStdBAhsgUjmtDpKjALS7vmxbQosp6xPlpwvTm8OKXj
0JYaYlQkOoS+wQRty8uvtnzf7SIc5p5AQsVNJNTXGVRTBeCZRE1Ayf2YPwQKmzNh
2xKygK+4QXaUkBpL0AG9U75Ni/mGfrMXAlrFcTeZZI9qVklw1/RKqxGPxcNL5pEO
qhPtGhJeFkhLuXb30JSyX1t2tRbIfKdce4Y+FrQ9byEvAz8bMbY=
=1cXv
-----END PGP SIGNATURE-----


Closed
?