[PATCH 2/4] gnu: Add python-trustme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 7 Aug 2020 15:24
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200807132416.49309-2-monego@posteo.net
* gnu/packages/python-crypto.scm (python-trustme): New variable.
---
gnu/packages/python-crypto.scm | 38 ++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index ecf82f2078..f3349b505d 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +55,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages time)
@@ -1347,7 +1349,42 @@ items and collections, editing items, locking and unlocking collections
(asynchronous unlocking is also supported).")
(license license:bsd-3)))
+(define-public python-trustme
+ (package
+ (name "python-trustme")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trustme" version))
+ (sha256
+ (base32 "0v3vr5z6apnfmklf07m45kv5kaqvm6hxrkaqywch57bjd2siiywx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-more-itertools" ,python-more-itertools)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-service-identity" ,python-service-identity)
+ ("python-zipp" ,python-zipp)))
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)))
+ (home-page "https://github.com/python-trio/trustme")
+ (synopsis "Fake a certificate authority for tests")
+ (description
+ "@code{trustme} is a tiny Python package that does one thing: it gives you
+a fake certificate authority (CA) that you can use to generate fake TLS certs to
+use in your tests.")
+ ;; Either license applies.
+ (license (list license:expat license:asl2.0))))
+
(define-public python-jeepney
(package
(name "python-jeepney")
--
2.20.1
E
E
Efraim Flashner wrote on 9 Aug 2020 13:55
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42742-done@debbugs.gnu.org)
20200809115546.GD840@E5400
Thanks! Pushed as 960dafce5cede173b83a47d6b65233eb87230aaf


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8v5EEACgkQQarn3Mo9
g1FA8A/9Ec+TaTowXaq7ghjqtcwblaWV+P9wrzVv5n+7CoPiTA/oTMFfkMym3mmL
06kguWQA+dBTKKI8Xn+3pBhDxYkCJaMnv5iyQdHxmIjcX6IifNeg/iIveCMM3m6G
TewPvY3JU11Ksg6P7Y1izG/6of5n8v7OZALRrCKB/32nXjY8dOQCyM/k2qOgmUDP
q9fxZYYqO6syLA4Zq2E0Ge6rOG9pklgO6bUXkIyMOaZZXEzKV9vC3nlHgeCq+Bsk
jt1OIqXuNP7Hqjlc/wxOMlwh9x4WzAOVVd9wi5uZTDWmfOjRgsIv5/O7XHfcvxww
BOhqnrlIA/mkVE8GJFvC9oHdWCKicXhHCI8rfei0VBFqq+3mtx99KdE2qtb+tt2h
frnRV6HI1x02u4j53408BTTAdrCJ8DfGFu0M/K2tQCgzpowAflqB6ExHYRKJzyq9
YTaGL/h+E7meYlOaIlZR4z4CLJ1vT8aQrdkwactmyYhdSpCTktJj4DfOa7XwcZcL
6qPkJElvEoHYjkfhjY45Mlrh27llWMHSovepRVYN2wBmW7RKRb2ifXbanr4Ns2Ez
wS4Qe4GAyRNbQiaxfXwBq8zsIjS/Gk7X0CpqxRsFqTsvWN1a0HDDQWBBs6LVXaMm
lVskZ0+Bql+nogmfDzZejeKTeXXuQS7b3woOF+J4b6HUSQvJIR0=
=AQ1/
-----END PGP SIGNATURE-----


Closed
?