[PATCH 1/4] gnu: Add python-outcome.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Efraim Flashner
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 7 Aug 2020 15:24
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200807132416.49309-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-outcome): New variable.
---
gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4a83a2f37..e15f1a495e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18929,6 +18929,39 @@ easy-to-extend subclass system, and lots of primitive constructs to
make your work easier.")
(license license:expat)))
+(define-public python-outcome
+ (package
+ (name "python-outcome")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "outcome" version))
+ (sha256
+ (base32 "0vxn04vspmlkkyijjkjnsc46f93ki8g62hr7ag10zpd7ic324y7w"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-asyncio" ,python-pytest-asyncio)))
+ (propagated-inputs
+ `(("python-async-generator" ,python-async-generator)
+ ("python-attrs" ,python-attrs)))
+ (home-page "https://github.com/python-trio/outcome")
+ (synopsis "Capture the outcome of Python function calls")
+ (description
+ "Capture the outcome of Python function calls. Extracted from the Trio
+project.")
+ ;; Either license applies.
+ (license (list license:expat license:asl2.0))))
+
(define-public python-humanize
(package
(name "python-humanize")
--
2.20.1
B
B
Brett Gilio wrote on 7 Aug 2020 20:45
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42741@debbugs.gnu.org)
87zh7647nf.fsf@gnu.org
Hi Vinicius!

Thanks for your patch series. I just wanted to let you know that best
practice is to send patch series all to the same bug number instead of
opening a new bug number for each patch in the series. Thanks! :)
V
V
Vinicius Monego wrote on 7 Aug 2020 21:30
(name . Brett Gilio)(address . brettg@gnu.org)(address . 42741@debbugs.gnu.org)
87imduuuc8.fsf@posteo.net
Brett Gilio writes:

Toggle quote (6 lines)
> Hi Vinicius!
>
> Thanks for your patch series. I just wanted to let you know that best
> practice is to send patch series all to the same bug number instead of
> opening a new bug number for each patch in the series. Thanks! :)

Hello Brett.

Sure, but that's a problem I'm having with git. I use `git format-patch
[branch] -o folder/` and `git send-email --to="[this list]"
folder/`. Sometimes it sends to one number, sometimes it sends to
different numbers.

I sent two different series for python-h2 and python-sniffio two days
ago using the very same procedure for both. The latter was sent correctly while
the former was sent to different numbers.

Am I missing something?
V
V
Vinicius Monego wrote on 8 Aug 2020 15:35
(name . Brett Gilio)(address . brettg@gnu.org)(address . 42741@debbugs.gnu.org)
87ft8xuuo8.fsf@posteo.net
Vinicius Monego writes:

Toggle quote (2 lines)
> Am I missing something?

I double checked the documentation for submitting a patch series. I
thought that Git would have tools to automate this (I saw a --thread
flag in the git manpage, but it still didn't group the thread as
expected).

Anyways, I will follow the documentation more closely from now on. Apologies
for the inconvenience :-)
E
E
Efraim Flashner wrote on 9 Aug 2020 13:55
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42741-done@debbugs.gnu.org)
20200809115517.GC840@E5400
Thanks! Pushed as 7d7ad3c946897014cc1ccb7094382b21a8f7b45c


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8v5CQACgkQQarn3Mo9
g1F2sxAAj78RNl9MDm1PdLwCXYmufUG/hce72sCW95EPbMiuKlW6s5sJQhvrK3CF
2A6az87AnL5j32oZWs2gEEp03AihyK2Ev/DWIZHJJy2YI2sw7KKdDNwB4yfHjWl2
u82/876Yyh903KwpPMUukMJR3XpZO3HS3P9Jxn/TaTxRb97XsDfnGDk5GsfDBCVW
RRR+t4HY9vnGuwNgrY3zvFwRrNyYiwFeffNSvHSzi+JhSYO7cSKW7Wz0bBO9bjwL
GPDnxSq6J8ItHbPQbaKhiF4RZNPiLXX9Telbc1cmHh8/TUOzpVVcgJMy8ONEh3W7
z+HMz2ugssUL/e77nRTDKF3bkruTJTbBKikTBpqFNqyC5rxBjVBM+oO1dmNzVpsJ
jrduyCllegyjAfklVsUN3WBIY2qVGVrcTtdb1SRBZ9WypkJbCG0B4B3y3pfqs24F
5g4cqiyMFYtTkXnEc7g/qECExO6aw04DQpc3TFjdNMarqNYJ9hcOQ90KcFplewzr
nyggjzcYg8YFCaFhxXg3j2OTEzX1ZXrqv5uOVsEAUjiPFVLsS4ixq8YGkzPb7wh2
T+p8ezW+qebPczEuDiLIe08N1+RibIIyEid3Zv0qxmMHtncBuNLq0qsmjyX8m+ap
U2gGafsrxfFu0oVnkiLFJx/A7p78ETTfnPI4uCbpT3qA8tOdUjo=
=TQFW
-----END PGP SIGNATURE-----


Closed
?