[PATCH] gnu: emacs-emms: Fix build of emms-print-metadata.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Pierre Neidhardt
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 6 Aug 2020 10:29
(address . guix-patches@gnu.org)
20200806082935.13379-1-mail@ambrevar.xyz
* gnu/packages/emacs-xyz.scm (emacs-emms): Inherit from
emacs-emms-print-metadata.
[inputs]: Add emms-print-metadata.
[arguments]: Fix path to emms-print-metadata.
---
gnu/packages/emacs-xyz.scm | 53 +++++++++++++++++++++++++++-----------
1 file changed, 38 insertions(+), 15 deletions(-)

Toggle diff (102 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9943af0fcb..5d353d0d57 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1484,9 +1484,9 @@ incrementally confined in Isearch manner.")
;;; Multimedia.
;;;
-(define-public emacs-emms
+(define emacs-emms-print-metadata
(package
- (name "emacs-emms")
+ (name "emacs-emms-print-metadata")
(version "5.42")
(source
(origin
@@ -1495,6 +1495,37 @@ incrementally confined in Isearch manner.")
"emms-" version ".tar"))
(sha256
(base32 "1khx1fvllrs6w9kxk12mp1hj309c90mc7lkq1vvlqlr7vd6zmnpj"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("emms-print-metadata")
+ #:tests? #f ; No tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (install-file "src/emms-print-metadata"
+ (string-append out "/bin"))
+ (install-file "emms-print-metadata.1"
+ (string-append out "/share/man/man1"))
+ #t))))))
+ (inputs
+ `(("taglib" ,taglib)))
+ (home-page "https://www.gnu.org/software/emms/")
+ (synopsis "The Emacs Multimedia System")
+ (description
+ "EMMS is the Emacs Multimedia System. It is a small front-end which
+can control one of the supported external players. Thus, it supports
+whatever formats are supported by your music player. It also
+supports tagging and playlist management, all behind a clean and
+light user interface.")
+ (license license:gpl3+)))
+
+(define-public emacs-emms
+ (package
+ (inherit emacs-emms-print-metadata)
+ (name "emacs-emms")
(build-system emacs-build-system)
(arguments
`(#:phases
@@ -1504,6 +1535,7 @@ incrementally confined in Isearch manner.")
;; so that everything works out-of-the-box.
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ (emms-print-metadata (assoc-ref inputs "emms-print-metadata"))
(flac (assoc-ref inputs "flac"))
(vorbis (assoc-ref inputs "vorbis-tools"))
(alsa (assoc-ref inputs "alsa-utils"))
@@ -1528,7 +1560,7 @@ incrementally confined in Isearch manner.")
(string-append opus "/bin/opusinfo")))
(emacs-substitute-variables "emms-info-libtag.el"
("emms-info-libtag-program-name"
- (string-append out "/bin/emms-print-metadata")))
+ (string-append emms-print-metadata "/bin/emms-print-metadata")))
(emacs-substitute-variables "emms-info-mp3info.el"
("emms-info-mp3info-program-name"
(string-append mp3info "/bin/mp3info")))
@@ -1545,23 +1577,14 @@ incrementally confined in Isearch manner.")
(string-append "\"" mutagen "/bin/mid3v2\"")))
#t))))))
(inputs
- `(("alsa-utils" ,alsa-utils)
+ `(("emms-print-metadata" ,emacs-emms-print-metadata)
+ ("alsa-utils" ,alsa-utils)
("flac" ,flac) ;for metaflac
("vorbis-tools" ,vorbis-tools)
("mpg321" ,mpg321)
- ("taglib" ,taglib)
("mp3info" ,mp3info)
("mutagen" ,python-mutagen)
- ("opus-tools" ,opus-tools)))
- (home-page "https://www.gnu.org/software/emms/")
- (synopsis "The Emacs Multimedia System")
- (description
- "EMMS is the Emacs Multimedia System. It is a small front-end which
-can control one of the supported external players. Thus, it supports
-whatever formats are supported by your music player. It also
-supports tagging and playlist management, all behind a clean and
-light user interface.")
- (license license:gpl3+)))
+ ("opus-tools" ,opus-tools)))))
(define-public emacs-emms-mode-line-cycle
(package

base-commit: 327ebd55ca595aa3fac41139c906fbe05b5b6e0b
--
2.28.0
B
B
Brett Gilio wrote on 7 Aug 2020 05:38
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 42728@debbugs.gnu.org)
874kpfjfan.fsf@gnu.org
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (110 lines)
> * gnu/packages/emacs-xyz.scm (emacs-emms): Inherit from
> emacs-emms-print-metadata.
> [inputs]: Add emms-print-metadata.
> [arguments]: Fix path to emms-print-metadata.
> ---
> gnu/packages/emacs-xyz.scm | 53 +++++++++++++++++++++++++++-----------
> 1 file changed, 38 insertions(+), 15 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 9943af0fcb..5d353d0d57 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -1484,9 +1484,9 @@ incrementally confined in Isearch manner.")
> ;;; Multimedia.
> ;;;
>
> -(define-public emacs-emms
> +(define emacs-emms-print-metadata
> (package
> - (name "emacs-emms")
> + (name "emacs-emms-print-metadata")
> (version "5.42")
> (source
> (origin
> @@ -1495,6 +1495,37 @@ incrementally confined in Isearch manner.")
> "emms-" version ".tar"))
> (sha256
> (base32 "1khx1fvllrs6w9kxk12mp1hj309c90mc7lkq1vvlqlr7vd6zmnpj"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:make-flags '("emms-print-metadata")
> + #:tests? #f ; No tests.
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'configure)
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out")))
> + (install-file "src/emms-print-metadata"
> + (string-append out "/bin"))
> + (install-file "emms-print-metadata.1"
> + (string-append out "/share/man/man1"))
> + #t))))))
> + (inputs
> + `(("taglib" ,taglib)))
> + (home-page "https://www.gnu.org/software/emms/")
> + (synopsis "The Emacs Multimedia System")
> + (description
> + "EMMS is the Emacs Multimedia System. It is a small front-end which
> +can control one of the supported external players. Thus, it supports
> +whatever formats are supported by your music player. It also
> +supports tagging and playlist management, all behind a clean and
> +light user interface.")
> + (license license:gpl3+)))
> +
> +(define-public emacs-emms
> + (package
> + (inherit emacs-emms-print-metadata)
> + (name "emacs-emms")
> (build-system emacs-build-system)
> (arguments
> `(#:phases
> @@ -1504,6 +1535,7 @@ incrementally confined in Isearch manner.")
> ;; so that everything works out-of-the-box.
> (lambda* (#:key inputs outputs #:allow-other-keys)
> (let ((out (assoc-ref outputs "out"))
> + (emms-print-metadata (assoc-ref inputs "emms-print-metadata"))
> (flac (assoc-ref inputs "flac"))
> (vorbis (assoc-ref inputs "vorbis-tools"))
> (alsa (assoc-ref inputs "alsa-utils"))
> @@ -1528,7 +1560,7 @@ incrementally confined in Isearch manner.")
> (string-append opus "/bin/opusinfo")))
> (emacs-substitute-variables "emms-info-libtag.el"
> ("emms-info-libtag-program-name"
> - (string-append out "/bin/emms-print-metadata")))
> + (string-append emms-print-metadata "/bin/emms-print-metadata")))
> (emacs-substitute-variables "emms-info-mp3info.el"
> ("emms-info-mp3info-program-name"
> (string-append mp3info "/bin/mp3info")))
> @@ -1545,23 +1577,14 @@ incrementally confined in Isearch manner.")
> (string-append "\"" mutagen "/bin/mid3v2\"")))
> #t))))))
> (inputs
> - `(("alsa-utils" ,alsa-utils)
> + `(("emms-print-metadata" ,emacs-emms-print-metadata)
> + ("alsa-utils" ,alsa-utils)
> ("flac" ,flac) ;for metaflac
> ("vorbis-tools" ,vorbis-tools)
> ("mpg321" ,mpg321)
> - ("taglib" ,taglib)
> ("mp3info" ,mp3info)
> ("mutagen" ,python-mutagen)
> - ("opus-tools" ,opus-tools)))
> - (home-page "https://www.gnu.org/software/emms/")
> - (synopsis "The Emacs Multimedia System")
> - (description
> - "EMMS is the Emacs Multimedia System. It is a small front-end which
> -can control one of the supported external players. Thus, it supports
> -whatever formats are supported by your music player. It also
> -supports tagging and playlist management, all behind a clean and
> -light user interface.")
> - (license license:gpl3+)))
> + ("opus-tools" ,opus-tools)))))
>
> (define-public emacs-emms-mode-line-cycle
> (package
>
> base-commit: 327ebd55ca595aa3fac41139c906fbe05b5b6e0b


Maybe I am not completely understanding, but wouldn't it make more sense
for emms-print-metadata to inherit from emms and not the other way around?
P
P
Pierre Neidhardt wrote on 7 Aug 2020 08:10
(name . Brett Gilio)(address . brettg@gnu.org)(address . 42728@debbugs.gnu.org)
87r1sj0yx0.fsf@ambrevar.xyz
No, because the user wants to install emacs-emms, not
emacs-emms-print-metadata.
Note that the parent package is unexported. Does that make sense?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl8s8DsACgkQm9z0l6S7
zH8o7QgAng9gtjp7lZlmLgj848YoI2XcjaKf96WQdQohf/r0yD6000wdJ5Fm5UBO
E4nP4ayXTa9Ii8bi3Si9t/UxTC6JM2t2GBtlemRj671LE47xYzENHPRUBhJ5+SIH
VQp+GMeNtTT3xFRlFO7Z9v3hujaPtPYwTL9/uSIaEIp9qxFMo63kPZcLl7yD3MDY
a35dukU1tkq1MlIut6WYolygOaXAkXAaSNIdSEODGcvevbTXl3gpNGECFw4Z6bCJ
v3ZMx8o5RbJnrX8TbWpNwkJ8mEsb9Y5XHh6P7dLTB/T+9IBiTHVWUFTXRHlW5ywR
E0Vj2RmiEyAd8ZOT+GZc9xxOVX9TrQ==
=zhIa
-----END PGP SIGNATURE-----

B
B
Brett Gilio wrote on 7 Aug 2020 17:03
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 42728@debbugs.gnu.org)
87eeoiebw6.fsf@gnu.org
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (4 lines)
> No, because the user wants to install emacs-emms, not
> emacs-emms-print-metadata.
> Note that the parent package is unexported. Does that make sense?

Oh yes! My apologies. :)
P
P
Pierre Neidhardt wrote on 7 Aug 2020 18:29
(name . Brett Gilio)(address . brettg@gnu.org)(address . 42728@debbugs.gnu.org)
878seqpggl.fsf@ambrevar.xyz
Should I merge?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl8tgWoACgkQm9z0l6S7
zH/SlAf+PocM7KYrctLr4RhtiSK6fkHP/tu+AmThtQGRtANbb7+ZskwbPoZdIeYh
my+nGsri4iwNTI+ZsAQI5ZETaYVUHxGs5/pObRXivLBTaqbbKn1srz6Cdy2OTGGd
qrG4UtKtnOo9YRf+xarlaTkmLk1eWXqEJ2bU5kk0mjOSTEOh34JfXfIABsJKA14w
fHX7DehKUbbFXBvox4n+ocFBVkoPfh2/M9tvEbDnrFmg1qZ0OG9bBCVbO0APUSe8
PkabovTEhmG7M18RNNPcNqyfH95rwN2m1kMZpjOe6dNgW3+bfApsM0tYOXhLbONd
4Ozu2JCWcaGzxNWaL2ERUwasMUrlPA==
=dqaN
-----END PGP SIGNATURE-----

B
B
Brett Gilio wrote on 7 Aug 2020 20:11
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 42728@debbugs.gnu.org)
87d0425ns7.fsf@gnu.org
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (2 lines)
> Should I merge?

LGTM!
P
P
Pierre Neidhardt wrote on 8 Aug 2020 10:42
(name . Brett Gilio)(address . brettg@gnu.org)(address . 42728@debbugs.gnu.org)
87r1sho7ej.fsf@ambrevar.xyz
Merged as 4aa2b6d0cd707b060284584d7fb65adf15790119.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl8uZYQACgkQm9z0l6S7
zH9WpAgAhqi0eYXbKxUGq62tI/p4dr1FKSKPBCRC1zYq4Ggkchbo7+HpUB9HnkTw
IlJKggII9xOp3v6g8zHxEfInQk9ds8crs0QAZ3cuCtVOm0GMpOepFwWa8wnoSlAW
eVgY5MJixMEC2xDfv7+96wTX4737vfMh14iLGRkbbpfERtOsVMX2B9Y0T3G6qQ2B
+9VGJ15DwWPEDDZenZy5EypBmwW0l8AzO6qhhHjLpuLGsfCRgeVHsRDEzjzItZJ7
x6ue009TYoV0Mh8TG1mqZA3Gzz3NX7RHHLnRoF9R/+3thG8tRuqYu1xCO33A9722
ygCzcYOcfsPCTtowblNmoi2HPM+vVw==
=EwCt
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 8 Aug 2020 10:42
control message for bug #42728
(address . control@debbugs.gnu.org)
87pn81o7e4.fsf@ambrevar.xyz
close 42728
quit
?