[PATCH 1/3] gnu: Add python-immutables.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 5 Aug 2020 17:33
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200805153317.9394-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-immutables): New variable.
---
This is a dependency for python-contextvars, which is a dependency for
python-curio. Contextvars is part of standard Python 3.7+ and uses this
implementation. Immutables still lives as a separate package.

Sending anyway in case it's useful somewhere else.

gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ab0b12383..28499411a7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8551,6 +8551,25 @@ Unicode-aware. It is not intended as an end-user tool.")
(define-public python2-xlrd
(package-with-python2 python-xlrd))
+(define-public python-immutables
+ (package
+ (name "python-immutables")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "immutables" version))
+ (sha256
+ (base32 "0y0aqw29g525frdnmv9paljzacpp4s21sadfbca5b137iciwr8d0"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/MagicStack/immutables")
+ (synopsis "High-performance immutable mapping type for Python")
+ (description
+ "An immutable mapping type for Python. The underlying datastructure is a
+Hash Array Mapped Trie (HAMT) used in Clojure, Scala, Haskell, and other
+functional languages.")
+ (license license:asl2.0)))
+
(define-public python-prettytable
(package
(name "python-prettytable")
--
2.20.1
V
V
Vinicius Monego wrote on 5 Aug 2020 17:33
[PATCH 2/3] gnu: Add python-curio.
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200805153317.9394-2-monego@posteo.net
* gnu/packages/python-xyz.scm (python-curio): New variable.
---
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 28499411a7..22a2176c4a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8594,6 +8594,36 @@ printing of sub-tables by specifying a row range.")
(define-public python2-prettytable
(package-with-python2 python-prettytable))
+(define-public python-curio
+ (package
+ (name "python-curio")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "curio" version))
+ (sha256
+ (base32 "16wkww6kh511b9bzsfhpvrv0766cc6ssgbzz4lgpjnrzzgx21wwh"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "-k"
+ ;; Tries to open an outgoing connection.
+ "not test_ssl_outgoing"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/dabeaz/curio")
+ (synopsis "Coroutine-based library for concurrent Python")
+ (description
+ "Curio is a coroutine-based library for concurrent Python systems
+programming. It provides standard programming abstractions such as as
+tasks, sockets, files, locks, and queues.")
+ (license license:bsd-3)))
+
(define-public python-tables
(package
(name "python-tables")
--
2.20.1
V
V
Vinicius Monego wrote on 5 Aug 2020 17:33
[PATCH 3/3] gnu: Add python-sniffio.
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200805153317.9394-3-monego@posteo.net
* gnu/packages/python-xyz.scm (python-sniffio): New variable.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 22a2176c4a..e4a83a2f37 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8696,6 +8696,35 @@ designed to efficiently cope with extremely large amounts of data.")
(define-public python2-tables
(package-with-python2 python-tables))
+(define-public python-sniffio
+ (package
+ (name "python-sniffio")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sniffio" version))
+ (sha256
+ (base32 "08bsp2pp2dxzn9yzcafwzw8jlm0jf50as0ix8vfhxzk91w810f4f"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-curio" ,python-curio)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://github.com/python-trio/sniffio")
+ (synopsis "Sniff out which async library your code is running under")
+ (description
+ "This is a tiny package whose only purpose is to let you detect which async
+library your code is running under.")
+ ;; Either license applies.
+ (license (list license:expat license:asl2.0))))
+
(define-public python-pytest-black
(package
(name "python-pytest-black")
--
2.20.1
M
M
Mathieu Othacehe wrote on 6 Aug 2020 16:21
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42721-done@debbugs.gnu.org)
87ft8zua6p.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-sniffio): New variable.

Pushed the whole serie, with a description edit for python-sniffio.

Thanks,

Mathieu
Closed
?