[PATCH 3/3] gnu: Add python-h2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 5 Aug 2020 17:12
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200805151256.7769-3-monego@posteo.net
* gnu/packages/python-web.scm (python-h2): New variable.
---
gnu/packages/python-web.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 857a0e755c..f9c8157f0d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -527,6 +527,39 @@ into HTTP/2 frames.")
for use in Python programs that implement HTTP/2.")
(license license:expat)))
+(define-public python-h2
+ (package
+ (name "python-h2")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "h2" version))
+ (sha256
+ (base32 "051gg30aca26rdxsmr9svwqm06pdz9bv21ch4n0lgi7jsvml2pw7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "test"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-hpack" ,python-hpack)
+ ("python-hyperframe" ,python-hyperframe)))
+ (home-page "https://github.com/python-hyper/hyper-h2")
+ (synopsis "HTTP/2 State-Machine based protocol implementation")
+ (description
+ "This module contains a pure-Python implementation of a HTTP/2 protocol
+stack. It does not provide a parsing layer, a network layer, or any rules
+about concurrency. Instead, it's a purely in-memory solution, defined in
+terms of data actions and HTTP/2 frames. This is one building block of a full
+Python HTTP implementation.")
+ (license license:expat)))
+
(define-public python-sockjs-tornado
(package
(name "python-sockjs-tornado")
--
2.20.1
M
M
Mathieu Othacehe wrote on 6 Aug 2020 16:03
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42718-done@debbugs.gnu.org)
87o8nnub1b.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-h2): New variable.

Pushed, thanks!

Mathieu
Closed
?