[PATCH 1/3] gnu: Add python-hyperframe.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 5 Aug 2020 17:12
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200805151256.7769-1-monego@posteo.net
* gnu/packages/python-web.scm (python-hyperframe): New variable.
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0bdea1b86d..a9f63bcf28 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2020 Holger Peters <holger.peters@posteo.de>
;;; Copyright © 2020 Noisytoot <noisytoot@gmail.com>
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -464,6 +465,34 @@ follow links and submit forms. It doesn’t do JavaScript.")
(define-public python2-mechanicalsoup
(package-with-python2 python-mechanicalsoup))
+(define-public python-hyperframe
+ (package
+ (name "python-hyperframe")
+ (version "5.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hyperframe" version))
+ (sha256
+ (base32 "07xlf44l1cw0ghxx46sbmkgzil8vqv8kxwy42ywikiy35izw3xd9"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "test"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/python-hyper/hyperframe")
+ (synopsis "HTTP/2 framing layer for Python")
+ (description
+ "This library contains the HTTP/2 framing code used in the hyper project.
+It provides a pure-Python codebase that is capable of decoding a binary stream
+into HTTP/2 frames.")
+ (license license:expat)))
+
(define-public python-sockjs-tornado
(package
(name "python-sockjs-tornado")
--
2.20.1
M
M
Mathieu Othacehe wrote on 6 Aug 2020 16:02
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42717-done@debbugs.gnu.org)
87v9hvub32.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-hyperframe): New variable.

Pushed, thanks!

Mathieu
Closed
?