[PATCH] gnu: Add confclerk.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 3 Aug 2020 14:58
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20200803125808.19605-1-efraim@flashner.co.il
* gnu/packages/calendar.scm (confclerk): New variable.
---
gnu/packages/calendar.scm | 59 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 58 insertions(+), 1 deletion(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 53c73c969d..9987ae1bf8 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -46,6 +46,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages time)
@@ -282,3 +283,59 @@ of day, written in C, and including bindings for C++, pascal, perl, php, python,
and ruby. It includes two illustrative command-line programs, @code{hcal} and
@code{hdate}, and some snippets and scripts written in the binding languages.")
(license license:gpl3+)))
+
+(define-public confclerk
+ (package
+ (name "confclerk")
+ (version "0.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.toastfreeware.priv.at/tarballs/"
+ "confclerk/confclerk-" version ".tar.gz"))
+ (sha256
+ (base32
+ "10rhg44px4nvbkd3p341cmp2ds43jn8r4rvgladda9v8zmsgr2b3"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Install directory is currently hard-coded.
+ (substitute* "src/app/app.pro"
+ (("PREFIX = /usr/bin")
+ (string-append "PREFIX =" out "/bin")))
+ (invoke "qmake"))))
+ (add-after 'install 'install-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share")))
+ (install-file "data/confclerk.1"
+ (string-append share "/man/man1"))
+ (install-file "data/confclerk.desktop"
+ (string-append share "/applications"))
+ (install-file "data/confclerk.svg"
+ (string-append share "/icons/hicolor/scalable/apps"))
+ #t))))
+ #:tests? #f)) ; no tests
+ (native-inputs
+ `(("perl" ,perl))) ; pod2man
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (home-page "https://www.toastfreeware.priv.at/confclerk")
+ (synopsis "Offline conference schedule application")
+ (description
+ "ConfClerk is an application written in Qt, which makes conference schedules
+available offline. It displays the conference schedule from various views,
+support searches on various items (speaker, speech topic, location, etc.) and
+enables you to select favorite events and create your own schedule.
+
+At the moment ConfClerk is able to import schedules in XML format created by
+the PentaBarf conference management system (or frab) used by e.g. FOSDEM,
+DebConf, FrOSCon, Grazer LinuxTage, and the CCC congresses.
+
+ConfClerk is targeted at mobile devices but works on any system running Qt.")
+ (license (list license:gpl2+
+ license:lgpl3)))) ; or cc-by3.0 for src/icons/*
--
2.28.0
M
M
Mathieu Othacehe wrote on 5 Aug 2020 11:48
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 42697@debbugs.gnu.org)
874kphjudg.fsf@gnu.org
Hello Efraim,

Toggle quote (2 lines)
> * gnu/packages/calendar.scm (confclerk): New variable.

This looks good to me!

Thanks,

Mathieu
E
E
Efraim Flashner wrote on 5 Aug 2020 12:11
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 42697-done@debbugs.gnu.org)
20200805101142.GB2042@E5400
On Wed, Aug 05, 2020 at 11:48:43AM +0200, Mathieu Othacehe wrote:
Toggle quote (11 lines)
>
> Hello Efraim,
>
> > * gnu/packages/calendar.scm (confclerk): New variable.
>
> This looks good to me!
>
> Thanks,
>
> Mathieu

Thanks! Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8qhd4ACgkQQarn3Mo9
g1HAhg//VDXG9r1Aa67m6XDfrN8xnEuG7+8mT0uyQQa5BsR0Q2lty6UCOaPVa5Eb
pkr368muiEMTAru0X1PnieitOrBfGMOkLs1HQhi1Ak0+TYekY+dl20mGzpjEo8IE
LCY2dt78OnGscHT+dvNCpwdQCG4w7RHJQgf6H25jXcl2qHaWxrQ8fieucooeTXeR
DvRjyBmmiZTTYUgbfhefHruHBGl8lzMJixjWG2R1dH0u63APolIVKfvcJjOqIB5h
Hm7imFUoXk7jdab8tZqj+WtU9xVqjaGPciqfEjxlFNoBeLPGakykccCPdq9KOPLL
axOZKbbgkGXNI6gMExhVjpLAeKPzcZY7M9KOqJN9UpMIqS7o6E1aoiZzrncdeLXZ
ztGVvIu8dN7i0f+c9COlTR/HRWoAVkebl1ev01wDRqiFCJbzUS619zNmc6mvpkhI
beTh/sdbg9JkbWgmLMG1PJw6C6EeYXL7IYy0GMd8WjIGUXu2gseU+wx5L+TrwBTO
8fIeTi0l2uSL4yH3SB+xEqd3/zlQUsUpHTp+Uu2MXYrl1LgTmzhgWQvT2hBojgIv
mLaBrAOC50DLb82YjWj5GwP1QiS9dfUw8T15yEPg0TEUHNoUL1udQJBdilnPfLJR
AKLgBm6lCgS+7Lh64TyN7Ftqf4bkkpygzAdXF3/8yHU8w3GBN6M=
=NB+5
-----END PGP SIGNATURE-----


Closed
?