add sbcl-cl-lambda-fiddle

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Guillaume Le Vaillant
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 3 Aug 2020 09:30
(name . Guix Patches)(address . guix-patches@gnu.org)
MDnDita--3-2@tuta.io
(define-public sbcl-cl-lambda-fiddle
  (let ((commit "d16bba55acf6065b412f64ab8fdff679a4a32b1e")
(revision "1"))
    (package
      (name "sbcl-lambda-fiddle")
      (version (git-version "0.0.0" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://github.com/Shinmera/lambda-fiddle")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32 "1zarj1pqjqmk95kdx1axkgpwy2wq3canczk7f9z5hvaw5an6gand"))))
      (build-system asdf-build-system/sbcl)
      (synopsis "Lambda-fiddle is a collection of utilities to process lambda-lists.")
      (description "Lambda-fiddle is a collection of utilities to process lambda-lists.
Mostly useful in contexts where you want a macro that uses lambda-lists in some fashion but need more precise processing.")
      (license license:zlib))))
B
B
Brett Gilio wrote on 4 Aug 2020 06:21
(name . Adam Kandur)(address . rndd@tuta.io)(address . 42690@debbugs.gnu.org)
87d047avnu.fsf@gnu.org
Adam Kandur <rndd@tuta.io> writes:

Toggle quote (22 lines)
> (define-public sbcl-cl-lambda-fiddle
>   (let ((commit "d16bba55acf6065b412f64ab8fdff679a4a32b1e")
> (revision "1"))
>     (package
>       (name "sbcl-lambda-fiddle")
>       (version (git-version "0.0.0" revision commit))
>       (source
>        (origin
>          (method git-fetch)
>          (uri (git-reference
>                (url "https://github.com/Shinmera/lambda-fiddle")
>                (commit commit)))
>          (file-name (git-file-name name version))
>          (sha256
>           (base32 "1zarj1pqjqmk95kdx1axkgpwy2wq3canczk7f9z5hvaw5an6gand"))))
>       (build-system asdf-build-system/sbcl)
>       (home-page "https://github.com/Shinmera/lambda-fiddle")
>       (synopsis "Lambda-fiddle is a collection of utilities to process lambda-lists.")
>       (description "Lambda-fiddle is a collection of utilities to process lambda-lists.
> Mostly useful in contexts where you want a macro that uses lambda-lists in some fashion but need more precise processing.")
>       (license license:zlib))))

Hi Adam,

Thank you for your submission. A few issues before we can proceed.

1. You have what I believe is a naming error (the cl in the name
probably should not be there, as we have a different purpose for cl-*
named packages).

2. The synopsis should not include the package name, and should not be
too close to the package description. See our packaging guidelines:

3. Guix accepts pcontributions in the form of git patches, which give us
the extra metadata to be able to easily apply your contribution to our
git tree (and ensure you get the proper credit for your work!). Also
taking care to add yourself to the copyright header if not already
there. Please see our documentation on submitting git patches:

Once we get these in order, we can merge your work!

Thanks,

Brett Gilio
G
G
Guillaume Le Vaillant wrote on 7 Oct 2020 11:38
Re: [bug#43718] [PATCH] gnu: Add sbcl-lambda-fiddle
(name . Adam Kandur)(address . rndd@tuta.io)
87k0w2pe8t.fsf@yamatai
Pushed as 582d0108d6e3e225dab810e6c0c03f8a4ca33e1c with a few edits.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCX32Mog8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+hfwD/Whoq2eHwzHc7jSnZiNapvwEpBLScW4Hwo66j
eLCsCGMBAIzuzh9mMr0mI8wAYaXXYM5bJ14GwDt1dc5QaUiIrgHn
=Pk6m
-----END PGP SIGNATURE-----

Closed
?