add sbcl-cl-livesupport

  • Done
  • quality assurance status badge
Details
4 participants
  • Brett Gilio
  • Alexandru-Sergiu Marton
  • Leo Famulari
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 3 Aug 2020 09:30
(name . Guix Patches)(address . guix-patches@gnu.org)
MDnD_6x--3-2@tuta.io
(define-public sbcl-cl-livesupport
  (let ((commit "71e6e412df9f3759ad8378fabb203913d82e228a")
(revision "1"))
    (package
      (name "sbcl-livesupport")
      (version (git-version "0.0.0" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://github.com/cbaggers/livesupport")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32 "1rvnl0mncylbx63608pz5llss7y92j7z3ydambk9mcnjg2mjaapg"))))
      (build-system asdf-build-system/sbcl)
      (synopsis "Some helpers that make livecoding at little easier")
      (description "A macro commonly used in livecoding to enable continuing when errors are raised. Simply wrap around a chunk of code and it provides a restart called 'continue' which ignores the error and carrys on from the end of the body. I usually wrap this around the code 'step' function in my main loop.")
      (license license:bsd-2))))
B
B
Brett Gilio wrote on 4 Aug 2020 06:22
(name . Adam Kandur)(address . rndd@tuta.io)(address . 42689@debbugs.gnu.org)
87a6zbavmf.fsf@gnu.org
Adam Kandur <rndd@tuta.io> writes:
Toggle quote (24 lines)
> (define-public sbcl-cl-livesupport
>   (let ((commit "71e6e412df9f3759ad8378fabb203913d82e228a")
> (revision "1"))
>     (package
>       (name "sbcl-livesupport")
>       (version (git-version "0.0.0" revision commit))
>       (source
>        (origin
>          (method git-fetch)
>          (uri (git-reference
>                (url "https://github.com/cbaggers/livesupport")
>                (commit commit)))
>          (file-name (git-file-name name version))
>          (sha256
>           (base32 "1rvnl0mncylbx63608pz5llss7y92j7z3ydambk9mcnjg2mjaapg"))))
>       (build-system asdf-build-system/sbcl)
>       (home-page "https://github.com/cbaggers/livesupport")
>       (synopsis "Some helpers that make livecoding at little easier")
>       (description "A macro commonly used in livecoding to enable
> continuing when errors are raised. Simply wrap around a chunk of code
> and it provides a restart called 'continue' which ignores the error
> and carrys on from the end of the body. I usually wrap this around the
> code 'step' function in my main loop.")
>       (license license:bsd-2))))
Hi again, Adam!
Same situation here, as per my last email :).
B
B
Brett Gilio wrote on 4 Aug 2020 19:28
877dueuxqk.fsf@gnu.org
Adam Kandur <rndd@tuta.io> writes:

Toggle quote (9 lines)
> like this ?
>
> From 5cade1fff3fb64892321505edd9ac1b13420782e Mon Sep 17 00:00:00 2001
> From: Adam Kandur <rndd@tuta.io>
> Date: Tue, 4 Aug 2020 17:40:50 +0300
> Subject: [PATCH] add sbcl-livesupport in gnu/packages/lisp-xyz.scm
>


This is closer, however the commit message and subheader do not conform
to our standards. We use the changelog format for our commit messages
and headers. This can be automated using our snippets with yasnippet if
you are an emacs user. Let me know if you need more help. Also, be sure
to reply to all when interacting with our bug reports. This email is
considered "off list" as you sent it to me only, and thus nobody else
will be able to see your last message :).

Brett Gilio
B
B
Brett Gilio wrote on 4 Aug 2020 20:09
871rkmth9f.fsf@gnu.org
Adam Kandur <rndd@tuta.io> writes:

Toggle quote (28 lines)
> ok, could you give me more information about this format and where i can view some accepted patches?
>
>
>
> Aug 4, 2020, 17:28 by brettg@gnu.org:
>
>> Adam Kandur <rndd@tuta.io> writes:
>>
>>> like this ?
>>>
>>> From 5cade1fff3fb64892321505edd9ac1b13420782e Mon Sep 17 00:00:00 2001
>>> From: Adam Kandur <rndd@tuta.io>
>>> Date: Tue, 4 Aug 2020 17:40:50 +0300
>>> Subject: [PATCH] add sbcl-livesupport in gnu/packages/lisp-xyz.scm
>>>
>>
>>
>> This is closer, however the commit message and subheader do not conform
>> to our standards. We use the changelog format for our commit messages
>> and headers. This can be automated using our snippets with yasnippet if
>> you are an emacs user. Let me know if you need more help. Also, be sure
>> to reply to all when interacting with our bug reports. This email is
>> considered "off list" as you sent it to me only, and thus nobody else
>> will be able to see your last message :).
>>
>> Brett Gilio
>>

Hi again, Adam.

I don't think you are replying to all when you respond. This is
important so that everybody subscribed to the list can see our
interactions! :)

If you use emacs, use yasnippet and our snippets for adding and updating
packages are in ./etc/snippets. You can configure yasnippet to load
these whenever you interact with

For some examples of guix patches that have been accepted and committed,
check the git log either from magit (M-x magit-log), or from

Thanks!

Brett Gilio
A
A
Adam Kandur wrote on 4 Aug 2020 20:54
another try
(address . 42689@debbugs.gnu.org)
MDuoswS--3-2@tuta.io
From 5cade1fff3fb64892321505edd9ac1b13420782e Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Tue, 4 Aug 2020 17:40:50 +0300
Subject: [PATCH] add sbcl-livesupport in gnu/packages/lisp-xyz.scm

---
 gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 767f50c104..fb2b664f26 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13395,3 +13395,32 @@ and decoder for Common Lisp.")
 
 (define-public ecl-qbase64
   (sbcl-package->ecl-package sbcl-qbase64))
+
+(define-public sbcl-livesupport
+  (let ((commit "71e6e412df9f3759ad8378fabb203913d82e228a")
+    (revision "1"))
+    (package
+      (name "sbcl-livesupport")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/cbaggers/livesupport")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1rvnl0mncylbx63608pz5llss7y92j7z3ydambk9mcnjg2mjaapg"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/cbaggers/livesupport")
+      (synopsis "Some helpers that make livecoding at little easier")
+      (description "A macro commonly used in livecoding to enable continuing when errors are raised.
+Simply wrap around a chunk of code and it provides a restart called 'continue' which ignores the error and carrys on from the end of the body.
+I usually wrap this around the code 'step' function in my main loop.")
+      (license license:bsd-2))))
+
+(define-public cl-livesupport
+  (sbcl-package->cl-source-package sbcl-livesupport))
+
+(define-public ecl-livesupport
+  (sbcl-package->ecl-package sbcl-livesupport))
--
2.28.0
B
B
Brett Gilio wrote on 5 Aug 2020 03:38
(name . Adam Kandur)(address . rndd@tuta.io)(address . 42689@debbugs.gnu.org)
873651swhv.fsf@gnu.org
Adam Kandur <rndd@tuta.io> writes:

Toggle quote (10 lines)
>>From 5cade1fff3fb64892321505edd9ac1b13420782e Mon Sep 17 00:00:00 2001
> From: Adam Kandur <rndd@tuta.io>
> Date: Tue, 4 Aug 2020 17:40:50 +0300
> Subject: [PATCH] add sbcl-livesupport in gnu/packages/lisp-xyz.scm
>
> ---
>  gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)
>

Hi Adam,

I am sorry to be a pest, but the commit message is still not following
our snippet protocol. I was trying to apply your patch, and take care of
it for you so that you could see what our expectation is more clearly
but your patch is mangled.

Could you walk me through, step by step, how you are creating, and then
sending the patch? That will help us immensely, in both getting you in
the right direction for future contributions (if you so choose), and in
seeing if there is something we need to do differently. :)

Thanks!
Brett Gilio
A
A
Alexandru-Sergiu Marton wrote on 5 Aug 2020 07:28
(name . Brett Gilio)(address . brettg@gnu.org)
87mu39ek54.fsf@posteo.ro
Hello Adam and Brett,

Brett Gilio <brettg@gnu.org> writes:

Toggle quote (19 lines)
> Adam Kandur <rndd@tuta.io> writes:
>
>>>>From 5cade1fff3fb64892321505edd9ac1b13420782e Mon Sep 17 00:00:00 2001
>> From: Adam Kandur <rndd@tuta.io>
>> Date: Tue, 4 Aug 2020 17:40:50 +0300
>> Subject: [PATCH] add sbcl-livesupport in gnu/packages/lisp-xyz.scm
>>
>> ---
>>  gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
>>  1 file changed, 29 insertions(+)
>>
>
> Hi Adam,
>
> I am sorry to be a pest, but the commit message is still not following
> our snippet protocol. I was trying to apply your patch, and take care of
> it for you so that you could see what our expectation is more clearly
> but your patch is mangled.

Adam, I'm a fellow contributor, like you, and I'd like to share some of
what I learned when sending patches to Guix.

Brett says that your patch is mangled -- that usually happens at
sending, depending on your email client. If you create your patches with
`git format-patch`, I wouldn't trust an email client to keep the text
intact by just pasting in the body of the mail. I would, instead, attach
the patch file.

You could, instead of manually putting the patch in a mail yourself,
send it with `git send-email`. There is a great guide regarding how to
do this: https://git-send-email.io/. This is what I use to send patches
to GNU Guix.

As for the commit message itself, besides the snippet solution Brett
suggested (maybe you're not using Emacs), there's always grepping the
git log. I run `git log` in the guix source directory and search (using
the '/' key) for whatever my patch does: if I'm adding a package, I
search for "Add", for example.

Here's what a commit that adds a new package usually looks like:

Toggle snippet (6 lines)
commit 28cbf3ef42353a491028d405a66595d45f3c8998
gnu: Add python-pgpy.

* gnu/packages/python-crypto.scm (python-pgpy): New variable.

Most of the time when adding a new package you follow this
template. Replace the package name and file with whatever you have and
you should be all set. (The "commit 28..." is just to show you what
commit is this taken from. You must care only about what follows after it.)

To format the commit message nicely, I recommend that you don't use the
-m/--message flag, but let git open your $EDITOR so you can easily write
multiple lines, like in the example above.

If you want to change the message of your last commit, you can use git
commit --amend.

If you want to read more about the ChangeLog format, I believe this is
the right place to look:
I never read that, but I always looks through the git log to see how
others formatted messages for similar commits before.

Cheers,
Sergiu
A
A
Adam Kandur wrote on 5 Aug 2020 09:17
[PATCH] gnu: Add sbcl-livesupport
(name . 42689)(address . 42689@debbugs.gnu.org)
MDxTobs--3-2@tuta.io
so, when i want to make a patch:
1) i "cd ~/path/to/guix"
2) make changes
3) git add gnu/packages/file_i_changed.scm (gnu/packages/lisp-xyz.scm for example)
4) git commit -m 'gnu: Add sbcl-livesupport'
5) git format-patch origin/master
6) for this one i attached file 0001-gnu-Add-sbcl-livesupport.patch

P.S.: my bad but i don't know how to use email with git. if anyone used tutanota.com please note how to do it
From bb0cdfbbe60c782603abb5136e8da61685925920 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 5 Aug 2020 10:11:09 +0300
Subject: [PATCH] gnu: Add sbcl-livesupport

---
gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 767f50c104..74f1adee5b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13395,3 +13395,31 @@ and decoder for Common Lisp.")
(define-public ecl-qbase64
(sbcl-package->ecl-package sbcl-qbase64))
+
+(define-public sbcl-livesupport
+ (let ((commit "71e6e412df9f3759ad8378fabb203913d82e228a")
+ (revision "1"))
+ (package
+ (name "sbcl-livesupport")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cbaggers/livesupport")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rvnl0mncylbx63608pz5llss7y92j7z3ydambk9mcnjg2mjaapg"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/cbaggers/livesupport")
+ (synopsis "Some helpers that make livecoding at little easier")
+ (description "A macro commonly used in livecoding to enable continuing when errors are raised.
+Simply wrap around a chunk of code and it provides a restart called 'continue' which ignores the error and carrys on from the end of the body.")
+ (license license:bsd-2))))
+
+(define-public cl-livesupport
+ (sbcl-package->cl-source-package sbcl-livesupport))
+
+(define-public ecl-livesupport
+ (sbcl-package->ecl-package sbcl-livesupport))
--
2.28.0
A
A
Adam Kandur wrote on 11 Aug 2020 22:23
(name . 42689)(address . 42689@debbugs.gnu.org)
MEUBCk1--3-2@tuta.io

From 8e799d99710ddd851419e75199b5e6a05db6d6bb Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Tue, 11 Aug 2020 23:15:53 +0300
Subject: [PATCH] gnu: Add sbcl-livesupport.

* gnu/packages/lisp-xyz.scm (sbcl-livesupport): New variable.
---
gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b8216b0..0df1d26 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13509,3 +13509,31 @@ for an example.")
(define-public ecl-hu.dwim.defclass-star
(sbcl-package->ecl-package sbcl-hu.dwim.defclass-star))
+
+(define-public sbcl-livesupport
+ (let ((commit "71e6e412df9f3759ad8378fabb203913d82e228a")
+ (revision "1"))
+ (package
+ (name "sbcl-livesupport")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cbaggers/livesupport")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rvnl0mncylbx63608pz5llss7y92j7z3ydambk9mcnjg2mjaapg"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/cbaggers/livesupport")
+ (synopsis "Some helpers that make livecoding at little easier")
+ (description "A macro commonly used in livecoding to enable continuing when errors are raised.
+Simply wrap around a chunk of code and it provides a restart called 'continue' which ignores the error and carrys on from the end of the body.")
+ (license license:bsd-2))))
+
+(define-public cl-livesupport
+ (sbcl-package->cl-livesupport sbcl-livesupport))
+
+(define-public ecl-livesupport
+ (sbcl-package->ecl-livesupport sbcl-livesupport))
--
2.28.0
A
A
Adam Kandur wrote on 12 Aug 2020 08:55
(name . 42689)(address . 42689@debbugs.gnu.org)
MEWRyCb--3-2@tuta.io

From 1aeb04ad466937b50acd1a2540e50f59446b6d8c Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 12 Aug 2020 09:52:05 +0300
Subject: [PATCH] gnu: Add sbcl-livesupport.

* gnu/packages/lisp-xyz.scm (sbcl-livesupport): New variable.
---
gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b8216b0..f5a0ab7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13509,3 +13509,31 @@ for an example.")
(define-public ecl-hu.dwim.defclass-star
(sbcl-package->ecl-package sbcl-hu.dwim.defclass-star))
+
+(define-public sbcl-livesupport
+ (let ((commit "71e6e412df9f3759ad8378fabb203913d82e228a")
+ (revision "1"))
+ (package
+ (name "sbcl-livesupport")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cbaggers/livesupport")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rvnl0mncylbx63608pz5llss7y92j7z3ydambk9mcnjg2mjaapg"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/cbaggers/livesupport")
+ (synopsis "Some helpers that make livecoding at little easier")
+ (description "A macro commonly used in livecoding to enable continuing when errors are raised.
+Simply wrap around a chunk of code and it provides a restart called 'continue' which ignores the error and carrys on from the end of the body.")
+ (license license:bsd-2))))
+
+(define-public cl-livesupport
+ (sbcl-package->cl-source-package sbcl-livesupport))
+
+(define-public ecl-livesupport
+ (sbcl-package->ecl-package sbcl-livesupport))
--
2.28.0
L
L
Leo Famulari wrote on 22 Aug 2020 20:23
(name . Adam Kandur via Guix-patches via)(address . guix-patches@gnu.org)(name . 42689)(address . 42689-done@debbugs.gnu.org)
20200822182321.GB18524@jasmine.lan
Toggle quote (7 lines)
> From 1aeb04ad466937b50acd1a2540e50f59446b6d8c Mon Sep 17 00:00:00 2001
> From: Adam Kandur <rndd@tuta.io>
> Date: Wed, 12 Aug 2020 09:52:05 +0300
> Subject: [PATCH] gnu: Add sbcl-livesupport.
>
> * gnu/packages/lisp-xyz.scm (sbcl-livesupport): New variable.

Thanks! I added the other new variables to the commit message...

Toggle quote (3 lines)
> + (description "A macro commonly used in livecoding to enable continuing when errors are raised.
> +Simply wrap around a chunk of code and it provides a restart called 'continue' which ignores the error and carrys on from the end of the body.")

And fixed some issues reported by `guix lint` in the description.

Pushed as ca7eada91819c7cd5a78e144d285cd972a478a0c
?