[PATCH core-updates] gnu: bootstrap-gcc: Don't use CPATH search paths.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Jakub K?dzio?ka
Owner
unassigned
Submitted by
Jakub K?dzio?ka
Severity
normal
J
J
Jakub K?dzio?ka wrote on 2 Aug 2020 22:34
(address . guix-patches@gnu.org)(address . efraim@flashner.co.il)
20200802203421.5959-1-kuba@kadziolka.net
This updates the bootstrap-gcc to use the same search path strategy as
the main compilers, making the bootstrap environment more similar across
architectures, and fixing the bootstrap path on non-x86 architectures
again.

This is a follow up to commit 7cde865f12dd67e55946a52a21103e71f447eced.

* gnu/packages/bootstrap.scm (%bootstrap-gcc)[native-search-paths]: Use
C_INCLUDE_PATH and CPLUS_INCLUDE_PATH instead of CPATH.
---

Note: because I don't have any non-x86 machines on hand, I haven't
actually tested the patch yet.

Efraim, you have helped me investigate this with your ARM board, perhaps
you could test this patch?

Regards,
Jakub K?dzio?ka
gnu/packages/bootstrap.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index c39e60ec8b..fd6c2e099c 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -740,8 +740,11 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
"1m5miqkyng45l745n0sfafdpjkqv9225xf44jqkygwsipj2cv9ks")))))))))
(native-search-paths
(list (search-path-specification
- (variable "CPATH")
+ (variable "C_INCLUDE_PATH")
(files '("include")))
+ (search-path-specification
+ (variable "CPLUS_INCLUDE_PATH")
+ (files '("include/c++" "include")))
(search-path-specification
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
--
2.28.0
E
E
Efraim Flashner wrote on 3 Aug 2020 08:40
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)(address . guix-patches@gnu.org)
20200803064026.GF1134@E5400
On Sun, Aug 02, 2020 at 10:34:21PM +0200, Jakub K?dzio?ka wrote:
Toggle quote (43 lines)
> This updates the bootstrap-gcc to use the same search path strategy as
> the main compilers, making the bootstrap environment more similar across
> architectures, and fixing the bootstrap path on non-x86 architectures
> again.
>
> This is a follow up to commit 7cde865f12dd67e55946a52a21103e71f447eced.
>
> * gnu/packages/bootstrap.scm (%bootstrap-gcc)[native-search-paths]: Use
> C_INCLUDE_PATH and CPLUS_INCLUDE_PATH instead of CPATH.
> ---
>
> Note: because I don't have any non-x86 machines on hand, I haven't
> actually tested the patch yet.
>
> Efraim, you have helped me investigate this with your ARM board, perhaps
> you could test this patch?
>
> Regards,
> Jakub K?dzio?ka
> gnu/packages/bootstrap.scm | 5 ++++-
> 1 file changed, 4 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
> index c39e60ec8b..fd6c2e099c 100644
> --- a/gnu/packages/bootstrap.scm
> +++ b/gnu/packages/bootstrap.scm
> @@ -740,8 +740,11 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
> "1m5miqkyng45l745n0sfafdpjkqv9225xf44jqkygwsipj2cv9ks")))))))))
> (native-search-paths
> (list (search-path-specification
> - (variable "CPATH")
> + (variable "C_INCLUDE_PATH")
> (files '("include")))
> + (search-path-specification
> + (variable "CPLUS_INCLUDE_PATH")
> + (files '("include/c++" "include")))
> (search-path-specification
> (variable "LIBRARY_PATH")
> (files '("lib" "lib64")))))
> --
> 2.28.0
>

I'm building out to hello on my aarch64 board now, starting from
make-boot0 apparently. Guile is only listed once so hopefully it won't
take too long.

I assume this doesn't break anything on x86_64?

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8nsVYACgkQQarn3Mo9
g1Hb7Q/7BHSO4FCPpvpA4MHNesIHRjjrU9LY55GRGcsUdac7NXVSRTdk/kLbWVLX
HbNxLY8RMVz7J/kUl1iA8ZF5NcYQg+WX6E2q7MOmgVrkPsQMwIL81eP3Xn9hD3Ua
o+KF09CTDQGpsGBMoLWO+XAhWHSPgeQEXhWkEDZoUu4PjFs//68Q4N+UZBdeOlrg
RnTGvit4uMnlqTVYVEE5a82JPkyD+pqZKsZDkRn5w6nmmHBbrYz4Smj1vGcZk59b
5BznDkF6V7RFW+59DfZWyhHQqKLGvjH6rOaBdZ02hj+r6/Z3XRanhb9Zd0+Ta5Sw
aOPxTpymBUAtf9vCdPEBBYoXfwlAgue+bljaTN1SFA5SlZTCDF9ra98dzBKVia0N
jaQ7i5/Y4t/LQW2TWhv5KnFmrWiw+S/Rl4Q9wMVIQZCC+hCnUaeA0OSrKtC44blj
u1Ly5XneOWVJNsAUlFjGewAPJmO869BovsqAcc/CLzTngADHUbcesGQce9gb7uID
iTrQ2rH0kY0DF5K1RGqZz57fBcsuVOuUqGT37hA0odVbgEyASGAB6/dX6bf27CxA
76dsvSe/IqatVtOhD93HEgWIhLOpinKTB8E+ZvsD9Tb3WhtfoXYtG+FBKM3liv53
693ujombRWI4c4dG3ZArHiSG5pR4J5AmJelikUGCaxjNhEzm+cY=
=/+zW
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 3 Aug 2020 13:03
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . guix-patches@gnu.org)
20200803110352.ehwmgpnyjoxzxo5z@gravity
On Mon, Aug 03, 2020 at 09:40:26AM +0300, Efraim Flashner wrote:
Toggle quote (48 lines)
> On Sun, Aug 02, 2020 at 10:34:21PM +0200, Jakub K?dzio?ka wrote:
> > This updates the bootstrap-gcc to use the same search path strategy as
> > the main compilers, making the bootstrap environment more similar across
> > architectures, and fixing the bootstrap path on non-x86 architectures
> > again.
> >
> > This is a follow up to commit 7cde865f12dd67e55946a52a21103e71f447eced.
> >
> > * gnu/packages/bootstrap.scm (%bootstrap-gcc)[native-search-paths]: Use
> > C_INCLUDE_PATH and CPLUS_INCLUDE_PATH instead of CPATH.
> > ---
> >
> > Note: because I don't have any non-x86 machines on hand, I haven't
> > actually tested the patch yet.
> >
> > Efraim, you have helped me investigate this with your ARM board, perhaps
> > you could test this patch?
> >
> > Regards,
> > Jakub K?dzio?ka
> > gnu/packages/bootstrap.scm | 5 ++++-
> > 1 file changed, 4 insertions(+), 1 deletion(-)
> >
> > diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
> > index c39e60ec8b..fd6c2e099c 100644
> > --- a/gnu/packages/bootstrap.scm
> > +++ b/gnu/packages/bootstrap.scm
> > @@ -740,8 +740,11 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
> > "1m5miqkyng45l745n0sfafdpjkqv9225xf44jqkygwsipj2cv9ks")))))))))
> > (native-search-paths
> > (list (search-path-specification
> > - (variable "CPATH")
> > + (variable "C_INCLUDE_PATH")
> > (files '("include")))
> > + (search-path-specification
> > + (variable "CPLUS_INCLUDE_PATH")
> > + (files '("include/c++" "include")))
> > (search-path-specification
> > (variable "LIBRARY_PATH")
> > (files '("lib" "lib64")))))
> > --
> > 2.28.0
> >
>
> I'm building out to hello on my aarch64 board now, starting from
> make-boot0 apparently. Guile is only listed once so hopefully it won't
> take too long.

Thanks!

Toggle quote (2 lines)
> I assume this doesn't break anything on x86_64?

I don't have hello built on current core-updates (it also wants to start
from make-boot0), but I have confirmed that guix build --no-grafts -d
hello returns the same derivation path before and after the commit.
%bootstrap-gcc is not present at all in the package graph on x86.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8n7xgACgkQ4xWnWEYT
FWRShxAAt68T0w3DWy3UOSbcSGTc1FqSGkqp/E+IGX6y3RePLoComSTKOkh68D3U
04eibLFB6s1d0HqXxGx74Oo05UR2mAv9EZZ3Z9DTVa7YnopJhgoDkWUEaB9JduxY
7Z+uvlkANDm5E2Nkll+GFtmZzEPgTX4jCCVa3ym2edQ23dvpnauLhpkGLKRebER0
CosaauIGHh70hSfJg8aDlNYIyEUajbjs9vWAn1rNtF8fEtFp1Mgb0j6t8ihd8SoZ
b4f4jtOdLXgkwcPMiWmfokHNTSkTUFvB60D3ANs/UtLenn9lr/TefKD0bHoHZ4nh
Ka8qhIN4haxVquPIb03avQGCNx6rpRGD9AOaisvmM+RiCD+N4cDHC755lzvOBvUq
xUrdFIGn3zBXfUgqm9lh8P18UZxp8SJ12ENRSIyakubPJHi88Tb2OES0aHRQVCo/
j9RurRzwaiqAJ0P+m7t2+JFWIShz/IUQmsIDnizGqljxu/KGCAJ5mLcLFi0QVK5X
huaBU6EUjGi83UfPblz94X70M4g30NLbP+Y9IW36+EumV5g5X0/3PvdSIXRoQCrs
qd06kA61AZUI0ZBHMleExk2qn2RGiOoy9JAKqP1pltvHkGuQxiZlBEXZxvbvJna0
tbT83JlIgnLchJ00KldRzEEVfe9bBTw7nhJElQxYzPcrTNfCv0U=
=TEzw
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 4 Aug 2020 08:00
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)(address . guix-patches@gnu.org)
20200804060006.GM1134@E5400
On Mon, Aug 03, 2020 at 01:03:52PM +0200, Jakub K?dzio?ka wrote:
Toggle quote (61 lines)
> On Mon, Aug 03, 2020 at 09:40:26AM +0300, Efraim Flashner wrote:
> > On Sun, Aug 02, 2020 at 10:34:21PM +0200, Jakub K?dzio?ka wrote:
> > > This updates the bootstrap-gcc to use the same search path strategy as
> > > the main compilers, making the bootstrap environment more similar across
> > > architectures, and fixing the bootstrap path on non-x86 architectures
> > > again.
> > >
> > > This is a follow up to commit 7cde865f12dd67e55946a52a21103e71f447eced.
> > >
> > > * gnu/packages/bootstrap.scm (%bootstrap-gcc)[native-search-paths]: Use
> > > C_INCLUDE_PATH and CPLUS_INCLUDE_PATH instead of CPATH.
> > > ---
> > >
> > > Note: because I don't have any non-x86 machines on hand, I haven't
> > > actually tested the patch yet.
> > >
> > > Efraim, you have helped me investigate this with your ARM board, perhaps
> > > you could test this patch?
> > >
> > > Regards,
> > > Jakub K?dzio?ka
> > > gnu/packages/bootstrap.scm | 5 ++++-
> > > 1 file changed, 4 insertions(+), 1 deletion(-)
> > >
> > > diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
> > > index c39e60ec8b..fd6c2e099c 100644
> > > --- a/gnu/packages/bootstrap.scm
> > > +++ b/gnu/packages/bootstrap.scm
> > > @@ -740,8 +740,11 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
> > > "1m5miqkyng45l745n0sfafdpjkqv9225xf44jqkygwsipj2cv9ks")))))))))
> > > (native-search-paths
> > > (list (search-path-specification
> > > - (variable "CPATH")
> > > + (variable "C_INCLUDE_PATH")
> > > (files '("include")))
> > > + (search-path-specification
> > > + (variable "CPLUS_INCLUDE_PATH")
> > > + (files '("include/c++" "include")))
> > > (search-path-specification
> > > (variable "LIBRARY_PATH")
> > > (files '("lib" "lib64")))))
> > > --
> > > 2.28.0
> > >
> >
> > I'm building out to hello on my aarch64 board now, starting from
> > make-boot0 apparently. Guile is only listed once so hopefully it won't
> > take too long.
>
> Thanks!
>
> > I assume this doesn't break anything on x86_64?
>
> I don't have hello built on current core-updates (it also wants to start
> from make-boot0), but I have confirmed that guix build --no-grafts -d
> hello returns the same derivation path before and after the commit.
> %bootstrap-gcc is not present at all in the package graph on x86.
>
> Regards,
> Jakub K?dzio?ka

I was able to successfully build all the way out to hello on
aarch64-linux.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8o+WIACgkQQarn3Mo9
g1GgTBAAnbvLvU+uzyTAPmMrd4Dx+h1Agc1BEshnoc8jsuDA6hL/uBMGt/wCuPm+
DHFgrFYiFDrJfnPFtW97wfLO0+NhI3JZ44Yotf+QHZQCYKc/+xdksTF8iYy7Ke7o
H2LmJoh5F6X46bHvfeVDPgatnQbRYEKJKUMbg+rSy5ne2k6UfBJq3FuSkyEw07Y9
Nk8pA8R3QibSmwsCnQb7/qjucnlz8a/8EcsQx8o3Bdmrf1vREVsEUgWEypwLn5gJ
DtPjKt4sjtG4TD46OzJdHBtAxRuADWuBMPb4n3nJGsmwS31cVHZU7S1LwI2WH5mr
JXqIKk0ysiLekQPw1ln1FJygoOjvhZvSXhD/E8df0qs+JrGSq8juAWFmeIaG1udp
D7hBNYQT3E4bcs5j9LJoCZ7G12eNR8h+80WQj+gcdwfO3C55DEhlhr2D19cFnWyt
nFQY1bA0mcu5/1y+ElYAhYpt/ffkuS621+gwA7QNfAwZtzipUi7CsMs6LDzAlGlR
OA0Jx7giNIk+FoM+ejp7b4SZIFO5sOw3GL+QXHfBgvgUQIvJaDfhLmBG3QDSfRNu
aZNz1rBbHqNwD38kQcITCy6t8IWOzdpr71e3w3NUQcVf3FvCvnSaiaFSGu10D9H2
tcoFnIgAOIfCUCOu+TvRn6EnrHUenNFgmgLAW5RzmYxSnGs+dAU=
=q6Sy
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 4 Aug 2020 14:34
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 42681-done@debbugs.gnu.org)
20200804123435.pk3uqpasdctvjdo5@gravity
On Tue, Aug 04, 2020 at 09:00:06AM +0300, Efraim Flashner wrote:
Toggle quote (22 lines)
> On Mon, Aug 03, 2020 at 01:03:52PM +0200, Jakub K?dzio?ka wrote:
> > On Mon, Aug 03, 2020 at 09:40:26AM +0300, Efraim Flashner wrote:
> > > On Sun, Aug 02, 2020 at 10:34:21PM +0200, Jakub K?dzio?ka wrote:
> > > I'm building out to hello on my aarch64 board now, starting from
> > > make-boot0 apparently. Guile is only listed once so hopefully it won't
> > > take too long.
> >
> > Thanks!
> >
> > > I assume this doesn't break anything on x86_64?
> >
> > I don't have hello built on current core-updates (it also wants to start
> > from make-boot0), but I have confirmed that guix build --no-grafts -d
> > hello returns the same derivation path before and after the commit.
> > %bootstrap-gcc is not present at all in the package graph on x86.
> >
> > Regards,
> > Jakub K?dzio?ka
>
> I was able to successfully build all the way out to hello on
> aarch64-linux.

This is great news! Patch pushed.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8pVdsACgkQ4xWnWEYT
FWT7Ng/+N6RwCApKKwpkvE883K7H6WIHPpIAOGQS5AziOq4mlvU98SodQJFfdRxA
oSgvmeT0V+epUyy9R/BKg5vADwtDxDrPK69uyRaUI7UQoJlkaOWDW/LCK2yJrAXz
9ppAeQUTXuD0y+kO2bEVfj52FmLyVySEibPoN/GrFZVrANfbRZxF/EwJ32QWxmcw
7A/1gL9Bo7Oknrw1Lm3a+YGLh8J9CGdcPvWz2S8YUxSiLRIAvj/U7XqQ6AeGCGRN
htcrxqhmATIERdNWG2pfkNZGr/9Sdexr0CGzhrYUS/zsBwDeqCW+1rN7RNiZ8ycT
IZ2aa7stx3AOeJdBxRjjqnc1dgPBimnncm+edOW+fvRWj4gAmqtYV0//aklHlaAT
gZ3S7nskoyu90guKEazBhnci6jrIcMUgP1fGU99U0T+fuTbw5njhKB794h7KDekU
b/iOw+Te8AXnURCzubVDHM2bCEc4OBIzExY29ZItfV/DCYpvygD9HxkRdQ2IDoIb
XVr6tCzMdCA8QjwKwcR0MFtJvxusOTN1Htrdr6yQghyp2k32KTltS/FrGLewBl2K
erbJg+LaU+KA9CWpWhPNUT1d4UykfJxr5afm2/J+HlkQzr7uUsQW45GE8fhM47rQ
eC++NUIflvXA/HdlrIuAFuOk5LNHRW8Mv5tdo0vrG7oVexiwPOs=
=tFrb
-----END PGP SIGNATURE-----


Closed
E
E
Efraim Flashner wrote on 5 Aug 2020 10:56
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)(address . 42681-done@debbugs.gnu.org)
20200805085606.GA2042@E5400
On Tue, Aug 04, 2020 at 02:34:35PM +0200, Jakub K?dzio?ka wrote:
Toggle quote (24 lines)
> On Tue, Aug 04, 2020 at 09:00:06AM +0300, Efraim Flashner wrote:
> > On Mon, Aug 03, 2020 at 01:03:52PM +0200, Jakub K?dzio?ka wrote:
> > > On Mon, Aug 03, 2020 at 09:40:26AM +0300, Efraim Flashner wrote:
> > > > On Sun, Aug 02, 2020 at 10:34:21PM +0200, Jakub K?dzio?ka wrote:
> > > > I'm building out to hello on my aarch64 board now, starting from
> > > > make-boot0 apparently. Guile is only listed once so hopefully it won't
> > > > take too long.
> > >
> > > Thanks!
> > >
> > > > I assume this doesn't break anything on x86_64?
> > >
> > > I don't have hello built on current core-updates (it also wants to start
> > > from make-boot0), but I have confirmed that guix build --no-grafts -d
> > > hello returns the same derivation path before and after the commit.
> > > %bootstrap-gcc is not present at all in the package graph on x86.
> > >
> >
> > I was able to successfully build all the way out to hello on
> > aarch64-linux.
>
> This is great news! Patch pushed.
>

Continued testing shows that this also worked on my aarch64 board when
building for armhf.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8qdCMACgkQQarn3Mo9
g1EZQA//RhXkon01NmyvMzOl08l07Rby6GmZHfHdN1v7wJE58gBxncuurMRCMDvn
LDzZ3SfedHxwNVOk385gXLKGcPA7Tv2iljPrOhVBdzNohCiJBGFCWKHFzT2KHooo
FbZz5GBdUQ91tTuL53X4LxTtEXI3EXi6LGXS3vPMzuQi2x43JM5m4uewdmCcaPN9
vdidnTXBS6fukCYNVrEDRGjyK7zdKuIaWrPFifgTeRVIGdobddfLyZC25Ej9lkzJ
cey/gAPzgH74jpyMV1qjdYkmXE4sldH0aLXCAsBA8tTxkbmlpZ3WqkcVQZtFkNEf
y8oNVMJyYTN2TMHz0j1NLJ5qllMOmiMg252XP6vPsPCxvE9CTVspVzv0BCEFWsx1
/32WfrnhOrWsmzWkhgwEZGmzOT7JwkZxzdRJGDEr8j7HbM2iXmpVIb0peJS7Srse
X9BONdiRuiGcCLyp7b2+lG/QpnlQvankAKbKdTL1xK4PtNBBCSidusvUrbhb3Us1
nxhzQRZCCsULapLSuzgfCLwvhWFewIcFMLpSRmLGNOD5L7iwYiJh6jlxe+XhShdw
skY4FDVOy0iAoQQUii//XD1br/tBAhU655FR9FiRk5in9FcaIRBaPNTnNxgTXTQA
MBrqbTGPXrFIx/ED+g4n0PHbpKF6d3waLaKi1rv6BEzvkbV5rvs=
=0//S
-----END PGP SIGNATURE-----


Closed
?