[PATCH, WIP] gnu: libimagequant: Update to 2.12.6

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Hendur Saga
  • Jelle Licht
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Hendur Saga
Severity
normal
H
H
Hendur Saga wrote on 2 Aug 2020 18:09
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
115810482.10783477.1596384550705@mail.yahoo.com
Hello,

Just a simple update, but sadly, I am unable to build using QEMU for other platforms. Same as with previous version, it does NOT build correctly on armhf.


starting phase `configure'
source directory: "/tmp/guix-build-libimagequant-2.12.6.drv-0/source" (relative from build: ".")
build directory: "/tmp/guix-build-libimagequant-2.12.6.drv-0/source"
configure flags: ("CONFIG_SHELL=/gnu/store/7zp9ifpgm3zj481nk6jg1im13g4mza2g-bash-minimal-5.0.16/bin/bash" "SHELL=/gnu/store/7zp9ifpgm3zj481nk6jg1im13g4mza2g-bash-minimal-5.0.16/bin/bash" "--prefix=/gnu/store/m65h6a45pz3wpraiid99hqq0rcbk5s9w-libimagequant-2.12.6" "--enable-fast-install" "--build=arm-unknown-linux-gnueabihf")
warning: unknown switch 'CONFIG_SHELL' (see ./configure --help for the list)
warning: unknown switch 'SHELL' (see ./configure --help for the list)
warning: unknown switch '--enable-fast-install' (see ./configure --help for the list)
warning: unknown switch '--build' (see ./configure --help for the list)

  Compiler: gcc
     Debug: no
       SSE: yes
    OpenMP: no

phase `configure' succeeded after 3.3 seconds
starting phase `patch-generated-file-shebangs'
phase `patch-generated-file-shebangs' succeeded after 0.0 seconds
starting phase `build'
gcc -fno-math-errno -funroll-loops -fomit-frame-pointer -Wall -std=c99 -I. -O3 -DNDEBUG -DUSE_SSE=1 -msse -Wno-unknown-pragmas -fexcess-precision=fast   -c -o pam.o pam.c
gcc -fno-math-errno -funroll-loops -fomit-frame-pointer -Wall -std=c99 -I. -O3 -DNDEBUG -DUSE_SSE=1 -msse -Wno-unknown-pragmas -fexcess-precision=fast   -c -o mediancut.o mediancut.c
gcc -fno-math-errno -funroll-loops -fomit-frame-pointer -Wall -std=c99 -I. -O3 -DNDEBUG -DUSE_SSE=1 -msse -Wno-unknown-pragmas -fexcess-precision=fast   -c -o blur.o blur.c
gcc -fno-math-errno -funroll-loops -fomit-frame-pointer -Wall -std=c99 -I. -O3 -DNDEBUG -DUSE_SSE=1 -msse -Wno-unknown-pragmas -fexcess-precision=fast   -c -o mempool.o mempool.c
gcc: error: unrecognized command line option ‘-msse’; did you mean ‘-fdse’?
make: *** [<builtin>: pam.o] Error 1
make: *** Waiting for unfinished jobs....
gcc: error: unrecognized command line option ‘-msse’; did you mean ‘-fdse’?
gcc: error: unrecognized command line option ‘-msse’; did you mean ‘-fdse’?
make: *** [<builtin>: mediancut.o] Error 1
make: *** [<builtin>: blur.o] Error 1
gcc: error: unrecognized command line option ‘-msse’; did you mean ‘-fdse’?
make: *** [<builtin>: mempool.o] Error 1
command "make" "-j" "4" failed with status 2


It appears to be an false assumption of SSE2 support where there is none? In addition, the same error happens when building this new version on aarch64, but not the previous one. The package definition for gemmlowp might have a clue as to what to do here.

Since QEMU is a machine emulator/virtualizer, I'm not sure how relevant this is, but my machine's CPU does not have SSE2 itself, AFAIK.

- Hendursaga
Attachment: file
From 13d5468c407ef569b343ff1e7cbdb6be2bfc5f3c Mon Sep 17 00:00:00 2001
From: Hendursaga <hendursaga@yahoo.com>
Date: Sun, 2 Aug 2020 15:59:55 +0000
Subject: [PATCH] gnu: libimagequant: Update to 2.12.6

* gnu/packages/image.scm (libimagequant): Update to 2.12.6
---
gnu/packages/image.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index ac523172de..159e75150f 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -304,7 +304,7 @@ Currently all documentation resides in @file{pnglite.h}.")
(define-public libimagequant
(package
(name "libimagequant")
- (version "2.12.5")
+ (version "2.12.6")
(source
(origin
(method git-fetch)
@@ -313,7 +313,7 @@ Currently all documentation resides in @file{pnglite.h}.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0cp68w04ja5pv77ssfafsn958w9hh9zb8crrlb5j3gsrcmdc032k"))))
+ (base32 "00w7fny3xf14cfyhbdnmqyh9ddqdh1irvgzxd35a2z65kp7vnvj0"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f)) ; no check target
--
2.28.0
M
M
Mathieu Othacehe wrote on 3 Aug 2020 09:26
(name . Hendur Saga)(address . hendursaga@yahoo.com)(address . 42678@debbugs.gnu.org)
87bljsur4e.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> Just a simple update, but sadly, I am unable to build using QEMU for other platforms. Same as with previous version, it does NOT build correctly on armhf.

You mean using "-s armhf-linux"?

I tried to build it using this command:

Toggle snippet (3 lines)
guix build libimagequant --target=arm-linux-gnueabihf

and I have a build trace similar to yours. The issue seems to be that
the configure script does not detect our intent to cross-compile,
because it uses "gcc" instead of "arm-linux-gnueabihf-gcc".

Mathieu
E
E
Efraim Flashner wrote on 3 Aug 2020 09:47
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20200803074712.GH1134@E5400
On Mon, Aug 03, 2020 at 09:26:41AM +0200, Mathieu Othacehe wrote:
Toggle quote (20 lines)
>
> Hello,
>
> > Just a simple update, but sadly, I am unable to build using QEMU for other platforms. Same as with previous version, it does NOT build correctly on armhf.
>
> You mean using "-s armhf-linux"?
>
> I tried to build it using this command:
>
> --8<---------------cut here---------------start------------->8---
> guix build libimagequant --target=arm-linux-gnueabihf
> --8<---------------cut here---------------end--------------->8---
>
> and I have a build trace similar to yours. The issue seems to be that
> the configure script does not detect our intent to cross-compile,
> because it uses "gcc" instead of "arm-linux-gnueabihf-gcc".
>
> Mathieu
>

Also armhf and aarch64 don't have the SSE instruction code as part of
the architecture. lensfun in gnu/packages/photo.scm has an example of
disabling SSE on all platforms except for x64_64 and i686.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8nwP0ACgkQQarn3Mo9
g1Gj7RAAiiRfRDcppm4xCpX8OJ7Qk14rIy+Y0+4dFU2Afe5pbwpSIgtheyoJOXZy
B/J/kxZrTW7B4DCXjNRgTdsfh3W7Y5hzyTZ8rnnx9HnSXB9qw+0/oqJ5QwC9Xb51
2Gmu7fd31WsP/PM4NzNFCOkqRwbEeE5ka0U8rOlop5paA7oYUKpr330XUxHbvXXp
24tsBPzwySmqcKsvIapMBoOLe5XOceSDEKcfAPjm6JYRS+t/fwXkF1l7R3wG+ApK
UAGwXIk+3CCKZCziegvEhq+mCFgXxWR1eOBrHwiTzEbBHnqHEhN7Ss1Om+6bJzd+
t+d9qdrFGPdDD/9RoxWkcu6qJGRRznyloL5QcgqeHTlPU3aXVSZhpovd1swpxJ3U
wSGHYmXq+UI2+h1KlcDtiueY79j/lHQv/qeRJ/4rfhbWV1OI01xaSm2C8F1e1U8I
XpSVJvrFPyIsb+1+amFMKcIyjCKHczBa+6ldGWyDDLFt/hxlEUQuxNLqFbVyevBF
bsv57g9CCLjnlvAAuySLdX7gjqBwYxHi/B+BueOem0ATMKmxTV3hcPVg+EEYFssk
HDnhRMa565+9Tg4msK3/hBoVKfBI7vIGSgyHHUkUTJvALXFCRTlxS3eYjVThtnq/
fh3orWhC1cfV32YhON26D2V4z0BPrfGIJexzUSWvfRMerYle2Js=
=NBug
-----END PGP SIGNATURE-----


J
J
Jelle Licht wrote on 28 May 2023 23:59
Re: bug#42678: [PATCH, WIP] gnu: libimagequant: Update to 2.12.6
(address . 42678-done@debbugs.gnu.org)
875y8cp160.fsf@fsfe.org
Superseded by d6f1e8135676a4d38fda9927434999312b60ba21 on master. Closing.
Closed
?