[PATCH] gnu: Add emacs-explain-pause-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Oleg Pykhalov
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 2 Aug 2020 15:33
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB21053058888E254EB95793B3C54C0@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-explain-pause-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a90d789d7a..5078bbd56e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3237,6 +3237,29 @@ keep pressing the key until it selects what you want. There's also
@code{er/contract-region} if you expand too far.")
(license license:gpl3+)))
+(define-public emacs-explain-pause-mode
+ (let ((commit "2356c8c3639cbeeb9751744dbe737267849b4b51")
+ (revision "0"))
+ (package
+ (name "emacs-explain-pause-mode")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lastquestion/explain-pause-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0frnfwqal9mrnrz6q4v7vcai26ahaw81894arff1yjw372pfgv7v"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/lastquestion/explain-pause-mode")
+ (synopsis "Provides a top like interface to determine why Emacs paused")
+ (description "Monitors Emacs function calls and records their execution
+time. This information can be reviewed to determine what is causing the user
+interface to pause.")
+ (license license:gpl3+))))
+
(define-public emacs-fill-column-indicator
(package
(name "emacs-fill-column-indicator")
--
2.28.0
O
O
Oleg Pykhalov wrote on 2 Aug 2020 17:17
(address . Morgan.J.Smith@outlook.com)(address . 42674@debbugs.gnu.org)
87a6zdrsas.fsf@gmail.com
Hi,

Could you take a look on running the test suite, please?

Thanks,
Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl8m2PsACgkQFn+OpQAa
+pxBYQ/+O145Dvr/dHQhQ3a8TduWNCJq0SJDdSZvX0+cKhoGWTASx8r59tI8UXCC
xbznxGW6PJcqWxq7puI16hGoHh6ud3bOHYZ0nk+vLt8o5kuyt98RY+d9vzf5sTgI
SfGDOtTLQUe0IvLYxpF2W13EPzfY3VoufPA4GuxtKj3zgk9z0J4RFa1/067x2Zdu
X3G3PnKJtWqQmFSUIpwpqLGW2G28fqTCEP7/zy6IfcQbQuujKoKk7Qpi12BbPkHk
DVF6LVX22L6za2qC/CCNc00yzK/PVh7o6lEMqs9UFTO49SNwqdOXfcXQoy3mk0T4
pnC/3b01y83ZznpVztBqNLoxGSabnfKkJZGWIasLa1ZT/+rWqv5CKlLlTTUOpCMV
bW7vWDdhzn/7YWg/kyAcUEZeUAd7s9onzg1v0sb3L7jAHQ/+UkoavAwKzgG2xXbc
6FS1Tbm3tdDpvvJPhA53KQ1wjmwhUr5mKD7+v95TGLDpl0tWzCIHFAUJS7p3CefY
uwxmWfQg9oXzj9DeasvWXwaRnfqjLw/eoUCFxepiELlfQBHQRo6tp05eIhqniEw+
a+1tgtZpyk8oPcERCzBnbqDfxJgMp1/aCDmQeh87vrpczLXHvdxfhZ+Uk6UdoBdh
ck0WxAl3ZrTvAYIPnILA09OhFxmjmeZLUuXIHespuDf4Zv2AkPE=
=Xmn0
-----END PGP SIGNATURE-----

M
M
Morgan.J.Smith wrote on 2 Aug 2020 21:10
[PATCH] gnu: Add emacs-explain-pause-mode.
(address . 42674@debbugs.gnu.org)
DM5PR1001MB2105D22DE6B640499E48AB16C54C0@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-explain-pause-mode): New variable.
---
DO NOT COMMIT YET!

This should only be commited after patch 42679.

gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a90d789d7a..ab8e6dff6c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3237,6 +3237,39 @@ keep pressing the key until it selects what you want. There's also
@code{er/contract-region} if you expand too far.")
(license license:gpl3+)))
+(define-public emacs-explain-pause-mode
+ (let ((commit "2356c8c3639cbeeb9751744dbe737267849b4b51")
+ (revision "0"))
+ (package
+ (name "emacs-explain-pause-mode")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lastquestion/explain-pause-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0frnfwqal9mrnrz6q4v7vcai26ahaw81894arff1yjw372pfgv7v"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs" ,emacs-buttercup)))
+ (arguments
+ '(#:tests? #t
+ ;; Don't run case-tests as they will fail to create sockets because
+ ;; the path is too long
+ #:test-command '("make" "byte-compile" "unit-tests")
+ ;; Parallel testing will cause the tests to run before
+ ;; byte-compilation is finished
+ #:parallel-tests? #f))
+ (home-page "https://github.com/lastquestion/explain-pause-mode")
+ (synopsis "Provides a top like interface to determine why Emacs paused")
+ (description "Monitors Emacs function calls and records their execution
+time. This information can be reviewed to determine what is causing the user
+interface to pause.")
+ (license license:gpl3+))))
+
(define-public emacs-fill-column-indicator
(package
(name "emacs-fill-column-indicator")
--
2.28.0
O
O
Oleg Pykhalov wrote on 12 Aug 2020 18:50
(address . Morgan.J.Smith@outlook.com)(address . 42674-done@debbugs.gnu.org)
87lfijiza9.fsf@gmail.com
Hi,

Thank you!

Pushed to master.

Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl80Hd4ACgkQFn+OpQAa
+pzHphAAqA+euaPEQda6rXSlsIm+o7bL4i/8/ltDGfqkp7zM59Bjb/zNJCtYSEsK
C60JJbFEzBbb3RuyKd8JK+iAgVcBwgy0VdZDH6UsuhnF+q6oSbTEn35eqg8N36tF
Sw4dLCDwtwAHXCZcXDfpFTS8bc1iXXyzDTH4uNYfkMrpx0iQcYS6CJOPUr3xQxSK
GdqJWCYyjsiBq5IwzJFO1zdg/FT7sQYcJsLIzMXE0aKaACYv5+m3uBvJAcjdYa3C
vUowkzGpKNWjG39tPx4TlDbbChlGOyzsjnwUGf3kswdL+ju/Yy0go78WTPpKERCJ
q/nShUC0c7m32xXy3khxutOLjzsBYljVzASiiHXcPS1zJ8TKhWZMtYvdZkj5TQUr
K8fneogK5dGHQRWMu6XLA077Su6R5p5mC/meF0bS67II/eLo+ETzxN1M2M15sQ5P
QCQ2GRVcOjUrx8b35rWnk+RMmEiC5QXy3J0fk/mbtiPTLtNs046fnEzLN3fF3qCz
EhxkEiQUygSkJmbmpwX19sTflGHTYp2M5patOmw0RWi9JnzwnGrvGRMDd+De7j/s
6ojeCtJpneA60XQalEw0N7WDn5dORVhzSPx4y+Ymto/BKcGVACU0WmreA643OXta
MUbF6dpnsXaLgtqVl8j1w1l6sNQ0riU666U/V8Fvjptp/qmJc2A=
=dRic
-----END PGP SIGNATURE-----

Closed
?