add sbcl-qbase64

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 1 Aug 2020 11:24
(name . Guix Patches)(address . guix-patches@gnu.org)
MDdKXZk--3-2@tuta.io
(define-public sbcl-qbase64
  (let ((commit "6374899aec189600e6b7b77c89009d0835154b93")
    (revision "1"))
    (package
      (name "sbcl-qbase64")
      (version (git-version "0.0.0" revision commit))
      (source
       (origin
         (method git-fetch)
         (uri (git-reference
               (url "https://github.com/chaitanyagupta/qbase64")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
          (base32 "1dir0s70ca3hagxv9x15zq4p4ajgl7jrcgqsza2n2y7iqbxh0dwi"))))
      (build-system asdf-build-system/sbcl)
      (inputs
       `(("sbcl-trivial-gray-streams" ,sbcl-trivial-gray-streams)
     ("metabang-bind" ,sbcl-metabang-bind)))
      (native-inputs
       `(("fiveam" ,sbcl-fiveam)))
      (synopsis "qbase64 provides a fast and flexible base64 encoder and decoder for Common Lisp.")
      (description "qbase64 provides a fast and flexible base64 encoder and decoder for Common Lisp.")
      (license license:bsd-3))))
G
G
Guillaume Le Vaillant wrote on 2 Aug 2020 09:32
(name . Adam Kandur)(address . rndd@tuta.io)(address . 42647-done@debbugs.gnu.org)
87d0497ba7.fsf@yamatai
Adam Kandur via Guix-patches via <guix-patches@gnu.org> skribis:

Toggle quote (26 lines)
> (define-public sbcl-qbase64
> (let ((commit "6374899aec189600e6b7b77c89009d0835154b93")
> (revision "1"))
> (package
> (name "sbcl-qbase64")
> (version (git-version "0.0.0" revision commit))
> (source
> (origin
> (method git-fetch)
> (uri (git-reference
> (url "https://github.com/chaitanyagupta/qbase64")
> (commit commit)))
> (file-name (git-file-name name version))
> (sha256
> (base32 "1dir0s70ca3hagxv9x15zq4p4ajgl7jrcgqsza2n2y7iqbxh0dwi"))))
> (build-system asdf-build-system/sbcl)
> (inputs
> `(("sbcl-trivial-gray-streams" ,sbcl-trivial-gray-streams)
> ("metabang-bind" ,sbcl-metabang-bind)))
> (native-inputs
> `(("fiveam" ,sbcl-fiveam)))
> (home-page "https://github.com/chaitanyagupta/qbase64")
> (synopsis "qbase64 provides a fast and flexible base64 encoder and decoder for Common Lisp.")
> (description "qbase64 provides a fast and flexible base64 encoder and decoder for Common Lisp.")
> (license license:bsd-3))))

Patch pushed as a05edef2ac692be8bf3033fe008b7c1b29f83123 with a few
modifications (version, indentation, etc...). Thanks.
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQQkUwKxurH4Z/3KlryPP4Yfgut6mgUCXyZsIAAKCRCPP4Yfgut6
msYAAQCMSpxvM2n5wEmSvCk6m7EzP1B1uaxLqfTTBbnQ58b8gwD/SEgNux3egr3v
wmIUZlCT9sh05fTLu8wDueWdsDM9YAM=
=2/en
-----END PGP SIGNATURE-----

Closed
?