[PATCH] gnu: Add Remake.

  • Done
  • quality assurance status badge
Details
3 participants
  • Eric Bavier
  • Eric Bavier
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Eric Bavier
Severity
normal
E
E
Eric Bavier wrote on 1 Aug 2020 06:40
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
20200801044002.18198-1-bavier@member.fsf.org
* gnu/packages/debug.scm (remake): New variable.
* gnu/packages/patches/remake-impure-dirs.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
gnu/local.mk | 1 +
gnu/packages/debug.scm | 25 ++++++++++++++++
gnu/packages/patches/remake-impure-dirs.patch | 30 +++++++++++++++++++
3 files changed, 56 insertions(+)
create mode 100644 gnu/packages/patches/remake-impure-dirs.patch

Toggle diff (86 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 181212c70b..299ccf0b69 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1507,6 +1507,7 @@ dist_patch_DATA = \
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \
%D%/packages/patches/rtags-separate-rct.patch \
%D%/packages/patches/racket-store-checksum-override.patch \
+ %D%/packages/patches/remake-impure-dirs.patch \
%D%/packages/patches/retroarch-disable-online-updater.patch \
%D%/packages/patches/rnp-add-version.cmake.patch \
%D%/packages/patches/rnp-disable-ruby-rnp-tests.patch \
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 2a3e6edc31..2f58f8e972 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -536,6 +536,31 @@ the position of the variable and allows you to modify its value.")
;; by GPLv3 or later.
(license (list license:lgpl3+ license:gpl3+))))
+(define-public remake
+ (package (inherit gnu-make)
+ (name "remake")
+ (version "4.3-1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (let ((upstream-version
+ (match (string-split version #\-)
+ ((ver sub) (string-append ver "%2Bdbg-" sub)))))
+ (string-append "mirror://sourceforge/bashdb/"
+ "remake/" upstream-version "/"
+ "remake-" upstream-version ".tar.gz")))
+ (file-name (string-append "remake-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xlx2485y0israv2pfghmv74lxcv9i5y65agy69mif76yc4vfvif"))
+ (patches (search-patches "remake-impure-dirs.patch"))))
+ (inputs
+ `(("readline" ,readline)
+ ,@(package-inputs gnu-make)))
+ (home-page "http://bashdb.sourceforge.net/remake/")
+ (description "Remake is an enhanced version of GNU Make that adds improved
+error reporting, better tracing, profiling, and a debugger.")
+ (license license:gpl3+)))
+
(define-public rr
(package
(name "rr")
diff --git a/gnu/packages/patches/remake-impure-dirs.patch b/gnu/packages/patches/remake-impure-dirs.patch
new file mode 100644
index 0000000000..698ac7476c
--- /dev/null
+++ b/gnu/packages/patches/remake-impure-dirs.patch
@@ -0,0 +1,30 @@
+Purity: don't look for library dependencies (of the form `-lfoo') in
+/lib and /usr/lib. Likewise, when searching for included Makefiles,
+don't look in /usr/include and friends.
+
+Borrowed from similar patch for GNU Make and adjusted for Remake.
+
+--- remake-4.3+dbg-1.5/src/read.c.orig 2020-03-14 17:06:16.000000000 -0500
++++ remake-4.3+dbg-1.5/src/read.c 2020-07-31 22:34:03.862383862 -0500
+@@ -104,7 +104,7 @@
+ # define INCLUDEDIR "."
+ #endif
+ INCLUDEDIR,
+-#ifndef _AMIGA
++#if 0
+ "/usr/gnu/include",
+ "/usr/local/include",
+ "/usr/include",
+--- remake-4.3+dbg-1.5/src/remake.c.orig 2020-03-14 17:06:16.000000000 -0500
++++ remake-4.3+dbg-1.5/src/remake.c 2020-07-31 22:34:26.798330508 -0500
+@@ -1665,8 +1665,10 @@
+ {
+ static const char *dirs[] =
+ {
++#if 0
+ "/lib",
+ "/usr/lib",
++#endif
+ #if defined(WINDOWS32) && !defined(LIBDIR)
+ /*
+ * This is completely up to the user at product install time. Just define
--
2.27.0
M
M
Mathieu Othacehe wrote on 1 Aug 2020 09:06
(name . Eric Bavier)(address . bavier@member.fsf.org)(address . 42641@debbugs.gnu.org)
87lfiyalq9.fsf@gnu.org
Hello Eric,

Toggle quote (4 lines)
> * gnu/packages/debug.scm (remake): New variable.
> * gnu/packages/patches/remake-impure-dirs.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.

This looks fine, feel free to proceed.

Thanks,

Mathieu
E
E
Eric Bavier wrote on 1 Aug 2020 21:06
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 42641-done@debbugs.gnu.org)
1b0dc45e5209e1d28dba25c180489655353bd866.camel@posteo.net
On Sat, 2020-08-01 at 09:06 +0200, Mathieu Othacehe wrote:
Toggle quote (8 lines)
> Hello Eric,
>
> > * gnu/packages/debug.scm (remake): New variable.
> > * gnu/packages/patches/remake-impure-dirs.patch: New file.
> > * gnu/local.mk (dist_patch_DATA): Add it.
>
> This looks fine, feel free to proceed.

Thanks for the review, Mathieu!

Pushed in 86f86cffd822afc012e308490e9931a66ce924aa

`~Eric
Closed
?