[PATCH] bump libuv to 1.38

OpenSubmitted by Formbi.
Details
3 participants
  • Formbi
  • Jakub Kądziołka
  • Mathieu Othacehe
Owner
unassigned
Severity
normal
F
F
Formbi wrote on 31 Jul 19:08 +0200
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
goNKsRaoBFRnv5vE8NIattm6PQSs6robVx9Am6DZQVxrL4l2NXBZLDDzgl0T7hYI7-iqd85HOC4HhIl3nMcyK4UtJCNOKAuXyB7tfVSN00E=@protonmail.com
Empty Message
From 58ed4908680d98a1b4769b40a47ded3fd49cfc6b Mon Sep 17 00:00:00 2001From: Formbi <formbi@protonmail.com>Date: Fri, 31 Jul 2020 18:59:55 +0200Subject: [PATCH] bump libuv
--- gnu/packages/libevent.scm | 12 ++++++++++++ 1 file changed, 12 insertions(+)
Toggle diff (25 lines)diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scmindex dab574a155..3e7189dd56 100644--- a/gnu/packages/libevent.scm+++ b/gnu/packages/libevent.scm@@ -133,6 +133,18 @@ resolution, asynchronous file system operations, and threading primitives.") ;; details. Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'. (license (list expat cc-by4.0)))) +(define-public libuv-1.38+ (package+ (inherit libuv)+ (version "1.38.1")+ (source (origin+ (method url-fetch)+ (uri (string-append "https://dist.libuv.org/dist/v" version+ "/libuv-v" version ".tar.gz"))+ (sha256+ (base32+ "0iy6yp9nrxpj643w7la3kl3j59ni59b0l4v6n23a63s8kqkpvkhf"))))))+ (define-public perl-anyevent (package (name "perl-anyevent")-- 2.26.0
M
M
Mathieu Othacehe wrote on 1 Aug 08:59 +0200
(name . Formbi)(address . formbi@protonmail.com)(address . 42638@debbugs.gnu.org)
87r1sqam2o.fsf@gnu.org
Hello Formbi,
When updating a package, the commit message has to follow a fewconventions detailed in the manual here:https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html.
Toggle quote (12 lines)> +(define-public libuv-1.38> + (package> + (inherit libuv)> + (version "1.38.1")> + (source (origin> + (method url-fetch)> + (uri (string-append "https://dist.libuv.org/dist/v" version> + "/libuv-v" version ".tar.gz"))> + (sha256> + (base32> + "0iy6yp9nrxpj643w7la3kl3j59ni59b0l4v6n23a63s8kqkpvkhf"))))))
Regarding this very update, why do we need this specific version?
Thanks,
Mathieu
F
F
Formbi wrote on 1 Aug 23:47 +0200
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(name . 42638@debbugs.gnu.org)(address . 42638@debbugs.gnu.org)
e2D9UoRJFEbPoTUeVJX45whPh4TZQj1dlKGh6nJFlkiFImRgL6EmfeMoURRy5xU1LKN9zzds22GHIkMZoR_Ke3XKqH3LTPADtPqPXq_YM7c=@protonmail.com
Toggle quote (2 lines)>why do we need this specific version?
It's needed by the 14.6 version of Node.
J
J
Jakub Kądziołka wrote on 6 Aug 23:28 +0200
(name . Formbi)(address . formbi@protonmail.com)
20200806212853.u27baqlvwltpxef2@gravity
On Sat, Aug 01, 2020 at 09:47:59PM +0000, Formbi wrote:
Toggle quote (4 lines)> >why do we need this specific version?> > It's needed by the 14.6 version of Node.
The core-updates branch already has libuv 1.38.1, so this patch mightbecome unnecessary depending on when Node 14.6 gets added - I think itwould be better if you submitted this patch as part of the Node 14.6patchstack.
Regards,Jakub Kądziołka
-----BEGIN PGP SIGNATURE-----
iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8sdhUACgkQ4xWnWEYTFWRuHQ//ewaC6zHJWdSB8MTjRqczkC1loRtVCKgWDYOXQFuqBfkcQaOpiTItcaqwgoKmetFX6YzP2BcDBy9l+sNMAnCE1uU7oCwPqQ+RZtL9xVrqLmcmjJaP3Kr2IHCx1Omv+UjQhUfAdJb1Xzmi1HKAVFKVGw+H6xJX9yD3wq2lWBg3JJ2HPHjg2ihuftungt08CcMZjNTSdkd5Q93e2rmqyj2AVW84skRTjgruYU5jvqE/EhjGKMjOKPiMdO5wQJ5WnanAPGsbggSDqgKq4Ly5Lce86fcuVn3k1hwz67+PugkonQxbpfkNIaGZinBGw7Yq8ye9Lx00vZ3hc+ipDdHMgK9rtOsKD/L5inLlTj3XDKcWXoU4NC52aepcdGLj89h3teJ+HQ31t5U5zn4zOJKzksGmgItSKiuMGo04VDNLRZg/0UVq1rcYAOWJX5gpqXIj5rc28dvyFsuCYxV9s5G5gqoSI/vbZ3zSyQyuG7eVSueCBGRT4fas+9zw1ONROVfSC9BwiJx2CpCoque6T1WlfWNoyk+aa8P1qTZ5opOOF1Uct7/AnCl0wTQPbxujQUrGkRaPjePA0+ujw51+Q4KCBHHWeaK91Ysf+89wXQgBCM9GKFGXrHHnx5pF11ZQGD+MlLqvCxVtUzJ2/Ts3mxW8x0YsXT+1FclQzXKqrF80nB6EGMg==kZNW-----END PGP SIGNATURE-----

J
J
Jakub Kądziołka wrote on 6 Aug 23:31 +0200
(name . Formbi)(address . formbi@protonmail.com)
20200806213112.idgx3uhkjicqgum4@gravity
On Thu, Aug 06, 2020 at 11:28:55PM +0200, Jakub Kądziołka wrote:
Toggle quote (13 lines)> On Sat, Aug 01, 2020 at 09:47:59PM +0000, Formbi wrote:> > >why do we need this specific version?> > > > It's needed by the 14.6 version of Node.> > The core-updates branch already has libuv 1.38.1, so this patch might> become unnecessary depending on when Node 14.6 gets added - I think it> would be better if you submitted this patch as part of the Node 14.6> patchstack.> > Regards,> Jakub Kądziołka
Whoops, I didn't see your Node patch, as the page-break on Debbugsobscured it. Not too long ago we only had a single page worth of pendingpatches... :/
-----BEGIN PGP SIGNATURE-----
iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8sdqAACgkQ4xWnWEYTFWStqhAA3rU52L4n/Pz40uLKOBT0bX7C8FwChI+NVeYPHyal7awaguMBLnCqHpv3PFF2cw1DYsQZHpjeFq4jgCO/HNTmNUWhVxrgjCsffeRvGsIJvelJdxNgkmY60GhTKQErvxlDMStjS2XmXhHObU796iIhyvPAauNEll6Y2/aGQW7IxpKssX/ZM9BrSJKBmf4bIKw8NBBXK7A+gYensbEu2jkobYZsBeJMnbqIBBejiPJgKJySFUWX2ExC+16VB5KV5pIyaMHyadQ3kbch30Td39JjJe8OxTD+fLKV80gYxK2iT/QOLF0U/Z3a/W6CZdnkbEc1H9wg8u3JpgDfvnQnNHxt+ezj2bzBjtLWvtKBWbkKTO8bl97uJvu83OGVJIgYsSh7DrLqGFlITsyLW9xGghBUseGOpESMy1qHfFRVYPjjUIllf0FG+4opzIQCxqdwoSHvz4ilsMPwkFsnmHq24AUGv7BNaNAhzgOBBIJkJiJjEKq67TaqTEdkzGkZUsKyFSnPXa7xVjxpX0XDufcVSy0QbJC+yzzJ6YwG1zF4AFCgcyArVAHT8jMTg9ydPf1rLE0YN7rRO5bZM7TMPe2hR+eSCPdc0LGPfdvayOVbXKvUOf2X6UmGJp/gYqLkddx/+xeZyTLywHooFh9zQqKXdRgg2X/h9TBOuDe7NArP0D1SAoI==dthH-----END PGP SIGNATURE-----

?