[PATCH] gnu: Add python-pytest-ordering.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 31 Jul 2020 17:59
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200731155921.39000-1-monego@posteo.net
* gnu/packages/python-check.scm (python-pytest-ordering): New variable.
---
gnu/packages/python-check.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index e96ce9e666..3beac8c206 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -126,6 +126,40 @@ detect the absence of a cassette file and once again record all HTTP
interactions, which will update them to correspond to the new API.")
(license license:expat)))
+(define-public python-pytest-ordering
+ (package
+ (name "python-pytest-ordering")
+ (version "0.6")
+ (source
+ (origin
+ ;; No tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ftobia/pytest-ordering")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14msj5gyqza0gk3x7h1ivmjrwza82v84cj7jx3ks0fw9lpin7pjq"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "-k"
+ ;; This test fails because of a type mismatch of an
+ ;; argument passed to @code{pytest.main}.
+ "not test_run_marker_registered"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/ftobia/pytest-ordering")
+ (synopsis "Pytest plugin to run your tests in a specific order")
+ (description
+ "This plugin defines Pytest markers to ensure that some tests, or groups
+of tests run in a specific order.")
+ (license license:expat)))
+
(define-public python-pytest-arraydiff
(package
(name "python-pytest-arraydiff")
--
2.20.1
M
M
Mathieu Othacehe wrote on 1 Aug 2020 08:54
(name . Vinicius Monego)(address . monego@posteo.net)(address . 42636-done@debbugs.gnu.org)
87tuxmama6.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> * gnu/packages/python-check.scm (python-pytest-ordering): New variable.

Pushed, thanks!

Mathieu
Closed
?