[PATCH 1/2] gnu: wxmaxima: Update to 20.06.6.

  • Done
  • quality assurance status badge
Details
One participant
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal
K
K
Kei Kebreau wrote on 31 Jul 2020 05:20
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20200731032038.23036-1-kkebreau@posteo.net
* gnu/packages/maths.scm (wxmaxima): Update to 20.06.6.
[arguments]: Add 'patch-doc-path' phase.
---
gnu/packages/maths.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3991b2f88b..6f446d9118 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3263,7 +3263,7 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "20.04.0")
+ (version "20.06.6")
(source
(origin
(method git-fetch)
@@ -3272,7 +3272,7 @@ point numbers.")
(commit (string-append "Version-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0vrjxzfgmjdzm1rgl0crz4b4badl14jwh032y3xkcdvjl5j67lp3"))))
+ (base32 "054f7n5kx75ng5j20rd5q27n9xxk03mrd7sbxyym1lsswzimqh4w"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -3290,6 +3290,14 @@ point numbers.")
`(#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-doc-path
+ (lambda _
+ ;; Don't look in share/doc/wxmaxima-xx.xx.x for the
+ ;; documentation. Only licensing information is placed there by
+ ;; Guix.
+ (substitute* "src/Dirstructure.cpp"
+ (("/doc/wxmaxima-\\%s") "/doc/wxmaxima"))
+ #t))
(add-before 'check 'pre-check
(lambda _
;; Tests require a running X server.
--
2.27.0
K
K
Kei Kebreau wrote on 31 Jul 2020 05:21
[PATCH 2/2] gnu: wxwidgets: Fix MIME type loading.
(address . 42625@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20200731032145.23092-1-kkebreau@posteo.net
* gnu/packages/wxwidgets.scm (wxwidgets)[inputs]: Add shared-mime-info.
[arguments]: Update 'refer-to-inputs phase so wxWidgets looks in the correct
directory for MIME type information.
---
gnu/packages/wxwidgets.scm | 16 +++++++++++-----
1 file changed, 11 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 7141b2f4b8..f3a7fdd7a4 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
@@ -75,6 +76,7 @@
("mesa" ,mesa)
("webkitgtk" ,webkitgtk)
("sdl" ,sdl)
+ ("shared-mime-info" ,shared-mime-info)
("xdg-utils" ,xdg-utils)))
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -97,11 +99,15 @@
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'refer-to-inputs
- (lambda _
- (substitute* "src/unix/utilsx11.cpp"
- (("wxExecute\\(xdg_open \\+")
- (string-append "wxExecute(\"" (which "xdg-open") "\"")))
- #t)))))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((mime (string-append (assoc-ref inputs "shared-mime-info")
+ "/share/mime")))
+ (substitute* "src/unix/utilsx11.cpp"
+ (("wxExecute\\(xdg_open \\+")
+ (string-append "wxExecute(\"" (which "xdg-open") "\"")))
+ (substitute* "src/unix/mimetype.cpp"
+ (("/usr(/local)?/share/mime") mime))
+ #t))))))
(home-page "https://www.wxwidgets.org/")
(synopsis "Widget toolkit for creating graphical user interfaces")
(description
--
2.27.0
K
K
Kei Kebreau wrote on 16 Aug 2020 23:33
(address . 42625-done@debbugs.gnu.org)
87ft8m2s42.fsf@posteo.net
Pushed to master as commits e79fe4f675 and 93d9737d2b.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAl85pi0ACgkQ5qXuPBlG
eg1W/xAAqBE5NQVe3LKAy15JGuh2drtAJV0Gn3sGoYU8bfqS9Sb4r/pLcT0r7ADG
8Pu6xKkLX+X+EVFAGD6LUob28B2dywv0+yalNSgHyntXwMKEOjRCQFNrn12qhZ9t
E9wQsdr1l9K/e+c4DR+g19t/I7COfsgD/tAeABiwO2AJcAgNcUvKjdoU9I9BYszT
gPIMSKAJBOjTPkpvroabeHGyC1V4cU+eqmwoX8wTX5I3zyTS+DaP43e5BvBlszNC
vByylJIjoAN0vR+nwhR/jouu9wwHGQH52Nka4LZn+qCBtNw0HVG8jInEAzjEnaIB
JH2j4m7PM1wvou4khgNowcA6tRQMWJKv7O9AslPuOlveqK1gbEEB9lPQIVYZhT/r
DyFLWOT3C0O+C7tKCo+IUPeMMOOJXgsQu6lLvkts5NQtt+O1pLRftyZmVWppo8jO
y1NGKE9fp2y3LbweTfZPhbbd5LOIjzZy2hvpbVVk1HhyvqexyZIY6IXtu7lYlzoV
aKZxkP+DIaR6zvBaoANdMM336zRY7OooXCAX4MpAEMCnJ/IiVeJ+OSJta7Sac8mE
r1ESScIlS291DF3mXuInJnpNofkCtwe92tlBguX3vAzslJ5bHVXr6XfbxS2+Bc9D
OoI4DvyERm7fvq9Bzo5BvYGZLmRsB3PYA/RtZJ5KIqKr8vFrL1k=
=53Mw
-----END PGP SIGNATURE-----

Closed
?